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1 Using the Manual 
This manual is a reference manual; it describes and explains the 
functionality of the Raith software modules one by one. It is not 
intended as an operation manual (how to run the instrument.) An 
operation manual is provided separately. 

1.1 Conventions 
The following conventions are used throughout this manual: 

 

Hints are indicated this way. 

 

 

Warnings are indicated this way. 

 

Examples are formatted like this. 

STEP 1 ► Step-by-step explanations are indicated in this way … 

STEP 2 ► … as in the operation manual. 

Table 1: Text 
attributes used in this 
manual. 

Style used for 

Command Software elements, e.g. buttons, menu commands, 
input fields, etc. 

A Coordinates, e.g. of the stage X and Y. 

B Key, e.g. Control + B. A standard US-English 
keyboard layout is assumed. 

 Reference to another section or hyperlink to an 
external document, e.g. see section  Conventions. 

<…> Variable, e.g. <filename>  
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Table 2: Mouse 
conventions used in 
this manual. 

Action Intended meaning 

Click Quickly press and release the left mouse button. 

Double-click Click the left mouse button two times in rapid 
succession. 

Drag Hold down the left mouse button while moving the 
mouse. 

Drop Release the left mouse button after dragging. 
Point Move the mouse until the mouse pointer (cursor) 

rests on the item of choice.  

Following the common terminology of Windows, the terms select and 
choose have different meanings: 

• Selecting an item usually means marking it. Very often this is 
used in connection with check boxes or radio buttons. Selecting 
alone does not initiate an action. 

• Choosing an item usually carries out an action. For example, 
choosing a command from a menu or choosing a command button 
in a dialog box. 

1.2 Described functionality 
Please note, this manual describes all software features which are 
available within the comprehensive Raith software suite. Some Raith 
products are licensed for only a limited number of software modules 
so sometimes not all of the features described here are available in all 
products. Hence, depending on the product ordered, there might be 
differences between the installed software and functionality described 
here. 

1.3 Glossary 
The following terms are used throughout this manual: 
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Table 3: Glossary of 
terms used in this 
manual. 

Term Meaning 

Chipmap Two-dimensional graphical representation of 
a chip area on a Wafermap, used to navigate 
as well as to define exposure jobs. 

Imagescan Two-dimensional plot of detector intensity as 
a function of the position. 

Linescan One-dimensional plot of detector intensity as 
a function of the position. 

Positionlist List which stores various task to be executed 
one after another. 

Wafermap Two-dimensional graphical representation of 
a sample area or work space, used to navigate 
as well as to define exposure jobs.  
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2 Starting Raith program 
2.1 Login 11 

2.2 Changing password 12 

2.3 User management 12 

To start the Raith software, choose Start > Programs > Raith of the 
Windows operation system and then the name of the product, e.g., 
Quantum. Alternatively, the Raith software can be started by double 
clicking a related Icon placed on the Windows desktop. 

After starting the application the login screen appears. 

Figure 1: Login 
Screen of Raith 
program. Login for 
RAITH150 shown as 
an example. 

If the error message “Error 7: RAITH Hardlock/Licence not 
available” appears, please ensure that the hardlock protection key is 
connected on the USB port of the computer. 

2.1 Login 
Select a User name and type the corresponding Password to login. 
Additionally, an available Project can be selected. Projects are 
necessary for storing and recalling specific session settings like screen 
configuration, related files, etc. 
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If the entered password is correct, the buttons Options and Login 
become enabled. Then the user has the possibilities to change the 
password or to reset the user configuration. 

Choose Login to start the Raith application with selected project. 
Simultaneously, the application loads the same settings, like step size 
and dose, as used during the previous session. See section  User 
interface to learn how to utilize a project to load specified files (like 
GDSII designs, Positionlists, Images, or desktop arrangements, etc.) 
upon Login. 

Choose Cancel to interrupt the login procedure. 

2.2 Changing password 
To change the login password, choose Options > Change password, 
enter and retype the new password in the appropriate dialog box.  

To restore the “default” user settings, choose Options > Reset user 
configuration. This option deletes any user-specific settings, like step 
size and dose, of the current user. Other settings which are stored in 
separate databases, like microscope settings, write field alignment 
values, and scan type definitions are not deleted. 

2.3 User management 
Through use of the Security section on the control bar each user can 
be assigned to one of three login (or access) levels: USR (ordinary 
user), EXP (expert user), and SYS (system level user.) The ability to 
add a new user is available only for those with system level of access. 
By default the Administrator possesses this level. For all other login 
levels the access to this routine is denied. 
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Figure 2: Security to 
manage users. 

 

In addition to creating new users, the supervisor may delete users or 
modify their passwords, names, and levels. 

2.3.1 Edit menu 

User properties Choose this command or choose  or to change the attributes of a 
selected user. 

Create new user Choose this command or choose  to create a new user. 

After choosing User properties or Create new user the User 
Properties dialog will be opened to enter user-specific attributes. 
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Figure 3: Dialog 
User Properties to 
create or modify user 
attributes. 

 

To create/modify a user, enter the user's Name, select the Login level 
and define a password by choosing the Password button. This will 
create/rename a user account named after user’s name. It is also 
possible to have no password specified. 

Delete User Choose this command or choose  to delete a selected user. After 
applying, choose if all files and directories should be deleted too. 

2.3.2 Options menu 
The various program settings are stored within a file with the 
extension VDB, which means variables database. This setup file is 
simply referred to as the VDB file. There are two types of VDB files. 
One type retains each individual user’s settings and is commonly 
called the user VDB. The central or main program settings are stored 
separately, and this file is called the main VDB. To protect the main 
VDB it is possible to encode the VDB so that it can only be modified 
by use of the software dialog menus (i.e., encoded so that it is not 
possible to edit the file with a text editor program.) Normally, the 
main VDB should be kept encoded. For debugging purposes or if 
support from Raith is required it might be necessary to decode the 
VDB file before sending it. To decode the VDB file choose the menu 
command Options > Decoded variables database. To encode the 
main VDB afterwards again choose the related menu command 
Options > Encoded variables database. At the same time it is 
possible to use the related buttons. 

 

Please note that modifications of the settings in the main VDB can 
affect the performance and the ability to use the system. In addition, 
modifying the main VDB or leaving the main VDB unprotected, 
might result in hardware malfunction or damage requiring a costly 
service visit. 
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3 User interface 
3.1 Program desktop 15 

3.2 Keyboard shortcuts 20 

3.3 Drag and Drop concept 20 

3.4 Using projects for customizing 20 

The RAITH program uses standard Window controls with windows, 
icons and mice. For details of how to operate Windows we refer to the 
public available documentation. This chapter introduces the 
extensions used in RAITH program. 

3.1 Program desktop 
Figure 4: Main 
window of RAITH 
software suite. 

 

Title The title bar shows the name of the software and in brackets the 
currently user logged in as well as the currently loaded Project. 

Menus Depending on the active window, more or less menus are available. 
Standard Windows terminology is used. 

Please note, for all control settings the menus are shown in the 
corresponding section on the control bar. 

Iconbar The toolbar contains icons with some often used menu commands. 
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Desktop area Within the Desktop area the various documents of the RAITH 
software are displayed. 

• Document windows, e.g. Positionlists, Images, etc. Normally, 
several documents of the same kind can be opened. 

• UV windows, a subset of documents with a sample position for 
each position within the window. 

These windows are displayed as opened or minimized. To open a 
window, double click on the corresponding icon. To close, minimize, 
increase, etc. the standard Window controls are available. 

Up to four different Desktop areas build one Project. In detail, each 
Project contains for each Desktop the following information about … 

• the position of each window, 

• the documents loaded, 

• the behavior when opening another document, and 

• the overlay displayed in UV-documents. 

Control bar The control bar summarizes all controls to set up all parameters. The 
bar itself consists of several tabs. Parameters which are used together 
appear on one tab. For example the Adjustment tab contains the 
parameter set Adjust UVW, Stage control, Scan Manager, and 
Coordinates. Coordinates appears on all tabs. Besides Adjustment 
the following tabs are available: Design, Column Control, 
Microscope Control, Exposure, Stage Control, Automation, 
Administration, Loadlock, Gas Injection, Nanomanipulators and 
Service. Please note depending on the options not all tabs might be 
visible. 

 Choose this button to minimize or to restore the complete control bar. 

On the various tabs of the control bar the parameters are group into 
sections. Each parameter section has the following functions. 

  Choose one of these two buttons minimize and restore the 
corresponding parameter section 

 Choose this button to open a menu with additional functions and 
settings. Please note, for all document windows the menus are shown 
in the menu bar. 

 Choose this button to start the on-line help function for this section.  

Status bar The status bar summarizes a set of information in different status 
fields. 

• The left status field displays on-line help. Additionally, system 
messages, e.g. Motors stopped, Emergency Stop, etc., will appear. 
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• While moving the mouse inside a UV window, like an image, the 
stage coordinates XY, the sample coordinates UV, and the 
window coordinates are displayed in the following status fields. 

• On the right side a visual indication of program status is given. 
Double-click it to open the Module Status (see Figure 5) or use 
the right mouse button to a drop-down menu with additional 
commands. Following statuses are possible: 

Table 4: List of 
possible Module 
status.  

Status Meaning 

 
No occurrences of errors, 
warnings or info. 

 
Information, no influence on 
program run. 

 Something is not quite correct. 

 
Something went wrong, please 
check before continuing. 

 
Immediate interaction is 
required, please check as soon as 
possible.  

By double-clicking into the status field or selecting menu Module 
status a list of all currently loaded modules, their error status and last 
messages is displayed. 

Figure 5: Window 
Status Report. 

This menu comprises two applications: editing of variables and 
display of status messages. For this there are three functions available. 

Reset Module To reset the module, select the module's name first. 

Edit Variables To modify or to inspect module variables select the module's name. 
Select the variable's name and choose the Edit button or double-click 
on the variable's name. Drop down a list of values, if available, or 
enter the value manually. To make the changes valid, reset the 
corresponding value. 
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Clear Messages To clear all messages without resetting the modules. 

3.1.1 File menu 

Close 

Close all  Choose Close to close the active document. Choose Close all to close 
all document windows for the same kind as the active one. 

New image 

Open image… Generate a new Image respectively opens an existing one. A new 
Image is named NONAME#.SSC, # indicates consecutive numbering. 

Open linescan… Opens an existing Linescan. 

New positionlist 

Open positionlist… Generate a new Postionlist respectively opens an existing one. A new 
Positionlist is named NONAME#.PLS, # indicates consecutive 
numbering. 

New Wafermap 

Open Wafermap… Generate a new Wafermap respectively opens an existing one. A new 
Wafermap is named NONAME#.WLO, # indicates consecutive 
numbering. 

New Script 

Open Script… Generate a new Script respectively opens an existing one. A new 
Script is named NONAME#.JS, # indicates consecutive numbering. 

Exit Choose this command to exit the program session. 

3.1.2 Project menu 
New Choose this command to load the Project file NEW.DSK. 

Open Choose this command to open an existing Project file. 

Save Choose this command to save changes to a loaded Project. The Project 
will be saved under the same file name. 

Save as … Choose this command to save a loaded Project under a freely 
selectable file name. 

Desktop# Choose this command to activate one of the four available desktop 
configurations. # indicates the number of the desktop. 

Save desktop Choose this command to save a desktop configuration. After 
choosing, select the number of the related desktop. In addition, enter a 
suitable name for the desktop configuration. 
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3.1.3 Extras menu 
Module status Choose this command to get an overview over the status of each 

module. The functionality is as described in Table 4. 

Settings Choose this command to set and display various parameters of your 
system or software. 

3.1.4 Window menu 
Arrange icons All windows icons are arranged alphabetically. The opened windows 

are not influenced. 

Close all All opened windows are closed. 

Save settings … Opens dialog to set the behavior of documents when opening a 
document of the same kind, e.g. an image. 

A list of all windows The listing contains all available windows in alphabetical order. The 
activated window is indicated by a tick mark 

3.1.5 ? menu 
Index Opens the on-line help at the main topic. 

Module After activating the corresponding window, this command opens a 
context sensitive on-line help for this module. 

About In addition to the standard version information, it displays the 
currently logged in user and the used Project. 

3.1.6 Icon bar 
As menus the displayed icons depends on the active window. General 
available icons are … 

    Recall Project specific desktop configurations. Up to four different 
configurations are possible. The active desktop is highlighted. 

 Save the desktop configuration. After choosing, select the number of 
the related desktop. In addition, enter a suitable name for the desktop 
configuration. 

    Rotates the presentation for active UV-document each time the button 
is presses by 90° counterclockwise. 
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3.2 Keyboard shortcuts 
Generally, all commands are accessible by hitting the Alt key together 
with the key corresponding to the underlined character. See Windows 
documentation for how to change this behavior. The following 
shortcuts are available throughout the software … 

F1 Call up help. Specific help will be called up for the activated window. 

Crtl + 1…4 Recall desktop configuration 1…4. 

Crtl + 5 Save desktop configuration. 

Alt + x Exit the program session. 

3.3 Drag and Drop concept 
The concept of drag and drop operation is extensively used throughout 
the Raith software to ensure easy operation of rather complex tasks. It 
means that some objects, e.g. scan, can be picked up using the mouse 
and placed or dropped in another location on the screen. In those areas 
where dropping of the object makes no sense, this will be indicated by 
a no-parking sign type mouse cursor. After reaching a possible target, 
a realistic representation of the selected object appears. Dropping is 
just done by releasing the left mouse button and all required set-ups 
are handled by the system. 

3.4 Using projects for customizing 

3.4.1 Window position 
To store the position of a window: 

STEP 1 ► Choose , , , or  to switch to the desktop which should 
contain the window. 

STEP 2 ► Place the window on the desktop where it should appear in the future 
and adapt also its size. 

STEP 3 ► Choose the  Icon to open the Save Desktop dialog. 

STEP 4 ► Save these setting by clicking the OK button. Optionally, the Name 
for this Desktop can be changed before saving. 
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3.4.2 Document opening mode and overlay 
To store the mode used when opening a new window or the displayed 
overlay: 

STEP 1 ► Activate the corresponding document window. 

STEP 2 ► Choose from the Menus Windows > Save Settings … to open the 
Pane window. 

STEP 3 ► Select Display and an entry from the list to define what to overlay into 
this document window. 

STEP 4 ► Select Close so that the opened document will be closed before 
opening another document of the same kind. 

STEP 5 ► Select Tile so that all opened documents of the same kind will be tiled 
within the area of the firstly opened document. 

STEP 6 ► Optionally, Choose Delete to restore the default values.  

STEP 7 ► Accept the selection temporarily by pressing the OK button. 

STEP 8 ► Choose the  Icon to open the Save Desktop dialog. 

STEP 9 ► Save these setting by clicking the OK Button. 
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4 UV windows 
4.1 Menu commands 23 

4.2 Using the toolbox 26 

4.3 Mouse and keyboard commands 27 

UV windows are special windows where each point can be identified 
with a coordinate. Such windows are Images, Wafermaps, Chipmaps, 
GDSII viewer and GDSII editor. If the cursor is placed within a UV 
window the status bar indicates the corresponding coordinates. 

Figure 6: 
Coordinates of a UV 
window displayed in 
the program status 
bar. 

 

The U- and V-coordinates with the globe are the corresponding 
sample coordinates, The U- and V-coordinates with the window 
symbol are the corresponding coordinates relative to the window 
origin, and the X- and Y-coordinates are the corresponding stage 
coordinates. 

4.1 Menu commands 

4.1.1 Edit Menu 
Adjustment Choose this command to place the marks used for 3-point adjustment. 

To make the markers visible in the current UV window, choose View 
> UV display … > UV window properties > Show adjustment 
marker while desired UV window is open. 

Measure Choose this command to measure coordinates, distances, angles and 
areas, defined by two points within the UV window area. After 
choosing this command, set the points by two subsequent mouse 
clicks. The results are displayed in a message window. 

4.1.2 View menu 
Redraw Choose this command to redraw the viewed area. The command can 

be canceled by pressing the Esc key. 

Zoom A cascading menu opens with the following commands 
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Choose command All to display the complete area, which is covered 
by all of the structure elements. 

Choose command In 2x to magnify the displayed area by factor 2 
around the cursor position. Because the size of the magnified area is 
half as large as of the former area, corresponding width and height are 
reduced by factor square root of 2. 

Choose command Out 2x to reduce the displayed area by factor 2 
around the cursor position. Because the size of the reduced area is 
twice as large as of the former area, corresponding width and height 
are magnified by factor square root of 2. 

Choose command Last to restore the previous zoom status. 

Choose command Window to define the area to be viewed digitally. 
Either select the option Edges to enter the lower left and the upper 
right corner coordinates. Or select the option Anchor/Size to enter the 
anchor coordinates and the size of the area to be viewed. Select the 
anchor point in advance. Select Same aspect ratio to get the same 
scale un U- and V-direction. 

Choose command Write field to display the actually defined write 
field, i.e. the current location of the beam. 

Choose command Zoom in to magnify any portion of the viewed area. 
Two possibilities exist. After choosing the command, point to any 
location and press the left mouse button. This will zoom in to this 
location. Or point to any corner of the area to be magnified and click 
the left mouse button. While pressing the mouse button point to the 
opposite corner of that area and release the mouse button. 

Choose command Zoom out to increase the viewed area by pointing 
to any location and pressing the left mouse button. 

Choose command Hand to move the viewed area. 

 

In addition it is possible to zoom in and out using the wheel of a 
corresponding mouse. 

Overlays Choose this option to display the overlay elements like Positionlists, 
etc. 

Toolbox Choose this command to display the GDSII Tools add-on window. It 
will stay on top of all activated windows until it is closed. It provides 
symbol buttons which allows the user to have permanent and quick 
access too the most commonly used commands. 
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4.1.3 Options menu 
UV display… Choose this command to select items to be overlaid onto the actually 

displayed UV window. An additional dialog window opens with the 
following functionality 

Figure 7 Dialog UV 
display Options 
defining overlay 
windows and several 
properties. 

 

The list box Add-On windows shows all available overlay windows. 
Select those to be overlaid, by selecting it. 

Select the Origin or insertion point of the overlay window within on 
of the following coordinate system. 

• UV system: Origin of the sample coordinate system. 

• Window: origin of the window. 

• Window + Offset: Origin of the window with selectable offset. 

• Chip Center: Chip center in which stage is located. 

• Chip Lower Left: Lower left corner of chip in which stage is 
located. 

• Chip Center + Offset: Chip center in which stage is located with 
selectable offset. 

If one of the coordinate systems "… + Offset" is selected, enter in 
fields Offset U and Offset V the offset values for U and V axes. 

Window origin selects the origin of the window coordinate system. 
The window coordinates are displayed within the status bar of the 
program desktop. 

Select the Cursor type. If one selects Default, the current Windows 
cursor is used. 
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Select check box Show stage position to show the cross-shaped 
marker graphically indicating the actual location of the stage. 

Select the check box Show alignment marker to show the adjustment 
flags. 

Select the check box Enable drive command to enable stage 
movement using the mouse command Control + right mouse button. 

Same aspect ratio Choose this option to display the viewed area true to scale, e.g. a 
square is displayed as a square and not as a rectangle. A check mark 
shows whether this option is in effect or not. To remove the check 
mark, choose this option once again. 

4.2 Using the toolbox 
For a fast access to the often used commands it is possible to open an 
add-on window by choosing View > Toolbox. 

Figure 8: Add-on 
window Tools for all 
UV windows. 

 

The general commands for viewing, measuring, zooming, and placing 
flags are described in the following. 

 Selects normal cursor. 

 Selects a frame selection mode. 

 Command View > Zoom > Hand. 

 Command Edit > Measure. 
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 Command View > Zoom > Zoom in. 

 Command View > Zoom > Zoom out. 

 Command View > Zoom > In 2x. 

 Command View > Zoom > Out 2x. 

 Command View > Zoom > All. 

 Command View > Zoom > Write field. 

 Command View > Zoom > Last. 

   Command Edit > Adjustment > Set mark. 

4.3 Mouse and keyboard commands 
The following tables give a summary of all available mouse and 
keyboard commands within all UV windows. 

Table 5: Mouse 
commands in all UV 
windows. 

Action Key(s) + Mouse Button Functionality 

Single 
click none + right Opens menu with often 

used commands. 

Single 
click Ctrl + right Drive to location. 

Single 
click Ctrl + left Move selected object to 

new position. 

Single 
click Shift + left 

Select elements within an 
area defined by second 
mouse clicks. 
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Table 6: Keyboard 
shortcuts available in 
all UV windows. 

Key Functionality 

+ to zoom in by a factor of 2 

- to zoom out by a factor of 2 

= to view all 

e to measure dimensions in editor or viewer 

h to move viewed area 

t to open toolbox , toggle mode 

z to zoom in and out, toggle mode 

Shift +  to scroll the display into direction of arrow 

Alt + o to show overlays, toggle mode 
Alt + r to redraw the display 
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5 GDSII data handling 
5.1 GDSII database 29 

5.2 GDSII editor and viewer 48 

5.3 Working with layers 74 

5.4 Using working areas 77 

5.5 Using the toolbox 77 

5.6 Mouse and keyboard commands 79 

5.7 Drag and drop 83 

GDSII data handling is done by means of three components. 

Database Layout data are organized in a hierarchical GDSII database. All 
standard GDSII design files from external CAD stations can be 
directly used. 

Editor The editor can be used to design or modify GDSII structures. It 
operates with absolute coordinates and offers a design resolution of 
one nanometer. Editor operations are only possible in one active 
editor. 

Viewer Within the viewer it is possible to represent and inspect all hierarchy 
levels graphically. 

5.1 GDSII database 
To enable handling of even extended GDSII files on a PC based data 
system, the hierarchical structure of the data is kept as long as 
possible, e.g. until final exposure. Externally created GDSII files can 
be handled as well as data files from other design systems. In 
particular, this module offers the following filters. 

• DXF import filter for import of patterns from most common CAD 
programs, e.g. AutoCAD, DesignCAD, etc, 

• ELM import filter for import of data files from RAITH PROXY 
and PROXY-WRITER, 

• ASC import and export filter for reading and saving of ASCII-
type data files, and 

• CIF import filter for import of data files stored in Caltech 
Intermediate Format by California Institute of Technology. 
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After importing, all data will be handled and stored in GDSII formats. 
Hierarchy information will be automatically scanned and stored in a 
separate file with extension *.HIR. 

The database within the RAITH software supports all standard GDSII 
features. However, internally it is extended by a range of new 
definitions such as text strings or single pixel lines, dose assignments, 
etc. This means, loading a structure with these definitions into an 
external GDSII editor, the additional features will not be available. In 
addition, the field "Data Type" which is available for each element 
and is defined within the GDSII format is used for assigning a doses 
factor to each element. 

The RAITH software allows only one single database to be open at a 
time. If one wants to transfer patterns or structures between different 
databases, use the Windows clipboard or use the commands ASCII 
import and export. 

Normally not the whole GDSII structure is of interest for example to 
inspect it or to expose it. To expose only a fraction of the whole 
GDSII structure it is possible to define several areas of interest so 
called working areas. These working areas are defined for each 
structure individually and are stored together with the GDSII database. 

5.1.1 GDSII database control 
The GDSII Database control shows the name of the opened database 
file in the title bar and a list of all included structures in a tree view. 
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Figure 9: Database 
control for GDSII 
handling. 

 

Within the tree view the following elements appear … 

 Main structure which is not referenced within any other structure 

 Single structure which is referenced within another structure 

 Single structure referenced in main structure tree 

 Area structure referenced in main structure tree 

  Structure hold in computer memory 
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  Structure opened in viewer or editor 

In addition the following two buttons are available … 

Edit Choose to open the selected structure for editing. 

View Choose to open the selected structure for viewing. 

For further operations, e.g. viewing, editing, deleting, any structure 
may be selected by the mouse. The selected structure will be 
highlighted and given in the input field. This input field works also as 
a search box assisting selection of structures. Type in the first 
characters of the structure name and the matching structure will be 
selected automatically. 

If the GDSII Database control is activated, additional menus and 
menu items are available within the menu bar, which will be explained 
in detail in the following sections. Clicking the right mouse button 
anywhere within the list area of the GDSII Database control, a 
shortcut menu will pop up. 

5.1.2 File menu 
New… Choose this command to create an empty GDSII database file. 

Standard extensions are *.CSF for Calma Stream Format and *.GDS. 

Open… Choose this command to open an existing GDSII database file. A file 
selector box shows all existing GDSII database files of the actual path. 
Choose the GDSII database to be worked on. Within the control 
GDSII database the complete hierarchy and set of structures will be 
displayed. To display the GDSII in such a way, a build of the 
hierarchy file will be performed automatically, if the database is 
opened for the first time. 

RAITH supports the GDS-II™ Calma Stream Format. However, there 
are occasions when we cannot import a GDS-II file. This is due to 
third party applications not conforming to the standard or storing the 
file in an internal binary format. Documentation for the third party 
program should be checked first, if one is having problems importing 
a GDSII file. The definition of the GDS-II format can be found at 
numerous WWW sites. 

Save as… Choose this command to store the currently opened database file 
under a freely selectable name. 

Build Hierarchy Choose this command to scan the hierarchical structure of the opened 
database and to create a corresponding hierarchy file (*.HIR). 

Properties… Choose to display a window with some statistical information and 
general information about the structure. 
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5.1.3 Edit menu 
View Choose to open the viewer window which is used for inspection 

purposes, especially to resolve hierarchical structures. To modify a 
structure, use the editor window. 

Edit Choose to open the internal GDSII editor. The editor window is used 
to design new structures and to modify existing structures. It includes 
the functionality of the viewer window. 

Delete… Choose this command to delete the selected structure. Only structures 
that are not referenced within any other structure can be deleted. 

Duplicate… Choose this command to make a copy of the selected structure within 
the same database. The copy will be named Copy_of_<name> 
automatically, where <name> is the name of the original structure. 

Rename Choose this command to change the name of a structure. 

Properties… Choose this command to display information of the currently selected 
structure. The information includes the size, the number of referenced 
structures, rectangles, boundaries, SREF = structure references, AREF 
= area references and paths. In addition, the used layers are indicated. 

New… Choose this command to create a new structure. After assigning a 
structure name, the editor will be opened automatically. 

Copy Choose this command to copy the selected structure to the clipboard. 
Afterwards it can be pasted within another database by choosing the 
command Edit > Paste. 

Paste Choose this command to paste the copied structure within a database. 

Clear clipboard Choose this command to clear the clipboard. and to free the memory 
after storing large structures in the clipboard. 

Load *.ELM See  section Loading files in ASCII format for details. 

Load *.ASC See  section Loading files in ASCII format for details. 

Save *.ASC See  section Saving files in ASCII format for details. 

Load *.DXF See  section Loading files in DXF format for details. 

Load *.CIF See  section Loading files in CIF format for details. 

Loading files in ASCII format 

It is possible to import elements into a GDSII database using a file in 
ASCII format as a source. Thus these filters are ideal to import self-
created structures, e.g. by means of calculation programs. The 
commands are Load *.ELM and Load *.ASC. The main difference 
between the two commands Load *.ELM and Load *.ASC is the 
handling of negative signs. While the ELM import filter erases all 
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negative signs, the ASC import filter leaves them as they are. The 
reason for this is the internal handling of negative signs by PROXY-
WRITER software within the ELM format. A negative sign 
characterizes within this software hidden lines. So, if structure 
elements are located in any but the first quadrant of the GDSII design 
coordinate system, the ASC import filter has to be used instead of the 
ELM import filter. 

Any standard editor or program, which is able to save data as ASCII 
text, may be used. Within current GDSII database there is a structure 
named <filename>.asc or <filename>.elm respectively after loading. 

The file format for the two import filter is defined as follows. Each 
element starts with a character defining the type of GDSII element 
followed by several parameters separated by space. The following 
table lists available GDSII elements and the corresponding character. 

Table 7: List of 
available elements. GDSII element Character name in GDSII programs from 

other vendors 

box or polygon 1 BOUNDARY 

arc A not available 

circle C not available 

ellipse E not available 

path L PATH 
point P PATH, start point = end point 
text T not available 

The syntax for the different elements and their parameters is as 
follows using the general rules that µm is the base unit for all length, 
width, etc., degree the base unit for all angles, and the dose is given in 
percentage. 

Table 8: Syntax of 
GDSII elements in  

GDSII 
element 

Syntax Comment 

polygon 1 <dose> <layer>  

 <u1> <v1> coordinates 1st point 

 <u2> <v2> coordinates 2nd point 

 …  

 <u1> <v1> must be repeated 

 # end of element 

arc A <dose> <layer> [<width>] not filled, width usage 

 <u-center> <v-center> center coordinates 
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 <radius> [<radius2>] 2nd radius for ellipse 

 <vertices>  

 <rotation> <angle1> <angle2> angles defining arc 
 #  
circle C <dose> <layer> [<width>] not filled, width usage 

 <u-center> <v-center> center coordinates 

 <radius>  

 <vertices>  

 <rotation>  

 #  
ellipse E <dose> <layer> [<width>] not filled, width usage 

 <u-center> <v-center> center coordinates 

 <radius> <radius2>  

 <vertices>  

 <rotation>  

 #  
path L <dose> <layer> <width>  
 <u-center> <v-center> coordinates 1st point 
 <u-center> <v-center> coordinates 2nd point 
 …  
 #  
point P <dose> <layer> <width> with w/o meaning 
 <u-center> <v-center> coordinates point 
 #  
text T <dose> <layer> <width>  
 <u-center> <v-center> coordinates start point 
 <height> <angle>  
 <u-align> <v-align> alignment values 0 to 2 
 <text> text itself 

 

The following example contains four elements. All elements are 
assigned with 100% dose in four different layers. 

1 100.0 0 
-5.000 5.000 
-5.000 -5.000 
5.000 -5.000 
5.000 5.000 
-5.000 5.000 
# 
L 100.0 1 1 
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0.000 -7.000 
3.000 -10.000 
7.000 -10.000 
10.000 -7.000 
# 
C 100.0 2 0.200 
10.000 10.000 
5.000 
100 
90.000 
# 
T 100.0 3 0.000 
3.000 3.000 
1.000 0.000 
2 2 
Example 
# 

Saving files in ASCII format 

This export filter enables the exporting of a selected structure into an 
ASCII file format. Hierarchy will be made flat. Structure modification 
has to be done by means of the GDSII editor before exporting. Import 
and export of ASCII files offer the capability to copy flat designs 
within one database or to transfer them into other databases. 

Loading files in DXF format 

Import filter for CAD files in DXF file format, e.g. made by means of 
AutoCAD, DesignCAD, etc. The imported data are stored within 
structure filename_DXF in the current GDSII database. 

When choosing this import filter a dialog is opened where several 
parameters can be set to control the import process. For example, if 
the CAD file contains several layer definitions, these may be assigned 
to different GDSII layers. In addition the settings under Options, e.g. 
dose factor etc., can vary for each DXF layer. 
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Figure 10: Dialog 
DXF import options 
used during import of 
AutoCAD files. 

 

Keep AutoCAD hierarchy Hierarchy is kept, if this check box option is selected. 
Otherwise the imported structure is made flat. 

Layer This list box contains the names of those CAD layers, import Options 
have been defined for. For each layer one can set different pattern 
conversion Options individually. To add a CAD layer name to the list 
box, choose the New button. To remove a CAD layer name from the 
list box, select it, and then choose the Delete button. 

GDSII Layer Enter the GDSII destination layer for all elements of the selected CAD 
layer. 

Dose Factor Enter the common dose for all elements of the selected CAD layer 
with 1.000 = 100% of clearing dose. 

Fill Circles Circles are imported as filled polygons, if this check box option is 
selected. Otherwise they are imported as lines, i.e. borders only. 

Lines to Polygons Polylines within the DXF format are converted into filled polygons, if 
this check box option is selected. Otherwise they are handled as lines, 
e.g. borders only. 

Single Pixel Lines The width of all imported lines is set to 0, if this check box option is 
selected. Otherwise the width is set to the line width defined in the 
Line width text box. 

Line Width Enter the line width, valid for all lines, which have no line width 
definition in the DXF format. If line width is included in the CAD 
definition, this parameter is not applied. If Single Pixel Lines are 
selected, this text box is disabled and all imported lines are set to 0. 

If the size of the imported structure does not meet the original CAD-
structure size, one has to change the value of the variable Module 
status > Import DXF Files > Scale factor. For example: 

Original size = 200 µm 
Imported size = 200 nm 
Set scale factor = 1000 
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The DXF file definition is a comprehensive standard for 2D and 3D 
graphical drawings. Each new release adds additional features to the 
definition. The current release DXFTM 2004 has over 1000 tag ID’s. 
Because the RAITH software supports only the relevant sub set of the 
DXF standard, one may occasionally come across features, which are 
not supported. Therefore it is highly recommend to keep too the 
standard elements listed in the following. 

  

Table 9: Available 
DXF sections. 

DXF section  

HEADER Will be ignored. 

TABLES Will be ignored. 

BLOCKS See section  section DXF Import features.  
ENTITIES Will be ignored.  

 

Table 10: Available 
hierarchical DXF 
elements. 

Hierarchical  
DXF element is converted to GDSII element 

LINE PATH with 2 points 

CIRCLE 

BOUNDARY with 50 points  
- Filled circle, if check box option Fill circles is 
selected  
- Circle ring, if check box Fill circles is cleared 

ARC BOUNDARY with 50 points as circle arch 

SOLID BOUNDARY with 4 points 

INSERT SREF leaving hierarchy 
AREF leaving hierarchy and multi insert  

 

Table 11: Available 
flat DXF elements. 

Flat DXF 
element is converted to GDSII element 

POLYLINE 

BOUNDARY 
polygon, if check box option Lines to Polygons 
is selected, open paths will be closed 
automatically 
PATH 
if check box Lines to Polygons is cleared 

VERTEX belongs to POLYLINE 

SEQUEND belongs to POLYLINE 
LAYER DATATYPE via dose class file LAYER.DOS  
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DXF Import Features 

During conversions, additional structures maybe added into the GDSII 
database. 

*model_space, *paper_space, *paper_space0: These are internal 
definitions in a DXF BLOCKS section. They can be safely ignored 
and deleted. They will however cause a warning message of an illegal 
character for the structure name. The DXF name is *model_space, 
however the GDSII standard allows only: 

 “A” through “Z”, “a” through “z”, and 0 through 9 and the special 
characters Underscore “_”, Question mark “?”, Dollar sign “$” 

Therefore, the “*” is an illegal character. The Raith software simply 
replaces the “*” with a “_” and issues a warning renaming the 
structures as: 

_model_space, _paper_space, _paper_space0. 

The DXF reference manual can be obtained from Autodesk Inc. 

Loading files in CIF format 

Import filter for data files stored in Caltech Intermediate Format by 
California Institute of Technology. The hierarchy of CIF files is equal 
to the GDSII hierarchy and will be kept during import. Supported data 
types for CIF import are listed in the following. 

Table 12: Available 
elements in Caltech 
Intermediate Format. 

CIF element converted to GDSII element 

B BOX 

P BOUNDARY 

9 STRUCTURENAME 

C SREF 

R0 STRANS with angle 90° 

L LAYER 
(* … *) comment  

Dose values are related via dose classes (file LAYER.DOS) - the same 
procedure as for import of DXF files. A (symbolic) layer name is 
assigned via the file CIF.INI (see example below). 

[LAYER] 
TLEN=1 
META=2 
BND=31 
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5.1.4 Tools menu 
Overlap removal Choose this command to cut all overlapping elements within the 

selected structure. The overlap removal command checks, if there are 
overlapping elements. If so, then one of the two elements will be cut 
to size so that it just contacts the other one. This command is not 
removing overlaps within different structure references. 

Field of Application: To avoid an over exposure of overlapping 
elements. 

Removing overlaps 

Figure 11: Before 
overlap removal. 

 

 

 

The command Overlaps removal overwrites the original structure. 
Therefore, we recommend working on a copy. 

STEP 1 ► Select a structure from GDSII database and choose then Tools > 
Overlap removal. A dialog provides then additional parameters to 
control this tool. Within the dialog the selected structure is indicated at 
the top. 

Figure 12: Dialog 
Overlap Removal. 

 

STEP 2 ► Select layers separated by comma to which the function should be 
applied by editing Use layer. The Overlap removal toll will remove 
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overlapping areas of all elements of the same layer. Therefore it is not 
possible to remove overlaps between two different layers. 

STEP 3 ► By selecting the check box Use all layers, the overlap removal will be 
applied all layers, not depending on a given layer. 

STEP 4 ► By selecting the Backup GDSII file check box, the overlap removal 
creates a backup. 

STEP 5 ► Choose OK to execute the tool. 

Figure 13: After 
overlaps removal. 

 

Layer removal Choose this command to delete complete layers. 

 

Layer removal overwrites the original structure. Therefore, we 
recommend working on a copy. 

Sort elements Choose this command to change the order of all elements within the 
selected structure. This command is not sorting within different 
structure references. 

Field of Application: To optimize a design for the exposure step. 
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Sorting elements 

Figure 14: Before 
sorting elements by 
location. 

 

 

 

The command Sort elements overwrites the original structure. 
Therefore, we recommend working on a copy. 

STEP 1 ► Select a structure from GDSII database and choose then Tools > Sort 
elements. A dialog provides then additional parameters to control this 
tool. Within the dialog the selected structure is indicated at the top. 

Figure 15: Dialog 
Sort elements. 

 

STEP 2 ► Select Sort by layer to sort elements layer by layer successively. This 
makes it easier to sort elements within a certain layer manually by 
using the editor command "Modify / Order". The result can be, for 
example, 

Layer 0: elements #1 - #4 
Layer 1: elements #5 - #15 
Layer 2: elements #16 - #158 

STEP 3 ► Select Sort by location to sort all elements independently of the layer 
so that the jump distance from element to element during exposure is 
minimized automatically. 

STEP 4 ► Choose OK to apply tool. 
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Figure 16: After 
sorting elements by 
locations. 

 

Unify structures Choose this command to resolve all references within the selected 
structure i.e. to get one large flat structure. The result is stored in a 
new GDSII database. 

Field of Application: Not all GDSII programs from another vendors 
support hierarchical files. Use this command to import GDSII files 
edited on RAITH program into those programs. 

Removing GDSII hierarchy 

Figure 17: Before 
unifying shown with 
hierarchy level 0. 

 

STEP 1 ► Select a hierarchical structure from GDSII database and choose then 
Tools > Unify structures. A dialog provides then additional parameters 
to control this tool. Within the dialog the selected structure is 
indicated at the top. 

Figure 18: Dialog 
Unify structure. 
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STEP 2 ► Select New layer to store the result in another layer and specify the 
layer in Layer No. 

STEP 3 ► Choose OK to apply tool. 

Figure 19: After 
unifying shown with 
hierarchy level 0. 

 

Convert userdefs Choose this command to convert RAITH specific user defined 
elements to common CAD elements. Most of the CAD systems use 
different definitions to store special elements like "Text", "Curves", 
"Circles", etc. In addition, the dose information, e.g. as dose factor to 
scale the exposure time, may be stored in different ways. To become 
compatible with common CAD systems, it is necessary to create a 
general GDSII format. The Convert userdefs tool converts all 
RAITH specific elements, e.g. text, circles, into polygons or open 
paths. In addition, the dose information can be removed. All changes 
are done in the same GDSII file. 

Converting to standard GDSII 

 

The command Convert userdefs overwrites the original structure. 
Therefore, we recommend working on a copy. 

STEP 1 ► Select a structure from GDSII database and choose then Tools > 
Convert userdefs. A dialog provides then additional parameters to 
control this tool. Choose All structures to convert the complete 
GDSII database. 
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Figure 20: Dialog 
Convert Userdef 
Elements. 

 

STEP 2 ► Select keep dose factor to preserve the dose factor. O otherwise the 
dose factor will be set to 0.001 so that the number 1 is stored in the 
GDSII file, which will be ignored by other CAD systems. 

STEP 3 ► Choose OK to apply tool. 

Merge elements Choose this command to remove gaps between elements. This 
command is not merging elements within different structure 
references. 

Merging GDSII elements 

Figure 21: Before 
using merge 
functionality. 

 

 

 

Merge elements overwrites the original structure. Therefore, we 
recommend working on a copy. This tool is applied to elements of the 
same layer. Gaps between elements of different layers would not be 
removed. 

STEP 1 ► Select a structure from GDSII database and choose Tools > Merge 
elements. A dialog provides then additional parameters to control this 
tool. Within the dialog the selected structure is indicated at the top. 
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Figure 22: Dialog 
Merge elements. 

 

STEP 2 ► Type in a Critical dimension to merge elements, if the distance 
between them is the same or less than the entered value. 

STEP 3 ► Select Join together to merge elements, i.e. the elements will not only 
be combined visually but they will also become one single GDSII 
element. 

STEP 4 ► Select the Check dose to merge only elements which have a dose 
difference of less than the entered value. 

STEP 5 ► Choose OK to apply tool. 

Figure 23: After 
using merge 
functionality without 
joining them together. 

 

Join sorted elements Choose this command to join in the minimum two GDSII elements to 
one larger GDSII element. For this the elements have to be sorted by 
location. 

Joining GDSII elements together 

 

Join sorted elements overwrites the original structure. Therefore, we 
recommend working on a copy. This tool is applied to elements of the 
same layer. Gaps between elements of different layers would not be 
removed. 
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STEP 1 ► Selected a structure from the GDSII database after sorting the 
elements (see  section Sorting Elements. Then choose Tools > Join 
sorted elements. A dialog provides then additional parameters to 
control this tool. Within the dialog the selected structure is indicated at 
the top. 

Figure 24 Dialog 
Merge elements. 

 

STEP 2 ► Select the Check dose to join only elements which have a dose 
difference of less than the entered value. 

STEP 3 ► Select Only hori. boxes to join boxes along u-direction only. 

STEP 4 ► Choose OK to apply tool. 

Boolean operations 

 

Boolean operations overwrite the original structure, if Backup 
database has not been selected. Therefore, we recommend working on 
a copy or to use this function. 

It is possible to perform Boolean operations between elements on 
different layers for the whole structure. 

Select between the operations A or B, A and B, A sub B, and A xor 
B. Then select the used layer as well as the target layer for the result. 
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Figure 25: Result of 
Boolean operations 
on GDSII elements in 
different layer. 
Elements 1, 2, 3 are 
one layer whereas 4 is 
on a different layer. 

Operation Elements Result 

A and B 

 

 

A or B 

  

A sub B 

  

A xor B 

   

 

5.1.5 Right mouse menu commands 
The commands of the right mouse menu are mainly listed under menu 
Edit. There is only one additional command. 

Sort structures An additional drop-down menu appears. Choose here to define the 
order of the display in the tree view. Three options are available by 
type and name, by name and by file order. 

5.2 GDSII editor and viewer 
GDSII editor and viewer cannot be opened at the same time, i.e. when 
opening the editor the viewer is closed automatically and vice versa. 
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But it is possible to open more than one viewer window at the same 
time. 

Figure 26: Editor 
window showing 
elements building 
transistors. 

 

Both editor and viewer windows are headed by an information and 
icon bar. 

• The actual U and V positions of the design cursor within the 
design field. Values are given in micrometer with a resolution of 1 
nm. 

• The number of the layer currently activated for editing (editor 
only). To change the layer for editing, click the layer indicator to 
open corresponding dialog. 

• The currently used design grid. Within the editor the design grid 
defines a grid, which is used to place elements. To change its step 
size, click the step size indicator to open corresponding dialog. 
Minimum step size is 0.001 µm, i.e. 1 nm, maximum step size is 
100 µm. 

• The currently active command. 

• Additional information, e.g. rotation angle, are displayed when 
using specific commands. 

• To open the toolbox click toolbox icon . 
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• To choose the displayed layers click the layer icon . 

• To edit the working areas for this GDSII click the working area 
icon . 

5.2.1 File menu 
Please note, in the following an (E) or a (V) indicates that this 
command is available only in the editor or in the viewer respectively. 

Save (E) Choose this command to save the current structure without leaving the 
editor. 

Save and Close (E) Choose this command to leave the editor with automatically saving 
the current structure. If changes have been made in referenced 
structures the hierarchy information of the database will be 
automatically scanned and updated. 

Print… Choose this command to print out the actually viewed area of the 
viewer or the editor. 

Save viewer Image as… (V) Choose this command to store the actually viewed area in 
Tagged Image File Format, i.e. as a TIFF file, or in Bitmap format, i.e. 
as a BMP file. 

5.2.2 Edit menu 
Please note, that the following commands are available within the 
editor window only. 

Undo, Redo Choose these commands to undo or redo the last action. Internally a 
list of all changes is managed meaning that the number of actions 
stored is limited only by memory. 

Cut Choose this command to cut out the selected elements and copy them 
into the Microsoft Windows clipboard for further usage, especially to 
paste them into another structure or database. 

Copy Choose this command to copy the selected elements into the Microsoft 
Windows clipboard for further usage, especially to paste them into 
another structure or database. 

Paste Choose this command to paste the elements actually located in the 
Microsoft Windows clipboard into the actually opened structure. 

Delete Choose this command to delete the selected elements without further 
query. 

Select The selection of at least one element within a structure is necessary for 
most of the "Edit" commands. All currently selected elements are 
characterized by having yellow points at the corners. The number of 
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selected elements will be displayed in the status bar on bottom of the 
Program Desktop. After choosing the "Select" command, a cascading 
menu appears offering additional functionality. 

Choose command All to select all elements of the structure 
irrespective of their layer assignments. 

Choose command Dose factor… to select elements within the 
specified range of dose factors. 

Choose command In to select all elements within the active layer 
located inside a box to be dragged. After choosing the command, 
point to any corner of the area covering all elements to be selected and 
click the left mouse button. Then point to the opposite corner of that 
area and click the left mouse button again. Pressing the Shift key 
while doing so, the first point defines the center and not the first 
corner of the rectangle. Pressing the Control key while doing so, the 
field of selection will become quadratic. 

 

As a shortcut, do not choose this command, but point directly to any 
corner of the area covering all elements to be selected, press and hold 
the Shift key and click the left mouse button. Then proceed as 
described. 

Choose command Layer to select all elements within the active layer. 

Choose command New to select all elements within the active layer, 
which have been added after saving respectively after opening the 
editor window. 

Choose command Next to select the next element within the active 
layer of the structure. The sequence for selecting next elements is the 
sequence of these elements in the design. Operation is cyclic. Starting 
element is the last element that has been selected before choosing this 
command. 

Choose command Previous to select the previous element within the 
active layer of the structure. The sequence for selecting previous 
elements is the inverse sequence of these elements in the design. 
Operation is cyclic. Starting element is the last element that has been 
selected before choosing this command. 

A Structure reference can be selected by one of the following three 
selection modes. All structures are selected. At selects all structures, 
which cover the point defined by a subsequent mouse click. In selects 
all structures, which are located inside a box to be dragged. 

Structure reference by name Choose this command to select structure references 
specified by the name of a referenced structure. After choosing one of 
the cascading commands All, At or In, a structure can be specified by 
means of a dialog box, showing all existing structures. If command 
All has been chosen, all structure references containing the specified 
structure are selected. If command At has been chosen, a structure 
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reference containing the specified structure is selected by a subsequent 
mouse click. If command In has been chosen, all structure references 
containing the specified structure are selected by a box to be dragged. 

Unselect Consists of the same set of commands as the Select command. The 
target is remove element’s selection for desired elements or 
substructures. 

Adjustment Command common to all UV windows, described in section  UV 
Windows. 

Measure Command common to all UV windows, described in section  UV 
Windows. 

5.2.3 View menu 
Hierarchy Choose this command to resolve hierarchy levels of the opened GDSII 

structure. After choosing this command, a drop-down menu appears 
offering additional commands. A check mark indicates the resolved 
hierarchy level. 

Choose command Increase to increase the hierarchy by one level. 

Choose command Decrease to decrease the hierarchy by one level. 

Cooose one of the comannds 0 – 8 to resolve the hierarchy to the 
specified level, where 0 is the highest level. 

Choose command Auto to resolve the hierarchy as a function of the 
current viewed area. 

Choose command Max to always resolve to the highest hierarchy 
level. 

Sometimes, maximum hierarchy level may contain so many elements 
that it would take minutes to build up the entire structure. In this case 
one may cancel this operation by cancel the redraw which can easily 
be achieved by pressing the Esc key. 

Redraw Command common to all UV windows, described in section  UV 
Windows. 

Zoom A cascading menu opens with additional commands, described in 
section  UV Windows. 

Choose command Active Working area to display the currently 
defined working area. 

Design grid Choose this option to display the design grid as small light gray dots, 
which are related to the actually chosen cursor step size. Creation of 
new elements or modification of elements is possible only within this 
design grid, irrespectively whether it is displayed or not. Depending 
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on the relation between displayed area and chosen step size, it may 
happen that not all of the grid dots will be displayed. 

Exposure grid Choose this option to display the exposure grid, i.e. the division of the 
active working area into stitch fields. Note this option is only available 
when having corresponding license. 

Working area Choose this option to display the active working area, i.e. the 
rectangle used for exposure. 

Layer selection Choose this command to display the layer selection add-on window. It 
will stay on top of all activated windows until it is closed. It allows the 
selection of layers to be displayed. 

Overlays Command common to all UV windows, described in section  UV 
Windows. 

Toolbox Command common to all UV windows, described in section  UV 
Windows. 

Working area editor Choose this command to display the GDSII Working area add-on 
window. It will stay on top of all activated windows until it is closed 
and manages a series of defined working areas for the design. 

5.2.4 Options menu 
Please note, in the following an (E) or a (V) indicates that this 
command is available only in the editor or in the viewer respectively. 

Background Choose this command to set the background gray level. A check mark 
indicates the currently selected gray level. 

Backside view (V) Choose this option to mirror the layout horizontally and to display the 
layers in reverse order. This becomes necessary, if the sample is 
viewed from the bottom side. 

Fill Choose this option to indicate filled structure elements, i.e. boxes, 
polygons, etc. A check mark shows whether this option is in effect or 
not. To remove the check mark, choose this option once again. If this 
option is not in effect, elements are indicated by frame, only. The fill 
color can be defined for each layer individually. 

If an element is covered completely by another element, it is no longer 
visible after choosing the option. To overcome this effect, set the 
variable Module status > GDSII Database > Solid Fill to "OFF". 
After closing and opening the editor or viewer window once again, 
choose Fill. Hatching will now indicate the filled structure elements. 

Physical layer order Choose this command to display the different layers in their physical 
order meaning layers which are deeper are displayed first. The layer 
order is defined in the Layer editor. 



5 GDSII data handling 

54 

Same aspect ratio Command is common to all UV windows, described in section  UV 
Windows. 

Layer editor… Choose this command to open an additional dialog to assign name, fill 
color, border color and pattern to each layer individually. 

Show dose Choose this option to fill the elements with a color indicating the dose 
factor. The layer assignment is indicated by the corresponding frame 
colors. 

Dose colors Choose this command to define the color assignment of the dose scale. 
This command is only available, if the dose distribution is displayed. 
The relation between colors and dose scale can be defined by editing 
the related text boxes. Use the pipette icon to insert dose values from 
the design into the dose range. 

Show video Choose this option to show the currently opened images 
simultaneously with the GDSII structure. In order to show the entire 
background image, the viewer / editor area coordinates (command: 
"View / Window") have to be fit to the image coordinates. 

UV display… Command is common to all UV windows, described in section  UV 
Windows. 

5.2.5 Annotate menu 
The complete menu is available only in the viewer but not in the 
editor. The items within this menu serve to add and handle comments 
and markers. They are stored within a separate file and do not 
influence the related GDSII database file. 

Show annotations Choose this option to activate the annotation functionality. After 
choosing the annotation location is indicated by a red triangle. 

Text Choose this command to create an annotation text. After choosing the 
command, move the mouse to the point of interest and click the left 
mouse button or press the space bar opening a dialog box with 
additional options. Use text boxes Position U/V to define the 
coordinates of the annotation location. Use Creation angle to enter 
the angle for rotating the annotation location around the coordinate 
origin (U/V = 0/0). To modify a text annotation, click on this red 
triangle, and a dialog will be opened. To delete an annotation, select it 
by clicking on the red triangle and press Del key. 

Rectangle Choose this command to create an annotation box. After choosing the 
command, point to any corner of the area to be annotated and click the 
left mouse button or press the space bar. Then point to the opposite 
corner of that area, a rectangular frame will be drawn, and click the 
left mouse button again or press the space bar. Pressing the Shift key 
while dragging, the first point defines the center and not the first 
corner of the rectangle. Pressing the Control key the rectangle will 
become quadratic. To modify an annotation rectangle double click it 
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and a dialog box appears offering additional options. The functionality 
of Position U/V and Creation angle are the same as for Text 
command. 

Ellipse Choose this command to create an annotation ellipse. Handling is 
similar to Annotation > Box. 

Move Choose this command to move the selected annotations. The 
movement vector has to be defined by two subsequent mouse clicks: 
first mouse click defines the start point of movement vector; second 
click defines the end point of movement vector. For digital control, 
the resulting shift values in both axes are displayed within the 
information line. To perform a combined move and copy operation, 
press and hold the Control key while defining the movement vector. 

Delete Choose this command to delete a selected annotation. 

5.2.6 Modify menu 
The complete menu is available only, if an editor window is open, but 
not in the viewer window. 

Attributes Select a structure element and choose this command to open a dialog 
box for modifying the selected element digitally. The dialog box 
contains all parameters that are specific for the selected element, i.e. 
the type of dialog box is automatically related to the currently selected 
element. If more than one element is selected, modification is possible 
only for the element with the lowest serial number. Please note this 
command is also available by double-clicking with the left mouse 
button on an element. 

Cut Choose this command to cut the selected structure element(s). This 
command is not available for dots or structure references. Two 
different possibilities exist. 

Choose command Horizontal to cut the selected elements along a 
horizontal line. After choosing the command, select the start point of 
the cutter line. Then move the mouse pointer, while a horizontal line 
will be drawn, and select the end point of the cutter line. All selected 
elements will be cut along that line, if they are touched. 

Choose command Vertical to cut the selected elements along a 
vertical line. Handling is analog to horizontal cutting. Text elements 
will be converted to paths and circles will be converted to polygons 
after cutting. 

Dose factor Choose this command to assign another dose to the selected elements. 
Two different possibilities exist. 

Within related dialog box Set, enter the dose factor to be assigned to 
all selected elements. 
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Within related dialog box Scale, enter the scale factor to be multiplied 
to the dose factor of all selected elements. 

Duplicate Choose this command to duplicate the selected elements. Two 
different possibilities exist. 

Choose command Single to make a copy of the selected elements. 
This command copies the selected elements and activates the Move 
command. 

Choose command Matrix to copy the selected elements in multiple 
columns and rows with dose scaling. Within the related dialog box, 
enter the Matrix size in U and V, i.e. the number of columns and 
rows. Enter the Base vectors in U and V with the possibility to keep 
them orthogonal or to define them in a non-orthogonal way, i.e. free. 
In addition the dose can be varied by entering Dose scaling values for 
each direction. 

Layer Choose this command to assign another layer to the selected elements. 
Within the related dialog box, select the layer to be assigned. All 
layers in use within the opened structure are listed. 

Line width Choose this command to assign another line width to the selected 
paths. Within the related dialog box, enter the line width to be 
assigned in micrometer. 

Mirror Choose this command to perform a mirror operation for all selected 
structure elements. To perform a combined mirror and copy operation, 
press and hold the Control key while defining the mirror axis. Three 
different possibilities exist. Three different possibilities exist. 

Choose command Horizontal to perform a horizontal mirror 
operation of the selected structure elements with respect to a vertical 
mirror axis, i.e. V direction, which is automatically placed in the 
centre of the enclosure of the selected structure elements. 

Choose command Vertical to perform a vertical mirror operation of 
the selected structure elements with respect to a horizontal mirror axis, 
i.e. U direction which is automatically placed in the centre of the 
enclosure of the selected structure elements. 

Choose command Line to perform a mirror operation of the selected 
structure elements with respect to a mirror axis, which has to be 
defined by two subsequent mouse clicks. 

Move Choose this command to move the selected elements. The movement 
vector has to be defined by two subsequent mouse clicks: first mouse 
click defines the start point of movement vector; second click defines 
the end point of movement vector. For digital control, the resulting 
shift values in both axes are displayed within the information line. To 
perform a combined move and copy operation, press and hold the 
Control key while defining the movement vector. 
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Rotate Choose this command to rotate the selected structure elements. This 
command is not available for structure references and text elements. 
Two different possibilities exist. 

Choose command Centre to rotate the selected structure elements 
digitally. The rotation centre is defined by the centre point of the 
enclosure of the selected elements. The related dialog provides a range 
of most used rotation angles on buttons and in addition, a text box for 
digital input of the rotation angle. To perform a combined rotation and 
copy operation, select the corresponding check box. 

Choose command Free to rotate the selected elements by mouse 
control. The rotation procedure has to be defined by two subsequent 
mouse clicks. The first mouse click defines the rotation centre. The 
second click defines the rotation angle. In detail, select the rotation 
centre by the first mouse click. Then move the mouse circularly 
around until the enclosure of the selected elements has reached the 
requested target position. Fix this target position with the second 
mouse click. For digital control, the resulting shift values in both axes 
and the rotation angle are displayed within the information line. To 
perform a combined rotation and copy operation, press and hold the 
Control key while defining the target position. 

Scale Choose this command to scale the selected structure elements. This 
command is not available for structure references and text elements. 
Two different possibilities exist. 

Choose command Factors to scale the selected structure elements 
digitally. The scaling centre is defined by the centre point of the 
enclosure of the selected elements. The related dialog box provides a 
range of most used scaling factors and in addition, text boxes for 
digital input of scaling factors for both directions, separately. Negative 
scaling factors include an additional mirror operation. To perform a 
combined scale and copy operation, select the corresponding check 
box. 

Choose command Free to scale the selected element(s) by mouse 
control. The scaling procedure has to be defined by two subsequent 
mouse clicks: first mouse click defines the new position of the lower 
left corner, second click defines the new position of the upper right 
corner of the enclosure of the selected elements. In detail, the 
enclosure of the selected elements, i.e. old area, is transferred into a 
new area, which is defined in size and orientation by two subsequent 
mouse clicks. Consequently, this operation may involve moving, 
zooming and mirroring actions, simultaneously. Select the target 
position of the lower left corner of the old area by the first mouse 
click. Then move the mouse to the target position of the upper right 
corner of the old area. Fix this target position with the second mouse 
click. For digital control, the width and height, i.e. du and dv, of the 
new area are displayed within the information line. To perform a 
combined scale and copy operation, press and hold the Control key 
while defining the target position. 
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Group… Choose this command to group selected GDSII elements so that they 
can be treated as one unit. Additional parameters can be set for a 
group, which are optional and described in a separate manual. 

Ungroup… Choose this command to ungroup a selected group so that the GDSII 
elements can be treated independently. 

Grow… Choose this command to grow all selected elements by the amount, 
entered within the related dialog box. 

Order Choose this command to enable modification of the element sequence. 
The sequence may be essential for exposure routines. After choosing 
this command, the serial numbers of all elements are displayed. To 
change this order, select the first element of the new order, then the 
second one etc. Press ESC to interrupt this command. 

Overlaps out Choose this command to remove overlaps of at least two selected 
elements to avoid an over-exposure. 

Remove Layer… Choose this command to delete the elements of all specified layers 
within the selected structure. The related dialog box indicates the used 
layers, and enables the user to enter the layers to be removed. 
Selecting the check box With references, the specified layers within 
the main structure and within all referenced substructures will be 
removed. 

Shrink… Choose this command to shrink all selected elements by the amount, 
entered within the related dialog box. 

Snap to grid… Choose this command to enlarge too small elements respectively too 
small gaps between elements. Before choosing this command, select 
the elements to be modified. After choosing this command, modify the 
base point of the grid. The related dialog box is preset by the selected 
base point of the selected elements. Enter the used grid size. The grid 
size is the smallest allowed distance between two structures 
respectively the smallest dimension of an element. 

Boolean operations Choose this command to perform Boolean operations over selected 
GDSII elements. The functions AND, OR, SUB, and XOR are 
available. SUB subtracts the element selected second from the one 
selected first. XOR is the "exclusive or" operation. 
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Figure 27: Result of 
Boolean operations 
on GDSII elements. 

Operation Elements Result 

1 AND 2 

 

 

1 OR 2 

  

1 SUB 2 

 

    

1 XOR 2 

  

 

Convert to … Choose this command to convert circles into polygons and vice versa. 
When converting a polygon into a circle the center of all points is 
calculates which becomes the center of the circle. The largest distance 
of all polygons' vertices with respect to the center is used a the radius. 

Copy & convert to FBMS path… Choose this command to convert GDSII elements into 
FBMS elements. The FBMS functionality is described in a separate 
manual. 

5.2.7 Add menu 
The complete menu is available only in the editor window but not in 
the viewer window. All added elements can be modified afterwards by 
means of the command Modify > Attributes. 

Preset Choose this command to assign layer, dose and line width as a 
standard value for subsequent "Add" operations. After choosing this 
command, a cascading menu appears offering to set the Dose factor, 
layer, line width. 
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The standard Dose factor … is valid for all subsequently added basic 
elements. Within the related dialog box, enter the dose to be pre-set as 
a factor (1 = 100% of clearing dose). 

The standard Layer is valid for all subsequently added basic elements. 
Within the related dialog box, select the layer to be pre-set. All layers 
in use within the opened structure are listed. To select a new layer, 
create this new layer by choosing the command View > Layer 
selection > Edit…. The pre-set layer is indicated within the 
information line of the window. 

The standard Line width … is valid only for subsequently added 
paths. Within the related dialog box, enter the line width to be pre-set 
in micrometer. Zero values lead to single pixel lines. These are no 
standard GDSII elements but useful for special ultra-high resolution 
applications. 

Circle Choose this command to add a circle or an ellipse, filled or border 
only, to the active layer. 

After choosing the command, move the cursor to any corner of the 
rectangle surrounding the ellipse and click the left mouse button. Then 
move the cursor to the opposite corner of the rectangle and click the 
left mouse button again. Simultaneously, an ellipse will be drawn. 
Each mouse click can be replaced by pressing Enter or by pressing the 
Space bar. By pressing Shift after the first mouse click the first point 
is interpreted as the center of the ellipse. By pressing Control the 
ellipse will be made a perfect circle. Both keys can be pressed 
simultaneously. 

An ellipse can also be added digitally. After choosing the command, 
press any digit key (0 through 9) to call up the dialog box for digital 
input. The input fields are pre-set with the coordinates of the current 
cursor position. Enter the coordinates of the first corner of the 
rectangle surrounding the ellipse. Choose Next to type in the 
coordinates of second corner. Choose OK to complete the ellipse. 

This command will be repeated automatically until pressing Esc or 
until choosing the stop button  within the icon bar. 

To access all properties of a circle double click it using the left mouse 
button. A window opens providing the following options. Use Centre 
to enter the U and V centre coordinates of the circle or the ellipse in 
micrometer. Use Ellipse to change the element shape. Use Radius to 
enter the radius of the circle respectively the U and V radii of the 
ellipse in micrometer. Use Arc to change the element style. If the 
check box is selected, two text boxes appear to enter an Angle Start 
value and an Angle End value for the circular or elliptical arc to be 
created in the range of -360° through +360°. If the check box is 
cleared, a full size circle or ellipse is added. Use Fill to change the 
element kind. If the check box option is selected, a circle or ellipse 
will be filled and an arc will be closed to become a filled segment not 
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a sector. If the check box is cleared, a text box appears to enter a 
Width value for the circular or elliptical ring respectively for the arc 
in micrometer. Use Vertices to enter the number of vertices for the 
element to be designed. This number must be in the range of 8 through 
1024. The start point is equal to the end point and this is counted 
twice. Enter Rotation to rotate the circle or ellipse counterclockwise. 
Use Dose factor to set factor which is multiplied to the dwell time. 
Select Layer to define the layer. 

Dot Choose this command to add a dot to the active layer. Dots are single 
points with zero extension. 

After choosing the command, click the left mouse button or press 
Enter or press Space bar at the location of the dot. 

A dot can also be added digitally. After choosing the command, press 
any digit key (0 through 9) to call up the dialog box for digital input. 
The input fields are pre-set with the coordinates of the current cursor 
position. Enter the coordinates of the dot. Choose OK to complete the 
input. 

This command will be repeated automatically until pressing Esc or 
until choosing the stop button  within the icon bar. 

Open path Choose this command to add a closed or open path to the active layer. 
There is a difference between a closed path and a polygon; a polygon 
has an area whereas a path consists of a border only. This difference 
can be made visible by choosing the menu command Options > Fill. 

After choosing the command, click the left mouse button at each 
corner of the path sequentially. Each mouse click can be replaced by 
pressing the Space bar. Simultaneously, an open path will be drawn. 
Click the right mouse button at the last corner to complete the path. 
This mouse click can be replaced by pressing Enter. 

It is possible to assign each open path a line width and zero value 
leads to single pixel lines. These single pixel lines are not standard 
GDSII elements but useful for ultra-high resolution applications. 

An open path can also be added digitally. After choosing the 
command, press any digit key (0 through 9) to call up the dialog box 
for digital input. The input fields are pre-set with the coordinates of 
the current cursor position. Enter the coordinates of the first corner. 
Choose Next to type in the coordinates of the following corners. After 
entering the coordinates of the last corner, choose Last to complete 
the path. Choose OK at any time to position the next corner with the 
mouse again. 

This command will be repeated automatically until pressing Esc or 
until choosing the stop button  within the icon bar. 

Polygon Choose this command to add a polygon to the active layer. 
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After choosing the command, click the left mouse button at each 
corner of the polygon sequentially. Each mouse click can be replaced 
by pressing the Space bar. Simultaneously, a polygon will be drawn. 
Click the right mouse button at the last corner to complete the path. 
This mouse click can be replaced by pressing Enter. 

A polygon can also be added digitally. After choosing the command, 
press any digit key (0 through 9) to call up the dialog box for digital 
input. The input fields are pre-set with the coordinates of the current 
cursor position. Enter the coordinates of the first corner. Choose Next 
to type in the coordinates of the following corners. After entering the 
coordinates of the last corner, choose Last to complete the polygon. 
Choose OK at any time to position the next corner with the mouse 
again. 

This command will be repeated automatically until pressing Esc or 
until choosing the stop button  within the icon bar. 

Rectangle Choose this command to add a rectangular box to the active layer. 

After choosing the command, move the cursor to any corner of the 
rectangle to be added and click the left mouse button. Then move the 
cursor to the opposite corner of the rectangle and click the left mouse 
button again. Simultaneously, a rectangular box will be drawn. Each 
mouse click can be replaced by pressing Enter or by pressing the 
Space bar. By pressing Shift after the first mouse click the first point 
is interpreted as the center of the rectangle. By pressing Control the 
rectangle will be made a perfect square. Both keys can be pressed 
simultaneously. 

A rectangle can also be added digitally. After choosing the command, 
press any digit key (0 through 9) to call up the dialog box for digital 
input. The input fields are pre-set with the coordinates of the current 
cursor position. Enter the coordinates of the first corner of the 
rectangle. Choose Next to type in the coordinates of second corner. 
Choose OK to complete the box. 

This command will be repeated automatically until pressing Esc or 
until choosing the button  within the icon bar. 

Structure reference Choose this command to add a structure reference, i.e. to design 
hierarchical GDSII files. Any structure of the loaded database with the 
exception of structures containing the opened structure as a reference 
can be referenced. These referenced structures itself of course may 
contain also references to other structures. In addition, the referenced 
structures can be arbitrarily placed, repeated in a matrix form, rotated 
and scaled within the opened structure. 



 5.2 GDSII editor and viewer 

 63 

Figure 28: Dialog 
New Structure 
Reference. 

 

Select one of the structures offered within the list box Referenced 
structure. 

Enter the scaling factor for the referenced structure within the field 
Magnification. A factor 1 includes the referenced structure in its 
original dimensions and for example a factor 0.1 includes it with 1/10 
of the original size. 

If Reflect is set, the element is reflected about the u-axis before 
angular rotation. For an array reference, the entire array is reflected, 
with the individual array members rigidly attached. 

Magnification operation is applied to the selected structure only, but 
it is not applied to Spacing U and Spacing V. Therefore the values for 
the spacing have to be calculated from the magnified structure. 

Enter the rotation angle for the entire structure matrix within the field 
Angle. The rotational center is the lower left corner of the first 
referenced structure, i.e. the lower structure, within the matrix. Please 
note, the entire matrix is rotated, not the single matrix elements. 

Enter the number of repetitions of the referenced structure along the 
rotated horizontal structure axis within the field Columns and along 
the rotated vertical structure axis within the field Rows. 

Enter the distance in micrometer between equivalent points of 
adjacent, magnified structures along the rotated horizontal structure 
axis within the field Spacing U and along the rotated vertical structure 
axis within the field Spacing V. 

Choose OK to confirm the entries. The resulting structure reference is 
indicated as a rectangle, attached to the mouse cursor, which has to be 
finally placed within the currently opened structure. For this, move the 
mouse to the target position and confirm by pressing the left mouse or 
by pressing Enter. In any case, the design cursor indicates the 
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rotational center of the structure matrix. Hence, this is not equal to the 
lower left corner of the enclosure, if a rotation angle is applied. 

The placement can also be done digitally. After confirming the the 
entries in the dialog, press any digit key (0 through 9) to call up the 
dialog box for digital input. The input fields are pre-set with the 
coordinates of the current cursor position. Enter the target coordinates 
of the rotational center of the structure matrix. Choose OK to 
complete placement. 

By default each structure reference is represented as a rectangular red-
framed rectangle indicating the location and size of the field enclosing 
all referenced structures. The name of the referenced structure and its 
matrix repetition, i.e. the numbers of rows and columns, is displayed 
in the center of this rectangle. For detailed inspection through the 
hierarchical levels, choose the menu command View > Hierarchy. 

This command will be repeated automatically until pressing Esc or 
until choosing the stop button  within the icon bar. 

Text Choose this command to add a text element to the active layer. 

Figure 29: Dialog 
Text Properties to add 
a text element to 
GDSII. 

 

Enter the text itself into the Text field. 

Enter the position a reference point for the text in micrometer within 
the field U and V. Select the alignment of the text with respect to this 
reference point by selecting the Horizontal alignment and Vertical 
alignment. 

Enter the Height of the letters in micrometer. 

Enter the Width of letters in micrometer. A value of zero will lead to 
letter consisting of single pixel lines. The preset line width Add > 
Preset > Line width is ignored. 

Enter the rotation Angle of the text in degrees. 

Enter the Dose to be assigned as a factor with 1 = 100% of clearing 
dose. 
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Select the Layer to be assigned to the text element. The preset layer 
Add > Preset > Layer is ignored. 

Additional input fields are available by pressing <<. for date and time 
strings as well as contents of VDB variables. 

Enter the VDB topic and VDB variable and press Add to copy 
corresponding string into the Text field. The syntax is 
$(vdb:<topic>.<variable>) and can be edited afterwards. The 
parameters <topic> and <variable> define the name of the topic and 
the name of the variable listed under that topic within the variables 
data base file (VDB). 

Example: The dwell time used for an exposure is stored in the variable 
“Dwelltime” under the topic “Variables”. One may want to expose 
this used dwell time together with the pattern for test purposes. For 
this, use the string 

Dwell time = $(vdb:variables.dwelltime) ms 

If the dwell time is set to 0.01, this leads to an exposure of 

Dwell time = 0.01 ms. 

Select from the list Time format and press Add time to copy time 
string into the Text field. The syntax for this kind of text entry is 
$(time:<topic>.<variable>:<format>). The parameters <topic> and 
<variable> have the same meaning as described above. If these 
parameters are left free, the actual date and time is used. If parameters 
are used then the VDB is interpreted as the number of seconds since 
1/1/1970 1:00:00. The parameter <format> defines the output format 
of the time string and can be edited afterwards. Following formats are 
available. 
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Table 13: Format of 
time string. 

<format> Result Description 

%a Sun, Mon, … short name of 
weekday 

%A Sunday, Monday, … full name of 
weekday 

%b Jan, Feb, Mar, ... short name of month 

%B January, February, 
… full name of month 

%c e.g. 04/21/01 
10:21:33 date and time 

%d 01 – 31 day number of month

%D e.g. 04/21/01 date 

%H 00 – 23 hour (24 hour 
format) 

%I 01 – 12 hour (12 hour 
format) 

%j 001 – 366 day number within 
year 

%m 01 – 12 month number within 
year 

%M 00 – 59 minute 

%p am – pm Used together with 
%I 

%S 00 – 59 seconds 

%U 00 – 52 week number (first 
day = Sun) 

%w 0 – 6 weekday number (0 
= Sun) 

%W 00 – 52 week number (first 
day = Mon) 

%x e.g. 04/21/01 date 

%X e.g. 10:21:33 time 

%y 00 – 99 year without century 
%Y e.g. 2004 year with century  

If the parameter <format> is left free %c is used as a default value. 

This command will be repeated automatically until pressing Esc or 
until choosing the stop button  within the icon bar. 
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Bitmap > As reference   Choose this command to add the link to a black and white 
image which will be exposed in a raster mode. 

Figure 30: Dialog 
Bitmap Properties to 
add an image of 
bitmap format. 

 

Enter the Filename and the Resolution in pixels or use Browse to 
search for the bitmap file. 

Enter the Position of the lower left corner of the bitmap in 
micrometer. 

Enter the Step size in DAC steps used between pixels within the 
bitmap. Take care that the product 'Stepsize' · 'bitmap pixel' does not 
exceed the total number of DAC steps, otherwise the size of the 
bitmap will exceed the writefield size. 

Enter the Dose to be assigned as a factor with 1 = 100% of clearing 
dose). 

Select the Layer to be assigned. The preset layer Add > Preset > 
Layer is ignored. 

This command will be repeated automatically until pressing Esc or 
until choosing the stop button  within the icon bar. 

Bitmap > As elements  Choose this command to import an image so that each pixel of the 
image is a separate GDSII element. All GDSII elements are 
automatically grouped. 
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Figure 31: Dialog to 
add an image as 
separate GDSII 
elements. 

 

Enter the Filename or choose  to browse for the image file. Select 
Dots, Circles, or Boxes to specify the GDSII element. Enter their 
properties when required. 

Enter Step size U/V to specify the distance between the elements. 

It is possible to set the dose by using the colors values of the image. 
The intensity for each pixel is determined using the following formula 
Intensity = (Red + Green + Blue) / 3. This intensity is then transferred 
into a dose for the corresponding GDSII element. Use min. dose and 
max dose to specify the minimum and maximum dose factor. Select 
Inverse intensity to apply the smallest intensity to the maximum dose 
factor and vice versa. Select Pixel threshold to exclude a certain 
intensity range. Optional a contrast curve can be used, which will be 
described in the corresponding manual. 

Enter the Position in U and V, if necessary. 

Select the Layer to be assigned. The preset layer Add > Preset > 
Layer is ignored. 

Group of curves Choose this command to add a group of curves to the active layer. 
This command gives access to a generator for groups of curves, which 
can be specified by flexible mathematical formulas. 

The available mathematical functions and fundamental arithmetic 
operations are listed below. If one enters functions or variables, which 
are not defined, an error message will be displayed below the 
corresponding input field. 
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Figure 32: Dialog 
Curve generator to 
add mathematically 
defined curves. 

 

Enter a suitable Title or comment for a newly generated group of 
curves. 

In general, each curve is described by a set of points and the positions 
of these points are calculated by the two equations U(X) and V(X). 
The curve itself is described in a parameter form with the running 
variable X. This variable X is incremented in a range defined by a 
start value and an end value with the specified Number of steps. This 
Number of steps is limited to 2048, i.e. if one enters a number greater 
than 2048, it will be reduced to 2048, automatically. Each curve is 
defined as an open path, i.e. the connections between adjacent steps 
are straight lines. 

Example 1 
A single circle with radius 10 and center coordinates 3/5 can be 
generated by 
U(X) = 10*COS(X)+3 
V(X) = 10*SIN(X)+5 
X = -PI to PI. 

Example 2 
A single standard parabola can be generated by 
U(X) = X 
V(X) = X^2 
X = -4 to 4 

Basic function Terms may be defined to simplify entry of complex or 
interlaced equations. Choose New to create a term or select an existing 
term and choose Edit to modify this term. In both cases the user will 
be assisted by a dialog box to enter the term characteristics. Within 
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this dialog, enter a suitable name for the term to be used within all 
other equations. But do not use any of the signs for fundamental 
arithmetic operations, i.e. + - * / ^. The length of the name is limited 
to the size of the text box. Within the same dialog, enter the term 
itself, which may contain any combination of numbers and pre-
defined mathematical functions as listed below. The length of the term 
is not limited. 

Enter the number of Curves to be generated. If this number is greater 
than 1, it is a good idea to include Parameters within the equations 
for U(X), V(X), or the Terms. Otherwise all curves will be located 
one upon the other, which may lead to accidentally over-exposure. 

The curves are generated and stored as GDSII-elements of the type 
Open path. The individual paths are created with the specified Width 
and a width of zero means, that the curves are created as single pixel 
lines. 

In order to generate a group of curves and not only a single curve, a 
set of Parameters can be defined each with a Start value and an End 
value. Within the resulting range each parameter is varied as often as 
specified. For the variation from curve to curve these parameters must 
be included within U(X), V(X), or the Terms. Choose New to create a 
parameter or select an existing parameter and choose Edit to modify 
this parameter. In both cases the user will be assisted by a dialog box 
to enter the parameter characteristics. Within this dialog, enter a 
suitable name for the parameter but do not use any of the signs for 
fundamental arithmetic operations, i.e. + - * / ^. Within the same 
dialog, enter a Start value and an End value for the parameter. When 
generating a group of curves, all specified parameters are varied in a 
linear mode from applying the start values to the first curve and 
applying the end values to the last curve. Hence, the step size of the 
parameters from curve to curve is defined as (End value - Start 
value) / (Curves - 1). Both Start value and End value may contain 
not only numbers, but also any combination of numbers and pre-
defined mathematical functions as listed below. 

The resulting curves may be limited in their U and V range. Activate 
the check box Limits and enter the lower and the upper limits for U 
and V into the input fields. If the check box Limits is cleared, the 
limits settings will be ignored. 

Choose Save and Load to store and reload all specified settings to 
dedicated files with the extensions *.MAT. 
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Figure 33: Group of 
curves generated with 
setting given above. 

 

Conventions for mathematical formulas 

For the mathematical curve generation the normal INFIX notation is 
applied. In order to achieve a good readability, one may add spaces 
anywhere within the formulas. Arguments for mathematical functions 
must be enclosed in round brackets, e.g. SIN(X). The circular constant 
PI=3.14159... is predefined. 

Table 14: 
Fundamental 
arithmetic functions. 

Key Function 

+ Addition or positive sign 

- Subtraction or negative sign 

* Multiplication 

/ Division 
^ Power  

Pre-defined Mathematical Functions 

The following mathematical functions are available to define almost 
any type of 2-dimensional curves. 
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Table 15: Pre-defined 
mathematical 
functions. 

Function Meaning Return values 

S Step or Heaviside 
function 

S(X) = 0 for X < 0 
S(X) = 1 for X ≥ 0 

R Ramp R(X) = 0 for X < 0 
R(X) = X for X ≥ 0 

SGN Signum 

SGN(X) = -1 for 
X < 0 
SGN(X) = 0 for 
X = 0 
SGN(X) = +1 for 
X > 0 

ABS Absolute 

ABS(X) = -X for 
X<0 
ABS(X) = X for 
X ≥ 0 

SQRT Square Root SQRT(X) = X^1/2 

CBRT Cube Root CBRT(X) = X^1/3 

EXP Exponential to base 
e = 2.71828… EXP(X) = e^X 

LN Natural Logarithm, 
base e = 2.71828...  

LOG Decimal Logarithm, 
base 10  

FAK Factorial FAK(X) = X! = 
1* 2*3*...*(X-1)*X 

RND Random 

X ≤ RND(X) ≤ 0 for 
X < 0 
0 ≤ RND(X) ≤ X for 
X ≥ 0 

SIN Sine Argument in radiant 

COS Cosine Argument in radiant 

TAN Tangent Argument in radiant 

COT Cotangent Argument in radiant 

ARCSIN Inverse Sine Result in radiant 

ARCCOS Inverse Cosine Result in radiant 

ARCTAN Inverse Tangent Result in radiant 

ARCCOT Inverse Cotangent Result in radiant 

SINH Hyperbolic Sine  
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COSH Hyperbolic Cosine  

TANH Hyperbolic Tangent  

COTH Hyperbolic 
Cotangent  

ARSINH Inverse Hyperbolic 
Sine  

ARCOSH Inverse Hyperbolic 
Cosine  

ARTANH Inverse Hyperbolic 
Tangent  

ARCOTH Inverse Hyperbolic 
Cotangent  

 

Manual mark scan Choose this command to add a 2-dimensional mark scan, i.e. an 
Imagescan, which can be used for aligning the write field during an 
exposure in a semi-automatic fashion. After positioning the mark by 
using the mouse or digitally the command opens an additional dialog 
which aids the definition of the mark scan. Center defines the position 
of the mark in U- and V-direction. Enter Size to modify the area 
which will be scanned around the center position. . The number of 
points used for the scan mark can be defined using Scan points. A 
point-by-point averaging is defined by modifying Average. 

The functionality is described in section  Beam to sample alignment 
in more detail. 

Auto mark scan Choose this command to add a 1-dimensional mark scan, i.e. a 
Linescan, which can be used for aligning the write field during an 
exposure in an automatic fashion. After positioning the mark by using 
the mouse or digitally the command opens an additional dialog which 
aids the definition of the mark scan. Center defines the position of the 
mark in U- and V-direction. Select the Scan direction to define the 
direction of the Linescan. Enter Size to modify the length of the scan 
whereas the Average size modifies the width used for averaging. The 
number of points used along the length of the scan can be defined as 
well as how often scans were recorded for averaging using Scan 
points and Average points. A point-by-point averaging is defined by 
modifying Average. 

The functionality is described in section  Beam to sample alignment 
in more detail. 

5.2.8 Proximity menu 
The Proximity menu gives access to two commands related to 
proximity effect correction (PEC) of GDSII patterns. As the 
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Proximity command modifies the pattern the menu is available only 
in the editor. 

The functionality will be described in the corresponding manual 
coming with the product NanoPECS. 

5.3 Working with layers 
Normally a device is build during several process steps and the idea is 
to assign all the elements used in one process step to one layer. To 
display only the layer of interest the add-on GDSII Layers can be 
opened while using the editor or the viewer at the same time. To 
distinguish between the various layers it is very convenient to assign 
each layer different properties like colors. This is done via dialog 
window Layer Properties. The layer properties are stored in separate 
file with extension LAY, path and file name are the same as of the 
corresponding GDSII database file. 

5.3.1 Displaying layers 
Choose command View > Layer selection to display the GDSII Layer 
add-on window used for selection of layers to be displayed. 
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Figure 34: Add-on 
window GDSII Layer 
used for selection of 
layers to be displayed. 

 

There are 256 layers available. To display a layer select corresponding 
layer. Selected layers are indicated by a pressed button. Choose OK to 
display selection, choose Reset to cancel changes made to the 
selection. In addition the following commands are available. All 
selects all available layers, Used selects only layers with content, and 
None cancels selection. Edit opens dialog Layer Properties. 

5.3.2 Defining layer properties 
Choose command Options > Layer Editor … to assign name, fill 
color, border color and pattern to each layer individually. 
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Figure 35: Dialog 
Layer Properties to 
modify the various 
properties of all layers.

To aid the management of these LAY files the following commands 
are available. Choose the open icon to open a LAY file from another 
GDSII database for example to take over these properties. Choose 
save icon to store the current properties to LAY file. Choose Save 
as … to store current properties to another LAY file, for example to 
attach current properties to another GDSII database. Choose Save as 
default … and current properties are used for all new created GDSII 
databases. 

Choose the arrow icons  to change the order of the 
different layers within the list. It is now interesting to interpret the 
order in the list also a physical order. Physical order means that a layer 
at the end of the list is processed first while a layer at the top of the list 
is processed later. Hence the order is interpreted as a sequence of 
process steps. To display also the layers in this physical order, i.e. 
later processed layers overlay previous processed layers, select Use 
Physical layer order. 

Choose  to remove the selected layer and choose  to add the 
layer with the number from the list box. 

To modify the layer properties select first the corresponding layer in 
the list. Place the mouse cursor in the input field Name to modify the 
name. The name is limited to 13 characters. Assign a border color by 
clicking in the color table with the right mouse button. Assign a fill 
color by clicking in the color table with the left mouse button. Assign 
a pattern by clicking in the pattern table. The last column presents 
then a preview against the current background color. 

Click on the bulb in the Active column of the list to activate or 
deactivate corresponding layer from the GDSII Layer add-on 
window. Two small boxes in the Active column indicate if 
corresponding layer contains GDSII elements. 
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5.4 Using working areas 
Normally not the whole GDSII structure is of interest for example to 
inspect it or to expose it. To expose only a fraction of the whole 
GDSII structure it is possible to define several areas of interest so 
called working areas. These working areas can be defined for each 
structure individually. The working areas for all structures are stored 
in separate file with extension WOR, path and file name are the same 
as of the corresponding GDSII database file. 

Figure 36: Add-on 
window Working 
Areas used for 
selecting and 
modifying of working 
areas. 

 

Use the new  icon to add a new working area. To change the 
properties like the Name of a working area place cursor in 
corresponding field to modify values. To define the working areas 
over their edges select button Edges, to define working area over its 
center and size select Center/Size. Note when selecting a new 
working area the corresponding area flashes several times within 
viewer or editor. 

Save changes with the save icon . The current active working area 
can be deleted using delete icon . The selected area can be viewed 
using the  icon. To move only the center of the viewpoint choose 

. Choose the pipette icon  to take over the editor or viewer 
window coordinates into the currently selected working area. Use the 
arrow icons  to change the order of the defined areas. 

To define an area as the active one click into the Active field and a 
tick is placed in this field. 

5.5 Using the toolbox 
For a fast access to the often used commands it is possible to open an 
add-on window by choosing View > Toolbox. 
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Figure 37: Add-on 
window Tools for 
editor (left) and viewer 
(right) to access some 
often used commands.

 

 

The general commands for viewing, measuring, zooming, and placing 
flags are described in section  UV Windows. 

 Editor command Add > Rectangle. 

 Editor command Add > Polygon. 

 Editor command Add > Open path. 

 Editor command Add > Dot. 

 Editor command Add > Text. 

 Editor command Add > Circle. 

 Editor command Add > Structure reference. 
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 Editor command Modify > Move. 

 Editor command Modify > Rotate. 

 Viewer and editor command Options > Fill. 

 Viewer and editor command Options > Physical layer order. 

 Viewer and editor command View > Hierarchy > 0. 

 Viewer and editor command View > Hierarchy > Max. 

5.6 Mouse and keyboard commands 
Within the editor selecting and deselecting of single elements is also 
possible by using the mouse. For selection, click anywhere within the 
element area. Selection of another element by mouse click will 
unselect the already selected elements. To unselect all elements, click 
within a free area. If a single element is selected, information about 
type, layer and dose is shown within the status bar. 

Selecting and deselecting of multiple elements by using the mouse is 
possible in two ways. Point directly to any corner of the area covering 
all elements to be selected, press and hold the Shift key and click the 
left mouse button. Releasing the Shift key lets the user define now the 
second corner of an area, holding it down the first point defines the 
center of an area. Or select one element after another while pressing 
and holding the Control key. In addition, one may use any 
combination of mouse click selection and Select respectively Unselect 
commands. If multiple elements are selected, the status bar shows the 
number of selected elements. 

Within the editor and the viewer, zooming can be done using the 
wheel of a corresponding mouse. 

If the crosshair is used as mouse pointer its movement is also done on 
the meshes defined by the design grid. If the default mouse pointer is 
used, the mouse can be placed also in between. The placement of the 
GDSII elements is not effected. 

The following tables give a summary of all available mouse and 
keyboard commands within the GDSII database, the viewer as well as 
the editor window. 
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5.6.1 GDSII database 

Table 16: Mouse 
commands in GDSII 
database window. 

Action Key(s) + Mouse 
Button Functionality 

Single 
click none + left Select a structure. 

Single 
click none + right Open the right mouse menu. 

Double 
click none + left Open the viewer window. 

Double 
click Control + left Open the editor window. 

 

Table 17: Available 
GDSII database 
keyboard shortcuts. 

Key Functionality 

F2 to rename a structure 
Control + C to copy a structure 
Control + N to create a new structure within a GDSII database
Control + O to open a new GDSII file 
Control + V to paste a structure into GDSII database 
Control + Shift 
+ N to create a new GDSII database 

Control + Shift 
+ S to save GDSII database into a new file 

5.6.2 GDSII viewer 

Table 18: Mouse 
commands in viewer 
window. 

Action Key(s) + Mouse 
Button Functionality 

Single 
click none + right Repeat the last command. 

Single 
click Control + right Drive to location. 
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Table 19: Available 
GDSII viewer 
keyboard shortcuts. 

Key Functionality 

+ to zoom in by a factor of 2 

- to zoom out by a factor of 2 

= to view all 

* to increase the design grid by factor 2 

/ to decrease the design grid by factor 2 

a to display GDSII element properties 

e to measure dimensions in editor or viewer 

f to fill out the elements, toggle mode 

g to show / hide the design grid, toggle mode 

h to move viewed area 

l to open layer selection box, toggle mode 

t to open toolbox , toggle mode 

w to open working area editor, toggle mode 

z to zoom in and out, toggle mode 

Shift +  to scroll the display into direction of arrow 

Alt + i to increase hierarchy by one step 

Alt + d to decrease hierarchy by one step 

Alt + o to show overlays, toggle mode 

Alt + r to redraw the display 

Del to delete an annotation 
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5.6.3 GDSII editor 

Table 20: Mouse 
commands in editor 
window. 

Action Key(s) + Mouse 
Button Functionality 

Single 
click none + left 

On an unselected structure element:
select that element and unselect all 
other elements 
Anywhere else: 
Unselect all elements 
Related menu command: 
Edit > Unselect > All 

Single 
click Control + left 

On an unselected structure element:
Select that element additionally 
(without unselecting all other 
elements) 
On a selected structure element: 
Unselect that element only (without 
unselecting all other elements) 

Single 
click Shift + left 

Select all elements additionally 
within a frame to be dragged 
(without unselecting all other 
elements - but only for active layer)
Related menu command: 
Edit > Select > In 

Single 
click none + right Repeat the last command 

Single 
click Control + right Drive to location 

Double 
click none + left 

On a structure element: 
select that element, unselect all 
other elements and open a dialog 
box to modify the attributes of that 
element 
Related menu command: 
Modify > Attributes 

 

Table 21: Available 
GDSII editor 
keyboard shortcuts. 

Key Functionality 

+ to zoom in by a factor of 2 

- to zoom out by a factor of 2 

= to view all 

c to add a circle 
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d to duplicate the selected elements 

e to measure dimensions in editor or viewer 

f to fill out the elements, toggle mode 

g to show / hide the design grid, toggle mode 

h to move viewed area 

l to open the layer selection box, toggle mode 

m to move the selected elements 

o to modify the order of elements 

p to add a polygon 

r to add a rectangle 

t to open the toolbox, toggle mode 

w to open working area editor, toggle mode 

z to zoom in and out, toggle mode 

Del to delete the selected elements 

Tab to select the next element 

Shift + Tab to select the previous element 

Shift +  to scroll the display into direction of arrow 

Control + a to select all elements 

Control + c to copy the selected elements 

Control + s to save the structure 

Control + v to paste the previously copied elements 

Control + x to cut the selected elements 

Control + z to undo last editing command 

Control + y to redo last undo command 

Alt + i to increase hierarchy by one step 

Alt + d to decrease hierarchy by one step 

Alt + o to show overlays, toggle mode 

Alt + r to redraw the display 
 

5.7 Drag and drop 
A summary of drag and drop operations involving GDSII structures 
are listed below. 
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Table 22: GDSII drag 
and drop 
functionality. 

Source Object Target Action 

GDSII 
Database Structure Image 

Place structure in Image and 
generate complete data line in 
related Positionlist 

GDSII 
Database Structure Positionlist 

Generate data line in 
Positionlist; read and use 
actual sample coordinates as 
object location (origin). 

GDSII 
Database Structure Wafermap 

Place structure in Wafermap 
and generate complete data 
line in related Positionlist for 
automated exposure routines. 

GDSII 
Database Structure Program 

desktop Delete structure. 

GDSII 
Database Structure GDSII 

Database 

Copy selected structure to 
current database. The original 
structure will not be 
overwritten. 
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6 Stage Control 
6.1 Coordinate display 85 

6.2 Stage control 87 

6.3 Find home position 92 

6.4 LASER stage control 93 

Normally the lithography system is equipped with a stage to position 
the sample. If this stage is motorized then it is possible to control the 
stage movement by means of the software. In addition it depends on 
the stage what axes are available. In the following all supported axis 
are listed. 

X One of the physical axis of the stage. The axis is normally oriented 
perpendicular to the beam. 

Y One of the physical axis of the stage. The axis is normally oriented 
perpendicular to the beam and perpendicular to X. 

Z One of the physical axis of the stage. Normally parallel to beam. 

R If available, the rotation axis of the system. 

T If available, the tilt axis of the system. 

U One of the axis of the sample coordinate system. The axis is in the 
plane of the sample surface. 

V One of the axis of the sample coordinate system. The axis is in the 
plane of the sample surface and perpendicular to U. 

W One of the axis of the sample coordinate system. The axis is 
perpendicular to sample surface and, if corrected for the sample 
height, equal to column working distance. 

6.1 Coordinate display 
Figure 38: Control 
bar section displaying 
current stage and 
sample coordinates. 
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The number of displayed coordinates depends on the number of 
motorized axes of the system. It may vary between 2 axes, i.e. X and 
Y, and up to 5 axes, i.e. X, Y, Z, R, and T. Any combination is 
possible. In most cases however, there are only the X Y or the X, Y, Z 
axes motorized. All displayed values are refreshed periodically. The 
difference between stage X, Y, Z coordinates and sample U, V, W 
coordinates is defined by a complete two-dimensional transformation. 

To get an overview over the current relation between stage as well as 
global and local coordinate system select Menu > Coordinates 
overview. 

Figure 39: Window 
displaying current 
stage and sample 
coordinates. 

 

6.1.1 Display options 
Basic display option settings can be done by choosing the command 
Edit > Options or by right mouse click anywhere in the Coordinates 
section. These settings are assisted by the Coordinate Display Options 
dialog. 
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Figure 40: Dialog to 
set options for the 
Coordinates section. 

 

Display/decimals Select the check box for each axis to be displayed., i.e. if one of the 
axes should not be displayed, the related check box has to be cleared. 
The display resolution, i.e. number of decimals, can be entered for all 
axes individually within the related text boxes. 

Length unit The metric unit setting is valid only for metric axes XYZUVW but not 
for R and T. It can be set to mm or µm. Due to this setting, the number 
of digits will change, but the position data remain to be the same. 
Please change the number of decimals accordingly. 

Order Select with this option which coordinates are displyed first. 

Tile Select the option horizontal to display stage coordinates and sample 
coordinates side by side. In case of selecting the option vertical, they 
will be displayed one beneath the other. 

6.2 Stage control 
The stage control allows controlling stage movement by sending 
single commands to the motor controller. 

Figure 41: 
Controlling stage 
movements, 
Command tab. 

 

On the left hand side it contains the following items. 
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Stop Choose this button to stop all motors immediately. The command is 
used as an Emergency Stop to cancel any stage movement or to avoid 
damage in a dangerous situation. This button is only available for 
Raith motor control or for demo motor control. 

Length Select here the basis unit for all drive command except drive 
commands in the Command line. 

Base Choose the coordinate system to be used for addressing, i.e. sample 
coordinates or stage coordinates. 

Figure 42: Dialog to 
define and store a 
position. 

 

To edit a position, proceed as follows: 

STEP 1 ► Select the position to be edited from the drop-down list box. 

STEP 2 ► Choose the Edit button. The "Edit User Defined Position" dialog box 
appears. 

STEP 3 ► Enter a suitable name for this position. 

STEP 4 ► Enter the position coordinates into the text boxes X, Y, Z, R, T or 
choose the Read button to take over the coordinates of the current 
stage position. 

STEP 5 ► Enter the sequence of axis movement into the text box, e.g. zXY for 
movement first in Z- and than in XZ-direction. Only those axes will 
be driven which are listed within this text box. After entering capital 
letters the stage moves in these axes simultaneously. With small 
letters the stages moves one axis after the other. 

 

This may be important, if a tilted wafer is moved to a position near the 
pole piece. In this case it is recommended first to drive the tilt axis to 
zero and the Z axis to a low position before moving X and Y axes. 

STEP 6 ► For information purposes, enter a comment within the respective text 
box. 

STEP 7 ► Choose OK to use settings. 
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6.2.1 Drive tab 

Figure 43: 
Controlling stage 
movements, 
Destination tab. 

 

Axis input fields Enter the destination values for UVW or for XYZRT depending on 
the Base selection. 

Start Choose this button to start movement. 

Clear Choose this button to clear all text boxes. 

Position  Choose the addressing mode, i.e absolute movement or relative 
movement. 

Command line Digital command input is done via this text box. To repeat the last 
command, choose the Repeat button besides the text box. 

The following digital commands can be given via the command line. 

Table 23: Available 
drive commands. 

Syntax Function 

<coordinate><lowercase-axis-
letter> absolute addressing 

<distance><uppercase-axis-
letter> relative addressing 

<axis#>b backlash compensation 

Space backlash on all axis 

<line#>g absolute Positionlist No. 

<line#>G relative Positionlist No. 

i<id#>g absolute Positionlist ID 
i<id#>G relative Positionlist ID  

The functionality of these commands is as follows: 

Absolute Addressing To move one axis to a requested position in stage or sample 
coordinates. 

The syntax is <coordinate><lowercase-axis-letter>. 
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Where the positive or negative <coordinate> value has to be entered in 
mm. Available <lowercase-axis-letter> values are x, y, z, r, t, u, v, w. 
To move to 0.0, just type the axis' letter. 

Example: 
The command "-5.5x" moves the stage to the X coordinate -5.5 mm. 

Relative Addressing To move one axis relative to its current position over a requested 
distance in stage or sample coordinates. 

The syntax is <distance><uppercase-axis-letter>. 

Where the positive or negative <distance> value has to be entered in 
mm. Available <uppercase-axis-letter> values are X, Y, Z, R, T, U, V, 
W. 

Example: 
The command "2.5X" moves the stage over 2.5 mm into positive X 
direction. 

Backlash Compensation Backlash compensation is essential for exact positioning with 
not-LASER stages. It is done by moving the stage away from the final 
position and returning always from the same direction, normally 
against the spring force. 

The syntax is <axis#>b. 

Where <axis#> is 1 for X axis, 2 for Y axis, 3 for Z axis, 4 for R axis, 
5 for T axis. Use Space to perform a backlash on all axis. 

Example: 
The command "2b" moves the Y motor for backlash compensation. 

Positionlist Addressing Within the latest opened Positionlist, any position can be 
addressed by data line number (No.) or by data line identification 
number (ID). Each of these commands can be specified to be absolute 
or relative to the currently selected data line. 

The syntax for absolute Positionlist No. addressing is <line No.>g. 

Where <line No.> is No. of corresponding line. 

Example: 
The command "15g" selects data line with No. 15 and moves the stage 
to the position specified in that data line. 

The syntax for relative Positionlist No. addressing is <line No.>G 

Where <line No.> value has to be entered as the difference between 
the number of the currently selected line and the number of the line to 
be selected. 
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Example: 
If data line with No. 10 is currently selected, the command "15G" 
selects data line with No. 25 (=10+15) and moves the stage to the 
position specified in that data line. 

The syntax for absolute Positionlist ID addressing is i<line ID>g. 

Where <line ID> is ID of corresponding line. 

Example: 
The command "i15g" selects data line with ID 15 and moves the stage 
to the position specified in that data line. 

The syntax of relative Positionlist ID addressing is i<line ID>G 

Where the <line ID> value has to be entered as the difference between 
the ID of the currently selected data line and the ID of the data line to 
be selected. 

Example: 
If data line with ID 10 is currently selected, the command "i15G" 
selects data line with ID 25 (=10+15) and moves the stage to the 
position specified in that data line. 

6.2.2 Step tab 

Figure 44: 
Controlling stage 
movements, Step tab. 

 

 Choose one of the arrow buttons to move stage into corresponding 
direction using the distance given in the input fields Step size. 

Base Select the base for following drive commands. 

Step size Type in the distance for following drive commands. Select Equal 
steps to link the movement in the two orthogonal directions. Choose 
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one of the two buttons  to read current write field or current 
distance between chips. 

Beam If the check box Use automatic beam off is selected, the beam will be 
blanked during stage movements. To observe the sample, leave this 
option unchecked. 

 

To control the general functionality to switch off the beam at each 
drive command, use the setting Module Status > Virtual beam 
Control > Auto Beam Off. 

6.2.3 Positions tab 
A set of 10 positions can be defined by the user and recalled on 
request. 

Go Choose this button to drive the stage to the position, selected from the 
drop-down list. 

Edit Choose this button to edit the position, selected from the drop-down 
list. A dialog opens. 

6.2.4 Stage lock tab 
This functionality is only available, if user possesses user level SYS 
and for Raith motor control or for demo motor control. Here it is 
possible to lock single axis to prevent them from moving. 

6.3 Find home position 
If one accidentally loose the coordinate system, the Find Home 
Position routine recovers and resets the setup. 

It requires the definition of limit switches and home positions for the 
relevant axes within the initialization routine. Hence the Find Home 
Position routine can be performed only for motorized axes which are 
equipped with limit switches. 
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Figure 45: Dialog to 
initiate each stage 
axis. 

 

Either choose a single axis by pressing on of the lightning buttons or 
choose the Find All button. 

After this, the stage moves towards the limit switches and the system 
sets the corresponding Switch position. Then the stage moves to the 
corresponding home position. 

6.4 LASER stage control 
Note this module is only available when having a stage which can 
move under LASER or encoder control. 

Figure 46: Control 
bar section to check 
stage mode and 
change mode. 

 

LASER control A green LED indicates that the LASER signal is available for the 
corresponding axis. 

Status Indicates what mode is currently used. 

LASER Switch to LASER mode. 

Coder Switch to encoder mode. 
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A Positionlist is a spread sheet orientated tool within the Raith 
software which serves the execution, generation, administration, and 
documentation of various tasks. 

• Adjustments and alignment tasks, i.e. performing a complex 
sequence of mark scans and their evaluations. 

• Stage controls tasks, i.e. driving the stage sequentially to multiple 
positions in stage or sample coordinates. 

• Exposure tasks, performing exposures of one or more selected 
structures at different sites on the sample with optionally different 
parameters. 

• Performing scans of images or of waveforms and automation 
tasks. 

The various tasks defined in a Positionlist can be configured by the 
customer in any selected sequence and combination. Positionlists 
required for standard adjustment and alignment procedures are 
generated automatically. 

A Positionlist is defined and internally stored as an ASCII data file, 
which normally is indicated by extension PLS. The Positionlist 
concept of the Raith software allows very flexible configurations, 
handling of different list formats, and thus can be adapted to almost 
any application. Although for normal operation a single Positionlist is 
used and fully sufficient, it is possible to load and operate multiple 
lists simultaneously. 

7.1 Positionlist window 
Open an existing Positionlist with extension *.PLS, by choosing the 
command File > Open positionlist or define a new one by choosing 
File > New positionlist. 
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Figure 47: Typical 
Positionlist window 
with its several 
elements. 

 

Task list The task list displays each task as a separate line. Each task is defined 
by various data which are stored in separate fields. Thus the task list 
can be seen as a spread sheet. 

Icon bar The most often used commands are directly available from the icon 
bar. Using the lists boxes it is possible to include or exclude some 
tasks according to their attributes. 

Information line Here some information associated with this Positionlist are displayed. 

7.1.1 Task list 
Each line contains the data set of a task. Tasks can be alignment 
procedures, Imagescans, Linescans, structures to be exposed, line 
width measurements, or simply stage positions which can be 
addressed. 

The task list is represented in a common table format, so that the 
standard editing functionality is available also for a Raith Positionlist. 
This mean it is possible to adapt the column width using the mouse 
and edit the contents of each cell by placing the cursor into it. 

Each Positionlist consists of some fixed columns as a serial number 
No., an identification number ID, coordinates XYZRTUVW, 
characterization Attribute, addressing information (Template), 
individual remark Comment. In addition each Positionlist can have 
some application specific columns. The columns have their own 
properties like name, optional units, display width, data size, default 
value, etc. Settings these properties is described in section  
Configuration. 

No. Serial numbers are set automatically by the Raith software, they 
cannot be changed by operator. They are used for addressing 
commands and to select a data line for scanning or editing purposes. 

The layout of serial numbers can be changed by setting the variable 
Module status > Positionlist > Line Number Format. The syntax is: 
Line Number Format = "%<0><digits>d" where <0> is optional to 
display leading zeros, and <digits> is the maximum number of digits 
for each serial number. 

Examples: 
Line Number Format = %3d displays 1, 2, 3, ... 



 7.1 Positionlist window 

 97 

Line Number Format = %03d displays 001, 002, 003, ... 
Line Number Format = %04d displays 0001, 0002, 0003, ... 

The serial number is dynamically generated and may change due to 
another sorting of the lines, e.g. after a filter command, etc. 

ID ID numbers may be freely defined and changed by operator. They are 
used for addressing commands and to select a data line for scanning or 
editing purposes. 

In contrast to the serial number, the ID number of a data line will not 
change due to display or filter restrictions. 

XYZRTUVW Any Positionlist must have at least one or more coordinates out of the 
range X, Y, Z, R, T, U, V, and W. 

Attribute Attributes are very important features of the Positionlist concept, since 
they may contain key codes for controlling purposes or other 
important information. In addition, attributes are used for display 
restrictions as described in section  Including and excluding. So, 
attributes should be used to qualify or classify individual objects or 
positions. 

Allowed inputs for attributes are all small letters a-z, all capital letters 
A-Z, single digit numbers 0- 9, and all combinations of the above. 

 

The standard value for attributes can be changed by setting the 
variable Module status > Positionlist > New Attributes. This 
variable is used to set a standard entry when creating a new data line, 
e.g. by using the command Edit > New. 

Template Templates are used to define, how the addressing of the stage is done, 
i.e. which of the values given under X, Y, Z, R, T, U, V, and W are 
used and in which order. Within the Raith software, template 
generation and handling is fully automated and requires no interaction 
by the user. 

For special purposes the user can use and modify the templates in 
order to define which coordinate combinations are to be used for 
driving the stage. Data lines without a template are ignored for stage 
addressing. 

The standard value for templates can be changed by setting the 
variable Module status > Positionlist > New Template. This variable 
is used to set a standard entry when creating a new data line, e.g. by 
using the command Edit > New. 

 

Generally, it makes no sense to have templates X and U at the same 
time. This is also true for Y and V, as well as for Z and W. 

Comment Can be used to store additional information for each position. 
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For predefined tasks like an exposure or a mark scan, the Comment 
field is used internally, e.g. to define which structure to expose or 
which scan to execute. Do not alter its content. 

7.1.2 Icon bar 
This bar contains some the often used commands as icons. These 
commands are File > Open, File > Save, File > Save as, Edit > List 
properties, File > Open assigned Wafermap, File > PLS 
Preprocessor, Edit > New > Insert before, Edit > New > Insert 
after, Edit > Delete, Search > Find, Search > Replace, Scan > 
Previous, Scan > Selection, and Scan > Next. Then two fields are 
available to include and exclude lines with some specific attributes. 

Including and excluding 

To display or to select only a fraction of the tasks, it is possible to 
include or exclude lines, which contain a certain character in their 
Attribute field. By typing a character into the Include field, only the 
lines containing this character in their Attribute field are included in 
the display. Whereas typing a character into the Exclude field 
prevents the lines containing this character in their Attribute field 
from being displayed. One may enter several attributes without 
separation. Attributes are case sensitive, so entry of lower case 
characters or upper case characters will achieve different results. In 
addition, including and excluding can be used at the same time and 
only lines fulfilling both conditions are shown. Default values are all 
for Include and none for Exclude. The attribute entry is stored within 
the related drop-down list as a history, but this history is available 
only until the Positionlist is closed. 

 

The search restrictions do not change the content of the Positionlist. 
This means that those data lines, which are not displayed, keep 
although staying in the Positionlist data file and can be made 
accessible by changing the search restrictions. 

7.1.3 Information Line 
This line contains the following information from left to right: 

• Which line is currently selected and how many lines exist. 

• A star indicates that this Positionlist was modified and contains 
some data which has not been stored so far. 

• If the Positionlist is used in connection with defect finder Lot ID, 
Wafer ID, and Slot can be used to identify a specific wafer. The 
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information itself can be changed by using the command Edit > 
Sample information. 

7.2 Menu commands 
It is possible to handle more than one Positionlist on the desktop. In 
the case that more than one Positionlist has been opened all 
commands are applied to the active one, only. 

 

The behavior on opening a new Positionlist can be defined using the 
command Window > Save Settings. This command is described in 
section  Using projects for customizing. 

7.2.1 File menu 
Open Choose this command to load a Positionlist into the current 

Positionlist window. A dialog box offers the capability to keep the 
format, i.e. all list properties, of the already opened list. Answering no 
uses the format for the newly opened list. 

This command is different from File > Open positionlist …, which 
adds another Positionlist window to the desktop. 

Save Choose this command to save the activated Positionlist under its 
current name. 

Save as … Choose this command to save the activated Positionlist under a freely 
selectable name. 

Open assigned Wafermap … Choose this command to open the assigned wafer Wafermap. 
See section  Assigned Wafermap for further details. 

Open PLS-Preprocessor … Choose this command to open the Positionlist preprocessor 
window. See section  Positionlist preprocessor for further details. 

New positionlist … Choose this command to open an empty Positionlist window. 

Open positionlist … Choose this command to open a previously saved Positionlist. 

7.2.2 Edit menu 
Cut Choose this command to cut out the currently selected lines and copy 

them to the clipboard. 

Copy Choose this command to copy the currently selected lines to the 
clipboard. 

Paste Choose this command to paste lines from the clipboard to the 
Positionlist before the currently selected line. 
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Delete Choose the command to delete the currently selected lines. 

 

If no data line is selected, this command will not work. A deleted data 
line cannot be restored. 

Select all Choose this command to select all lines of a Positionlist. 

New > Insert before Choose this command to insert a new line before the currently 
selected line. The new line contains only the current stage position, 
the default template as well as the default attributes. 

New > Insert after  Choose this command to insert a new line after the currently selected 
line. The new line contains only the current stage position, the default 
template as well as the default attributes. 

New > Stage Position Choose this command to open the dialog Store new position ... which 
contains already the current stage position, the default template as 
well as the default attributes. After editing the position properties and 
applying OK, a new line is appended at the end of the Positionlist. 
Press Cancel to quit dialog without adding a new position. 

Current … Choose this command to open a window for editing of the selected 
line. 

Figure 48: Window 
to edit the various 
data fields of a line 
within a Positionlist. 

 

The meaning of the fields ID to Comment is described in section  
Universal Columns. Whereas the meaning of the User defined fields 
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depend on the application and is therefore described in various section 
of this manual. 

Line number/ID … Choose this command to select a line by using the line number or its 
ID. Hence this command is useful to avoid scrolling through 
extremely long Positionlists. 

Figure 49: Window 
to select a line within 
a Positionlist either by 
its number or ID. 

 

Within the following dialog, choose the select mode and enter the 
Line number or the ID within the Position field. 

Attributes … Choose this command to add attributes to or remove attributes from 
all lines or only selected ones. 

Figure 50: Dialog to 
edit Attributes of lines 
within a Positionlist. 

 

Within the related dialog box, enter the Character, select the editing 
mode Remove or Add, and specify to which Positions the 
modification should applied to. Please note that the evaluation of the 
Attributes is case sensitive and matches only whole words. 

List properties … Choose this command to open a dialog to modify the properties of the 
columns and to select the assigned Wafermap. 
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Figure 51: Dialog to 
modify the column 
properties as well as 
the assigned 
Wafermap. 

 

The list box on the left hand side contains names of the Columns. The 
list starts with the fixed columns serial number (No.), identification 
number (ID), coordinates (X, Y, Z, R, T, U, V, W), Attribute, 
addressing information (Template), Comment. Then additional 
application specific columns follow. 

To add a new application specific column, click on New. To delete a 
application specific column, select the column first and then click on 
Delete. Only application specific column can be deleted. 

To set or to change the layout properties of a column, the column 
name has to be selected within this list box. A selected column name 
appears to be highlighted. 

On the right hand side, the layout properties for each selected column 
name are displayed. The meaning of the layout properties is as 
follows: 

Title The title can be changed only for user defined columns but not for 
fixed columns. 

Units The entered dimension is displayed directly behind the column title, if 
Show units is selected. They serve for information purposes only, but 
have no influence on calculation routines. 

Data Size This setting reserves space for storing the data within the Positionlist 
file. It can be changed only for application specific columns. 
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A fixed memory of 1024 Bytes is reserved for each line. Therefore, 
the user has to make sure that enough space for the data is available. 
Not enough space to store the data is the main reason for losing 
information. 

Default value The default value can be set or changed only for application specific 
columns but not for fixed columns. It is used to set a standard entry 
when creating a new line. 

Visible If the check box is selected, the column will be displayed within the 
Positionlist. 

Write to file If the check box is selected, the column data will be stored within the 
Positionlist file. The serial number No. will never be written to file. 
The application specific columns will always be written to file. 

Display width The graphical representation of the columns can be accommodated by 
assigning a display width for each of them. 

 

This can also be set directly within the Positionlist window by using 
the mouse. For this, select the separating line between two column 
names and move it. To set the optimum column width, double click 
the column name. 

Waferlayout Select the Wafermap which should be assigned to the current 
Positionlist. The drop-down list contains all Wafermaps stored in the 
user directory "Wafer". 

Save as default Select this option to use the applied settings for all newly generated 
Positionlists. 

Sample information  Choose this command to open the dialog for editing the sample 
information. 

7.2.3 Search menu 
Within a Positionlist it is possible the search for certain strings as well 
as to replace them. In addition to the common parameters of all search 
dialogs the rows and columns which are scanned can be selected. 
Rows are selected whereas columns can be addressed by their name. 

7.2.4 Filter menu 
Matrix Copy The Matrix Copy filter serves to easily generate a position matrix 

consisting of a rectangular array positions. 

 

The command is not available, if the activated Positionlist is empty. 
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The result of the matrix copy operation is a list of newly generated 
lines, which are added automatically. The related dialog has the 
following functionality: 

Figure 52: Dialog to 
set parameters for 
Matrix Copy filter. 

 

Positions to copy Choose whether all data lines are to be used as the base data lines or 
only the selected ones. 

Matrix size Enter the numbers of matrix elements in U and in V direction. 

Step Enter the distances between adjacent matrix positions in U and in V 
direction. The numbers may also be negative. In this case the copying 
action is performed into the negative U or V direction. 

Element order Choose whether element order is row by row. i.e. U (rows) first, or 
column by column, i.e. V (columns) first. If Meander option is active 
the positions are ordered, the sequence of positions alternates from 
row to row or column to column. This optimizes the spatial order and 
therefore decreases the exposure time. 

Dose factor Choose here by which amount the exposure dose factor is increased 
from matrix element to element. The factor can be set for U- and V-
direction independently. The amount can by added or multiplied to the 
previous matrix element. By selecting Calculate automatically it is 
possible to use one amount for the complete matrix. 

Linescan analysis This command is used to apply one or more Linescan filters to 
previously scanned Linescans in a Positionlist. So, its main use is 
retrospective data processing and analysis. Those filters which obtain 
a result will store this result as Pos1 through Pos3 in the Positionlist. 
The old data are overwritten! 
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Figure 53 Dialog to 
define which 
Linescan filters to 
apply to Linescans in 
a Positionslist. 

 

Within the dialog choose first, if the filters should be applied to All or 
only to the Selected Linescans. By using < and > buttons, it is 
possible to copy the filters from the list Available filters to the list 
Filters to apply. The functionality of the filters is the same as 
described in section  Evaluation algorithms. 

Slowscan analysis This command is used to apply one or more Image filters to 
previously scanned Images in a Positionlist. So, its main use is 
retrospective data processing and analysis. Those filters which obtain 
a result will store this result as Pos1 through Pos3 in the Positionlist. 
The old data are overwritten! 

Figure 54: Dialog to 
define which Image 
filters to apply to 
Imagescans in a 
Positionlist. 

 

Within the dialog choose first, if the filters should be applied to All or 
only to the Selected positions. By using < and > buttons, it is possible 
to copy the filters from the list Available filters to the list Filters to 
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apply. The functionality of the filters is the same as described in 
section  Evaluation algorithms. 

Line calculation This command calculates the distance between Pos1 and Pos2, or the 
mean value of Pos1 and Pos2 of all valid Linescans in a Positionlist. 
In the case of the difference, the result can be interpreted as a width. 
In the case of the mean value, the result can be interpreted as a 
position. After applying the result will be shown in the Positionlist 
column "Pos3". 

Figure 55: Dialog to 
calculate the width or 
the position of all 
valid Linescans. 

 

Select Metrology mode, to use the scaling previously defined in an 
Adjust UV procedure. Hence, the measurement is given in units of the 
stage. 

Long distance This command calculates the difference between Pos1, Pos2, or Pos3 
of one line and Pos1, Pos2, or Pos3 of another line within a 
Positionlist. If Pos1, Pos2, Pos3 are the results of position 
measurements the result is the distance between them. 

Figure 56 Dialog to 
calculate the distance 
between two  
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Within the dialog chose first, if the filter should be applied to All or 
only to Selected positions. For distance calculation, the two lines must 
have a link assigned between them. To establish this link, type into the 
column Link of one of the two lines the ID of the other line. After 
applying the command, this line contains now the result.  

Unselect result with sign, to calculate only the absolute values. 

Statistics This command calculates and displays the mean, the minimum, the 
maximum and the standard deviation values for all data within the 
columns Pos1, Pos2 and Pos3 of a Positionlist. 

Figure 57: Window 
displaying some 
statistical values of 
Pos1, Pos2 and Pos3. 

 

By using Filter, it is possible to exclude positions from being 
displayed and used during calculation. To display and to use all, press 
All. 

Query This command selects all positions which fulfill the criteria specified 
by means of the appearing dialog. 

Figure 58: Dialog to 
select some positions 
fulfilling certain 
criteria. 

 

The text comparison can be made Case sensitive. 

Select first the name of the column, then if the comparison is made as 
text or as number. Select in the following the comparison condition. 
In case of a text comparison, the conditions < and > assume an 
alphabetical order. Then type in the data. The comparison can be 
negated by selecting the not option. To build a more complex 
comparison, press the insert before or insert after icons and connect 
the sub-conditions by using or, and and xor. Each sub-condition can 
be deleted using the Delete icon. 

Press Apply to see the result of the selection. Press Remove to 
neutralize the filtering. 
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The whole comparison can be saved and recalled for later usage, using 
the Open and Save icons. 

Export This command provides an universal export for all Positionlists. 

There are three kinds of data export available: 

• configurable Text file export, 

• configurable export to Microsoft Excel, 

• configurable export to KLA File. 

The related dialog box (see figure) has the following functionality: 

Figure 59: Dialog to 
export positions into a 
Text file. 

 

Select Source whether all data lines are to be exported or only the 
selected ones. The entire number of data lines within the activated 
Positionlist is indicated in brackets. 

Choose for Destination one of the options Text File, Microsoft Excel 
or KLA File. 

• Text File: A text file needs the selection of a field separator. 
Common field separators are ";", ",", <SPACE> or <TAB>. If 
Field name in 1st line is selected, the column headers will be 
added to the target file. 
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• Microsoft Excel: This export option requires that the Microsoft 
Excel program is installed on the computer and it is running. Enter 
the name of the Microsoft Excel file to be used for export. 

• KLA File: Export to a file which then can be imported into KLA 
system or many yield management programs. 

 

To adapt the output to your regional settings, set the variable Module 
status > Export Filter > Decimal Separator to the used character. 

To select one column for exporting, place a tick in front of its name. 
Choose then the Type depending on the columns contents. In case of 
selecting the option Float, one may enter a scaling factor. If for 
example the external program handles the coordinates as µm instead 
of mm, the scale factor is 1000. 

If export to a KLA File has been chosen, select from list KLA field 
the column which is used within KLA software and which 
corresponds to the active Positionlist column. 

Statistic results Choose this command to display a distribution of the content of 
column Pos3. 

Figure 60: 
Distribution of values 
given in column 
Pos3. 

 

Specify the range on the x axis by entering the corresponding numbers 
within the parameter set Calculation range. Specify the range of the y 
axis by entering the numbers under counts range. Using Bars one can 
set the width of count interval. Select  to recalculate the settings, 
select  to move the annotate, use  to define the annotation text, 
and use  to overlay a Gaussian distribution fitted to the values. Use 
the , , and to save the distribution as an image, to copy it to the 
Window's clipboard, or to print it. 
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7.2.5 Scan menu 
These commands assist the user to execute a list of task in a 
Positionlist. 

Before scanning, make sure that the required or wanted scan options 
Drive to position, Scan Manager, Exposure, Execute Macro are in 
effect which is indicated by check marks. The Positionlist 
automatically differentiates what needs to be done to execute a 
selected line. This differentiation is performed by interpreting the 
Positionlist column Type. 

Cancel Scan This command stops the execution of a Positionlist. 

 

While executing a Positionlist, it can be difficult to reach this menu 
command. Press the ESC key instead. 

Selection Choose this command to scan the selected positions. If no data line is 
selected, this command has no effect. If a group of lines is selected, 
only these lines are executed. 

Next Choose this command to scan the next position after the currently 
selected one. If no data line is selected, this command has no effect. 

Previous Choose this command to scan the previous position before the 
currently selected one. If no data line is selected, this command has no 
effect. 

Line number/ID Choose this command to select a specific data line for scanning. 
Within the additional dialog choose the Line number or ID and enter 
the number. 

All Choose this command to scan once through all positions within the 
Positionlist starting from the first data line and ending with the last 
data line. 

From current Choose this command to scan once through the positions within the 
Positionlist starting from the currently selected position and ending 
with the last data line. 

Endless Choose this command to scan endless through all positions within the 
Positionlist starting from the currently selected position. Choose the 
command Scan > Cancel Scan or the ESC key to cancel scan. 

Drive to position Choose this option to drive the stage to each selected position. If this 
option is not in effect, the stage will not drive to the positions. Thus 
normally this option should be switched on. 

Scan manager Choose this option to execute adjustment and alignment procedures as 
well as Imagescans and Linescans. Thus normally this option should 
be switched on. 
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Exposure Choose this option to execute exposure steps of GDSII structures. 

The name of the GDSII structure is listed in the column Comment, 
the GDSII file is listed in the column File, and their destinations are 
defined as sample coordinates U, V within the Positionlist. In 
addition, the position can store information about a dose factor, step 
sizes, dwell times, the working area and layers. These parameters are 
described in more detail in section  Exposure. 

Execute macro Choose this option to execute macros and scripts. 

The name of the macro to be executed is listed in the column File 
within the Positionlist. 

7.3 Assigned Wafermap 
A Wafermap can be linked to a Positionlist so that by just pressing the 
corresponding button this Wafermap is opened. The corresponding 
information is stored within the Positionlist which serves like a 
master. To assign a Wafermap to on specific Positionlist choose the 
command File > Open assigned Wafermap … while the Positionlist 
window is active or choose the corresponding icon . Change then 
the Wafermap by open a new Wafermap. The command is File > 
Open while the Wafermap window is active. Finally save the 
Positionlist to make the change permanent. 

7.4 Positionlist preprocessor 
The following tabs exist: Matrix copy, WA Matrix, Move Positions, 
GDSII fracturing, and Find marks. Before applying one of the 
functions select first if All Positions or only the Selected positions 
will be processed. 

7.4.1 Matrix copy processor 
The Matrix copy processor serves to easily generate a position matrix 
consisting of a rectangular array positions. The result of this operation 
is a list of newly generated lines with the same setting but at different 
UV positions. 
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Figure 61: Window 
to define paramters 
for Matrix Copy 
processor. 

 

The related dialog has the following functionality: 

Matrix size Enter the numbers of positions in U and in V direction. 

Step size Enter the distances between adjacent positions in U and in V direction. 
The numbers may also be negative. In this case the copying action is 
performed into the negative U or V direction. 

Element order Select if copying in U direction or V direction is done first. 

Dose factor Choose this command to change also the dose factor for each position. 
This can be used to generate very easily a dose test. Set the dose 
change in U and V direction independently or select calculate 
automatically to have the same variation over the complete matrix. 
Select add or multiply to generate an arithmetic or a geometrical 
sequence. 

7.4.2 Working area (WA) matrix processor 
The WA matrix processor serves to generate a rectangular array of 
working areas. The result of the operation is a list of newly generated 
lines with the same GDSII only changing the working area and setting 
the correct UV positions. 

Figure 62: Window 
to define paramters 
for WA Matrix 
processor. 

 

The related dialog has the following functionality: 

Matrix size Enter the numbers of working areas in U and in V direction. 
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Design Start Point Select Working area to start with the currently used working area. 
Select Start point to define the point independently.  

Step size Enter the distances between adjacent working areas in U and in V 
direction. The numbers may also be negative. In this case the copying 
action is performed into the negative U or V direction. 

WA size Enter the size of the working areas in U and V. 

7.4.3 Move positions processor 
The Move positions processor serves to move positions to new UV 
coordinates. The result of the operation is the same positions but at 
different locations on the sample. 

Figure 63: Window 
to define paramters 
for Move Positions 
processor. 

 

The related dialog has the following functionality: 

Positions Select between a relative or absolute relocation of positions. 

Values Enter the values by which the position shall be relocated. 

7.4.4 GDSII fracturing processor 
The GDSII fracturing processor serves to fracture GDSII positions. 
The result of the operation is GDSII positions where each position is 
only a fraction of the original GDSII. At the same time the UV 
coordinates are shifted in such a way as if the original GDSII has been 
exposed. 
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Figure 64: Window 
to define paramters 
for GDSI fracturing 
processor. 

 

The related dialog has the following functionality: 

Fracturing area Select the area which will be fractured into smaller parts. Boundary is 
the boundary box of all GDSII elements in the corresponding 
structure. PLS Working area uses the currently within the 
Positionlist defined working area. User area opens the possibility to 
define a new area. 

Fracturing field size Select the size of the fragments. PLS write field is using the write 
field stored within the Positionlist. PLS working area is using the 
working area stored within the Positionlist. Please note when using 
this option and setting Fracturing area to PLS working area is 
cutting out the working area and storing the corresponding GDSII 
elements in a new database. Design working area opens the 
possibility to select a working area stored with the GDSII. By using 
User field it is possible to enter a field. Selecting PLS layer only is 
keeping only the layers stored within the Positionlist on the fractured 
GDSII. 

7.4.5 Find Marks processor 
The Find Marks processor serves to search GDSII positions and to 
generate from each write fields containing mark scans a separate 
position. The result of the operation is GDSII positions only with 
mark scans before the original GDSII. At the same time the UV 
coordinates are shifted in such a way as if the original GDSII has been 
exposed. 
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Figure 65: Window 
to define paramters 
for Find marks 
processor. 

 

The related dialog has the following functionality: 

Mark area Select the area which is search for the mark scans. Boundary is the 
boundary box of all GDSII elements in the corresponding structure. 
PLS Working area uses the currently within the Positionlist defined 
working area. User area opens the possibility to define a new area. 

7.5 Mouse and keyboard commands 
The usage is very similar to other spread sheet programs. A task can 
be selected by mouse click. The so selected task is marked by 
highlighting. A selection of groups or multiple lines is possible by 
applying the standard Microsoft Windows operations using the Shift 
respectively Control key. Whereas all tasks can be selected using 
Control + A. 

Double-click within task opens an object with is linked to this 
position. This can be a GDSII design within the GDSII viewer, an 
image which was taken at this position, or in the case of an alignment 
or adjustment task another Positionlist. 

 

To open the corresponding object, the software stores in the data field 
File a link to this object, e.g. filename and path of a GDSII. If the 
software can find this object, it opens a simple dialog to edit the data 
fields. This can be used to test, if the link to the object is broken. 

Using the right mouse button opens a menu where addition commands 
are available. 

Whenever a data line is selected and if a corresponding UV window 
has been opened in parallel, a related marker will be highlighted by 
flashing it three times. This enables a quick orientation on where an 
object of interest is located. 

The table below gives a summary of all available mouse commands 
within a Positionlist window. 
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Table 24: Mouse 
commands available 
within a Positionlist. 

Action Key(s) + Mouse 
Button 

Functionality 

Single 
click none + left Select line and unselect all other 

lines. 

Single 
click 

Control + left Select or unselect line without 
unselecting all other lines. 

Single 
click 

Shift + left Select all lines from the first 
selected one to the latest selected 
one and unselect all other lines. 

Single 
click 

none + right Open a menu with the commands: 
Open, Edit, Properties, Scan, 
New, Delete and Select all. 

Double 
click 

none + left Open a window related to the type 
of the line, e.g. an Imagescan, a 
Linescan, a GDSII viewer. 

7.6 Drag and drop 
A line can be copied or deleted by drag and drop technique: 

• To copy a line to another Positionlist, select it, move it to the other 
Positionlist and release the mouse button. 

• To copy a line within the same Positionlist, select it, move it to its 
new location by pressing the Control key. 

• To move a line within the same Positionlist, select it, move it to its 
new location. 

• To delete a line, drop it anywhere else within the program 
desktop. 

A task can be relocated using drag and drop technique as well by 
picking it up in the list and dropping it within any UV window. 

A summary of drag and drop operations is listed below: 
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Table 25: Positionlist 
drag and drop 
functionality. 

Source Object Target Action 

Positionlist line Positionlist Copy lines 

Positionlist line Image Redefine location of line 
using Image coordinates 
of mouse cursor as new 
location. 

Positionlist line Wafermap Redefine location of line 
using Wafermap 
coordinates of mouse 
cursor as new location. 

Positionlist line Program 
desktop 

Delete line. 

Scan 
Manager 

Procedure 
or Scan 

Positionlist Generate position with 
adjustment or alignment 
procedure or scan using 
current UV location. 

GDSII 
database 

Structure Positionlist Generate position with 
exposure line using 
current UV location. 

Automation File Positionlist Generate position with 
automation line with no 
stage movement, i.e. 
Options=STAY and 
U=V=0, Template=dUV 

Microscope Write field  Positionlist Generate position setting 
the selected write field 
with no stage movement, 
i.e. Options=STAY and 
U=V=0, Template=dUV 

Column 
Control 

Parameter 
set 

Positionlist Generate position setting 
the selected column 
parameters with no stage 
movement, i.e. 
Options=STAY and 
U=V=0, Template=dUV 

7.7 Configuration 
Using the command Edit > List properties, the Positionlist format 
can be configured for different applications. The default 
configurations within the Raith software are prepared to allow all 
standard tasks such as adjustment and alignment procedures, exposure 
runs and automation jobs. If the drag and drop technique is used, the 
all relevant parameters are transferred automatically into the 
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Positionlist. A reconfiguration is not necessary. But to customize the 
functionality of a Positionlist or for debugging purposes, it is essential 
to know the functionality of each column and of the stored data. 

For a general overview, the relevant Positionlist columns are sorted by 
the task they are reserved for. 

7.7.1 Universal columns 

Table 26: 
Functionality of 
universal columns. 

Column Functionality 

No. Serial numbers are set automatically by the software. 
They are used for addressing commands and to select 
a position. 

ID Identification number can be set by the operator. 
They are used for addressing commands and to select 
a position. 

X, Y, Z Cartesian stage coordinates, generally X, Y, in 
horizontal direction and Z in vertical direction. 
Values are given in mm. 

U, V, W Cartesian sample coordinates, generally U, V, in 
horizontal direction and W in vertical direction. 
Values are given in mm. 

R, T Rotation and tilt sample coordinates. Values are 
given in degree. 

Attribute A combination of letters is used to assign and 
identify task and status of the position. 
"X" identifies an exposure,  
"W" identifies an adjustment or alignment procedure, 
"I" identifies an Imagescan,  
"L" identifies a Linescan,  
"N" identifies a newly created position,  
"S" identifies a successfully scanned position, and 
"E" identifies an error. 
The attributes controlling the status ("N", "S", "E") 
are used for a color coded line indicator: a blue dot 
for "N", a green dot for "S", a red dot for "E". 

Template The template defines how the addressing of the stage 
is done. Use the letter of a coordinate to use the 
corresponding axis. Use a "d" in front to perform a 
relative drive command. For example for lithography 
tasks almost exclusively "UV" are used. 

Comment This column is automatically filled with additional 
information which is specific for one task. For 
example, in the case of an exposure task, it identifies 
the GDSII structure. 
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Options "STAY" or "DRIVE" to prevent or enforce a stage 
movement. 

Type The type is internally used to identify and 
differentiate between the various tasks. The type is 
automatically generated. The Raith software uses the 
following types: EBEAMSCAN, IMAGESCAN, 
SLOWSCAN, MACRO, EXPOSURE, 
ALWF_MANUAL, ALWF_AUTO, 
ALWF_AUTOLINE, ADUV_MANUAL, 
ADUV_AUTO, ADUV_AUTOLINE, MARKSCAN, 
AUTOSCAN, AUTOMARKSCAN, RMARKSCAN, 
RAUTOSCAN, RAUTOMARKSCAN, 
CALIBSCAN, VIDEOSCAN, REFMARKSCAN, 
GDSII_MAN, GDSII_AUTO) 

7.7.2 Linescans and Imagescans 
The following types are used in connection with Linescans and 
Imagescans: EBEAMSCAN, IMAGESCAN, SLOWSCAN, 
MARKSCAN, AUTOSCAN, AUTOMARKSCAN, RAUTOSCAN, 
RMARKSCAN, RAUTOMARKSCAN. 

Table 27 
Functionality of 
columns used by Scan 
Manager for 
Imagescans and 
Linescans. 

Column Functionality 

U, V Sample coordinates of the center of the scan. 

Attribute Has to be "L" in the case of a Linescan and "I" in the 
case of a Imagescan. 

Comment Name of the scan which is executed; has to be 
defined in the Scan Manager. 

Options "STAY" or "DRIVE" to prevent or enforce a stage 
movement. 

Size-U, 
Size-V 

Defines the scan length and width, e.g. of a mark, in 
sample coordinates. Data are given in micrometer. 

Points-U, 
Points-V 

Number of points, which can be defined freely up to 
4096 points. 

Dir Scanning direction of a Linescan in sample 
coordinates, i.e. U or V. 

Avg Number of point-by-point averaging. 

Pos1, Pos2, 
Pos3 

This column is used to store the result of a detection 
process, e.g. of the threshold algorithm.  
Pos3 may contain the line width, the center or, in the 
case this scan is linked to another one, the distance. 

Link By means of this column two scan can be connected 
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to each to calculate the distance between them. 
A link is used to configure long distance 
measurements between different entry points in the 
Positionlist. Based on a link between scanned and 
evaluated entries in the Positionlist, the distance may 
be either calculated between Pos1, Pos2, or Pos3 or 
combinations of it. It makes only sense to link 
Linescans of the same type and orientation. Links can 
be generated by text editing, graphically on any UV 
window. 

File Name of the file, which contains the scan. 

Time Seconds since 1/1/1970, i.e. UNIX timestamp. 

Timestamp Human-readable time when a scan was recorded. 

Angle Angle relative to the scanning direction under which 
scan is acquired. 

Mark-
Sequence 

 

7.7.3 Adjustment and alignment procedures 
The following types are used in connection with adjustment and 
alignment procedures: ALWF_MANUAL, ALWF_AUTO, 
ALWF_AUTOLINE, ADUV_MANUAL, ADUV_MANUAL, 
ADUV_AUTOLINE. 

Table 28: 
Functionality of 
columns used by Scan 
Manager for 
adjustment and 
alignment procedures. 

Column Functionality 

U, V Sample coordinates where the adjustment and 
alignment procedure starts. 

Attribute Has to be "W". 

Comment Name of the scan which is executed; has to be 
defined in the Scan Manager. 

Options "STAY" or "DRIVE" to prevent or enforce a stage 
movement. 

Size-U, 
Size-V 

Defines the scan length and width, e.g. of a mark, in 
sample coordinates. Data are given in micrometer. 

Dir Automatically set to U. 

File Link to the Positionlist containing the sub-tasks for 
the procedure. 

Mark-
Sequence 
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7.7.4 Exposure runs 
The type EXPOSURE is used in connection with an exposure run. 

Table 29: 
Functionality of 
columns used for an 
exposure. 

Column Functionality 

U, V Sample coordinates of the center of the first write 
field. 

Attribute Has to be "X". 

Comment Name of the structure which is exposed; has to be 
defined in the GDSII file. 

Options "STAY" or "DRIVE" to prevent or enforce a stage 
movement. 

Size-U, 
Size-V 

Gives the length and width of the exposed area only 
for information purposes. 

Pos1, Pos2 Half of the write field size. 

File Link to the GDSII file. 

Layer Layer which will be exposed; the layers are separated 
by "/", "," or ";". A range of layers is indicated by "-". 

Area The working area which will be exposed; the GDSII 
coordinates are separated by ";". 

DoseFactor A factor which is multiplied to the dose, i.e. the dwell 
times, prior to an exposure. 

Dwelltime Exposure dwell time in ms to be used for the 
exposure. If this column is empty, the dwell time is 
taken from the Exposure module. 

Stepsize Exposure step size in µm to be used for the exposure. 
If this column is empty, the step size is taken from 
the Exposure module. 

SplDwell Dwell time in ms for exposing single pixel lines. If 
this column is empty, the SPL dwell time is taken 
from the Exposure module. 

SplStep Step size in µm for exposing single pixel lines. If this 
column is empty, the SPL step size is taken from the 
Exposure module. 

DotDwell Dwell time in ms for exposing single pixel dots. If 
this column is empty, the dot dwell time is taken 
from the Exposure module. 

SplDot Flag controlling, if single pixel lines and a single 
pixel dots are exposed, if corresponding setting from 
the Exposure module is used. 
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7.7.5 Automation task 
The type MACRO is used in connection with an automation task. 

Table 30: 
Functionality of 
columns used for an 
automation task. 

Column Functionality 

U, V By default set to U=V=0.0 in combination with 
Template="dUV" to prevent stage from moving 

Attribute Has to be "M". 

Template By default set to "dUV" in combination with 
U=V=0.0 to prevent stage from moving. 

Options "STAY" or "DRIVE" to prevent or enforce a stage 
movement. 

File Link to the macro or script file to be executed. 
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The intensity, e.g. of the secondary electron, can be recorded and 
displayed within the Raith software as a function of the position. One 
has to distinguish between two different types. 

• Linescans: The intensity is recorded one-dimensionally. Even if 
several different cycles covering a certain area are recorded, in the 
end the results of each scan are summed up to an intensity curve 
as a function of the position along a straight line. 

• Imagescan: The intensity is recorded two-dimensionally. The 
intensity is given as function of a position on the sample within an 
area. A normal image is acquired. 

The main use of both types is detecting the position of marks, the 
performing CD, pitch, placement measurements, and for archiving the 
result after each process steps.  

8.1 Linescan window 
Figure 66: Linescan 
window displaying 
the intensity as a 
function of the 
position. 

The Linescan window is opened automatically whenever a Linescan 
has been started, when using the command File > Open Linescan, or 
when double-clicking on a scan with a Positionlist. 
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The title bar shows the file name. In the vertical axis, the measured 
intensity is displayed within the range form 0 to the maximum 
intensity. The horizontal axis shows the scan range in nm. Within the 
icon bar the following commands are available Edit > Open, Edit > 
Save, Edit > Print, Edit > Copy, Edit > Cross cursor, Filter > 
Select active filter, Filter > Apply active filter, Filter > Delete filter 
results, and Filter > Store filter results. 

8.1.1 File Menu 
Print Choose this command to print a Linescan. This command opens the 

default print dialog. This command is also available over the Linescan 
window itself. 

Open … Choose this command to load an existing Linescan. This command 
replaces the actually loaded Linescan by the newly selected one. This 
command is also available over the Linescan window itself. 

Save Choose this command to save the Linescan under its current name. 
This command is also available over the Linescan window itself. 

Save as … Choose this command to save the Linescan under a freely selectable 
name. 

8.1.2 Edit Menu 
Cross Cursor Choose this command to toggle between a mouse cursor and a cross 

hair. 

Copy Choose this command to copy the Linescan into the Window's 
clipboard. From here it can be pasted into another application, for 
example for documentation purposes. 

8.1.3 Filter Menu 
Apply active filter Choose this command to apply the selected filter and to display 

automatically the result. This command is also available over the 
Linescan window itself by pressing . 

Select active filter An additional drop-down menu appears. Choose here to define the 
active filter. An Overview over the available filters is given in section 

 Linescan filters. This command is also available over the Linescan 
window itself by selecting a filter from the drop-down list. 

Delete filter results Choose this command to delete the result of the selected filter. This 
command is also available over the Linescan window itself by 
pressing . 
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Store filter results Choose this command to store the result of the selected filter to the 
Positionlist. This command can only be used, if the Linescan was 
opened from a Positionlist. When using one of the threshold 
algorithms the left edge is stored in column Pos1, the right edge is 
stored in column Pos2, and the width or position is stored in column 
Pos3. This command is also available over the Linescan window itself 
by pressing . 

8.1.4 Linescan filters 
In the following it is described, how a Linescans can be processed, for 
example to reduce the noise, and how a specific structure can be 
found, for example a maximum in the intensity. 

Post-processing filters 

Very often not only a recording but also a processing is required. The 
setup of these parameters is described in the following. It is important 
to know that these filters modify the data itself. Thus it is not possible 
to switch back to the unmodified data after applying one of these 
filters. 

Noise reduction Choose this filter to perform a numerical averaging after recording the 
data. Two parameters define the averaging. Number of average 
points is used to define over how many points along the scan direction 
the average is calculated. Whereas Number of iterations defines how 
often the averaging is done. 

Offset correction Choose this filter to subtract a background. The calculation is done in 
such a way that the minimum of the intensity is set to zero. 

Derivate Choose this filter to calculate the derivation of the intensity signal. 

Finding structures 

After recording and optionally processing, Linescans can be evaluated 
also for line width, position, and distance measurements. It is 
important to know that these filters do not modify the data itself. 
These filters store only the result of the evaluation. 

Check Amplitude Choose this filter to verify that the intensity is larger than a certain 
level. A typical application would be search for a structure and to 
identify those locations on the sample where the structure is missing. 

Peak detection Choose this filter to identify a peak structure within the recorded data 
for an example to determine its width. Select first the Edit button  
to set the parameters for the peak detection algorithm. A detailed 
description of the parameters is given in section  Threshold 
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algorithm. After selecting these parameters activate the option and 
define if the position or the width should be stored. 

Edge detection Choose this filter to search for an edge within the recorded data for an 
example to determine its position. Select first the Edit button  to 
set the parameters for the edge detection algorithm. A detailed 
description of the parameters is given in section  Threshold 
algorithm. After selecting these parameters activate the option and 
define if the position or the width should be stored. 

Pitch detection Choose this filter to search for an edge within the recorded data for an 
example to determine the distance between two edges. Select first the 
Edit button  to set the parameters for the pitch detection algorithm. 
A detailed description of the parameters is given in section  
Threshold algorithm. After selecting these parameters activate the 
option and define if the position or the width should be stored. 

Cross correlation Choose this filter to compare the measured intensity with a previous 
recorded intensity. Therefore this option is very helpful when a 
irregular shape of a structure prevents the operator from using another 
algorithm. Select first the Edit button  to set the parameters for the 
cross correlation algorithm. A detailed description of the parameters is 
given in section  2-dimensional mark detection. After selecting these 
parameters activate the option. The result of the algorithm can only be 
a position. Therefore, the Check detected width option is disabled, 
when selecting this option. 

Check detected width If a structure with a certain width was scanned, this filter can be used 
to verify that the width is of a certain size. Therefore this option is 
helpful to identify such structures which are too small or too large. 

8.1.5 Mouse and keyboard commands 
Use Control + C to copy an image of the Linescan into Window's 
clipboard to paste it then into any other application. 

Use Control + O to load an existing Linescan into current window. 

Use Control + S to save current Linescan. 

Use the right mouse button to sequentially set two marks within the 
Linescan. These marks can be for example edges or significant 
features. The positions of these two marks are indicated by two red 
lines and are stored together with the Linescan. 

Use the left mouse button and move the mouse to zoom into the 
Linescan data. Thus it is possible to have a closer look onto a specific 
substructure. Use the left mouse button again to zoom out. 



 8.2 Imagescan window 

 127 

Table 31: Mouse 
commands available 
within a Linescan. 

Action Key(s) + Mouse 
Button 

Functionality 

Single 
click 

none + right Sets sequentially two marks to 
define manually edges, etc. 

Drag none + left Zoom into Linescan data. To zoom 
out press left mouse button again. 

8.2 Imagescan window 
Digital images can be acquired and displayed conveniently within the 
Raith system by making use of the high resolution scan generator. The 
main use of the image acquisition for lithography applications is 
related to mark recognition which is an essential part of every 
lithography task. 

The image acquisition commands within this mode make use of the 
high resolution scan generator. The images are acquired with the 
current scan calibration, i.e. write field zoom, shift, and rotation. In 
addition, the images are displayed in UV-coordinates.  

The link to the absolute sample coordinate system is detected from the 
position sensing system of the sample stage. The operator has access 
to this transformation in the status bar when moving the cursor over 
the image window. The status bar displays the sample coordinates 
UV, the stage coordinates XY, and the window coordinates. Scaling is 
indicated by scale bars in the lower left corner of the Image window. 

The images are handled as UV windows allowing addressing, drag 
and drop, overlay options. 

8.2.1 File Menu Commands 
Close Choose this command to close the activated image. 

Close all images Choose this command to close all opened images. 

Save image Choose this command to store the activated image under its current 
name. File format is BMP or TIFF due to the "Picture file format" 
settings within the Imagescan Options dialog (see command Options 
> Imagescan). 

Save image as Choose this command to store the activated image under a freely 
selectable name. File format is BMP or TIFF due to the "Picture file 
format" settings within the Imagescan Options dialog (see command 
Options > Imagescan). 

Print Choose this command to print out the actually viewed area of the 
Image. 
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New image Choose this command to open a new image window. The image size 
is automatically set to the write field size from the Microscope 
control. The image location in sample coordinates is taken from the 
stage control unit. 

Open image Choose this command to open an existing image. 

8.2.2 Edit menu 
Copy Choose this command to copy the active image into the Microsoft 

Windows clipboard. This allows pasting the image directly into a 
different application. 

Image information Choose this command to show position, size and scan resolution of the 
activated image. Values for image position and size can be edited. 

Adjustment Command common to all UV windows, described in section  UV 
Windows. 

Measure Command common to all UV windows, described in section  UV 
Windows. 

8.2.3 View menu 
Redraw Command common to all UV windows, described in section  UV 

Windows. 

Zoom A cascading menu opens with additional commands, described in 
section  UV Windows. 

Overlays Command common to all UV windows, described in section  UV 
Windows. 

Toolbox Command common to all UV windows, described in section  UV 
Windows. 

8.2.4 Options menu 
Histogram Choose this command to show the distribution of gray levels. 

Imagescan Choose this command to set image scan parameters. 
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Figure 67: Dialog to 
set Imagescan 
parameters. 

 

The related dialog box allows to set and to change the Imagescan 
parameters. These Imagescans are scanned with the scan generator 
unit and are based on the alignment of the write field. The scan size is 
the selected write field size. 

The dialog box has the following functionality: 

Scan resolution Enter the number of pixels along the U and V axes. The number of 
pixels must be from 64 up to 4096. Select Keep aspect to record a 
quadratic image. 

Display If Invert Palette is selected, the inverted gray level palette is 
displayed on the screen. Otherwise the original gray level palette is 
displayed. This setting will be saved within the image file. 

Average Enter the number of Point-By-Point averaging cycles, which results 
in a multiple intensity sampling at each individual point to enhance 
the signal-to-noise ratio. 

Enter the number cycles and choose either Line integration, Frame 
integration and Frame averaging for signal averaging by multiple 
scans. If Frame integration is chosen, the entire image is scanned as 
often as defined by the number of averaging cycles. After finishing a 
cycle and if continuous scanning has been selected, the integration 
starts from the beginning with a noisy image. If Frame averaging and 
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continuous scanning is chosen, the entire image is averaged over the 
last scanned images as often as defined by the number of averaging 
cycles. If Line integration is chosen, each line is scanned as often as 
defined by the number of averaging cycles. 

Picture file format Choose one of the file format option buttons for 
storing of the scanned image. Choose TIFF compression to compress 
the data in the case that the Tagged Image Format (TIF) is used. 

Overlay options Select Include to store overlays together with the image. In this case, 
choose between Scaling bars only and All overlays, i.e. overlays of 
Positionlists, GDSII elements, etc. In addition, it is possible to include 
a comment: the image name, the image position, the date and time, or 
the image size. Select 256 to store a colored image. If overlays are 
included, the overlay information is stored within the image itself. 
Hence, a post-processing of this image, e.g., image filter, can not 
applied etc. 

Scale Image Choose this option to display the Imagescan in such a way on the 
screen that one image pixels correspond to one screen pixel. This 
option has to be set for each opened Image window individually. 

Cursor grid Select the step size the cursor can be moved in an image. 

UV display… Command common to all UV windows, described in section  UV 
Windows. 

8.2.5 Imagescan menu 
Continuous Choose this command to start a continuous image scan at the actual 

sample coordinate. 

Single Choose this command to start a single image scan at the current 
sample coordinate. 

Stop Choose this command to stop an image scan immediately. 

8.2.6 Filter menu 
Matrix Filter This command can be used for post-processing images. After 

choosing a dialog opens to type in a matrix or to select a predefined 
matrix from a list. The filter works in such a way that the given matrix 
is folder with the image which is also interpreted as a matrix. The 
result is then stored back to the image. For example folding the matrix 
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 with an image is equivalent to an averaging over 

all neighbors of each pixel. 

Mark Detection This command can be used for detecting a structure and its deviation 
from a reference position by comparing tie image with a reference 
image. Its functionality is described in section  2-dimensional mark 
detection. 

8.3 Evaluation algorithms 
In this section the theoretical background of the various algorithms is 
described. 

8.3.1 Threshold algorithm 
The basis for the peak detection, the edge detection, or the pitch 
detection is a threshold algorithm. The idea of the threshold algorithm 
is that in all three cases the intensity has to go through two levels or 
thresholds. Within Figure 68 these two thresholds are indicated by two 
green lines. The usage of two levels makes the algorithm more robust 
because simple outlier can be filtered out by setting the second 
threshold high enough. 

Figure 68: Linescan 
after applying the 
Threshold Algorithm 
to determine the 
center of this double 
peak structure. 
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The range between the intersections of threshold levels with the 
intensity slope is called an edge. The boundaries of the two edges are 
indicated in Figure 68 by gray lines. The actual position of an edge 
can be defined between these boundaries. The position is marked by 
red lines in Figure 68. 

After detection two edges it is then possible to calculate the distance 
or the center between them. The distance or the center can be 
interpreted for example as the width or as the position of a structure 
on the sample. For example the center of the double peak structure in 
figure is marked by a yellow line and its numerical value is given too. 

The threshold algorithm can be modified by several parameters. All 
these parameters together form a set which is stored under one name. 
In all three cases, i.e. for the peak detection, for the edge detection, 
and for the pitch detection, these parameters are very similar so that 
they are described in the following together. 

Setting up threshold algorithm 

The threshold parameters can be accessed from several points within 
the software. The way described in the following has the advantage 
that different parameters can be tried out while a pre-recorded 
Linescan has been opened beforehand. 

STEP 1 ► Open a pre-recorded Linescan by using File > Open Linescan. Some 
example Linescans come with the software. 

STEP 2 ► Choose the command Filter > Select active Filer to select the 
Threshold filter for detecting a peak or valley, the Edge detection or 
the Pitch detection filter. 

STEP 3 ► Choose the command Filter > Apply active Filer to open the window 
for setting up the parameters. 
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Figure 69: Parameter 
set window to define 
threshold algorithm 
for Peak Detection. 

 

STEP 4 ► Select the name of an existing Parameter set or, if a set with 
appropriate parameters does not exist, create a new set by choosing 
the New icon. 

STEP 5 ► Select the following parameters for the threshold levels, the edges and 
the structure type to define the measurement. 

Mode Select a relative or absolute definition of the threshold values. 
Normally, relative definition is the more robust detection, because the 
success depends not on the signal brightness and contrast. But to 
discriminate out scans achieving not a certain signal level, it can make 
sense to use an absolute definition. 

Lower, Upper Type in the threshold values either from 0% to 100% in the relative 
definition or from 0 to the maximum intensity in the absolute 
definition mode. Press Apply to see the current threshold levels as 
horizontal, green lines. 

Left, Right Choose which edges are defining the structure and from which 
direction the algorithm is searching for these edges. This setting 
becomes important if more than one peak is present within the 
Linescan or when determining the pitch of a grating. The intersections 
of the intensity curve with the two threshold levels define a range on 
the position axis. To calculate the position of the edge within this 
range use the at parameter. A value of 50% means the edge is in the 
center of this range, whereas a value 0% or 100% means at the left or 
the right border of the range. 
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Type Select either "minimum" or "maximum" from the drop-down list box, 
if the structure is defined by a minimum or a maximum in the 
intensity slope. 

Width range Using this setting, it is possible to reject structures which are too small 
or too large. This function limits the range the algorithm is searching 
for the second edge after finding the first edge. If the second edge is 
not found within this range, the algorithm sets the error flag and 
position of the edges as well as the center, the size, or the pitch are not 
calculated. 

Display Choose this option to display the width or the center between the two 
edges numerically as well as by a yellow line. This option effects only 
what is display, but not the information which is stored in a 
Positionlist. 

STEP 6 ► After finding a parameter set press Apply to start a measurement. 

STEP 7 ► Choose save to store the optimum parameter set under the current 
name. 

 

Sometimes it is very difficult to find the correct parameter set for the 
threshold algorithm, especially when dealing with a new Linescan. In 
this case it is recommended to scan first one exemplary scan, open this 
scan by using File > Open Linescan or by double-clicking it in a 
Positionlist, and to start the Threshold algorithm by using the 
commands Filter > Select active Filer and Filter > Apply active 
Filer. In this case the Apply button is accessible applying the current 
parameters to Linescan. This makes it easy to try out various 
parameters and, if the right set is found, it can be stored and recalled 
for later usage. 

8.3.2 2-dimensional mark detection 
This algorithm compares two Images with each other. The result of 
the comparison is first whether a structure is present in an image and 
secondly how far the structures in the two images are shifted with 
respect to each other. Such a shifted structure and its reference are 
shown in Figure 70. 
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Figure 70: Two SEM 
images of the same 
structure, the 
reference (left) and 
the shifted structure 
(right).  

 

A very similar algorithm is available for Linescans too. Here it is 
called Cross Correlation and its working principle is the same for 
Images. Thus, only the two-dimensional case is described in the 
following. 

By comparing the images in Figure 70 the challenges for such an 
algorithm are clearly visible. A robust algorithm has to be able to 
overcome 

• contrast and brightness variations, 

• image distortions, like rotations and different scaling, 

• visibility variations, e.g. structures might be only partially visible 
or even missing, 

• and the background noise should not affect the comparison.  

In the literature two different algorithms are discussed. 

• The approach of a pure cross correlation has the disadvantage that 
it requires in general a pre-processing to detect larger shifts, 
because only small shifts are detected reliable. 

• The approach of a pure deconvolution has the disadvantage to be 
very sensitive on noise such a careful noise-reduction is required 
beforehand. 

In this software an implementation is used combining the advantages 
of both approaches meaning that it is a combination of the cross 
correlation as well as the deconvolution. In the following this 
approach is described as far as it is necessary to understand and to use 
the software. 

The starting point is the assumption that the shifted image can be 
calculated by using the following equation 

"shifted image" = "reference image" × δ(u-u0, v-v0) + "noise". 
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Herein × labels the convolution of two images and δ(u-u0, v-v0) is the 
two dimensional δ-function which is shifted by u0 und v0. The term 
"noise" summarizes all sources of noise, e.g. the background noise 
visible in all SEM images, the different appearance of the two images 
can also be interpreted as noise, and the noise which comes from the 
fact that during the calculations periodic boundary values are used. In 
general, "noise" should be an image too, but for our purpose a real 
number representing the strength of noise is sufficient and thus 
making the calculation much easier. 

After calculating the Fourier transformation of "shifted image" as well 
as "reference image" and by giving the quantity "noise" the algorithm 
calculates the image δ(u-u0, v-v0). It is important to understand, that 
the so calculated δ depends on the "noise" and one has to search for 
the optimum δ by varying the "noise". Fortunately, the here 
implemented algorithm depends not critically on the exact value of 
"noise" and a value nearby gives a sufficient result. After finding the 
optimum δ u0 and v0 are determined by using the coordinates of the 
maximum intensity in the δ image. 

When using this detection algorithm automatically, it is very 
important to distinguish a successful detection of a structure from 
unsuccessful ones. An unsuccessful might occur, when for example a 
structure is completely missing. In this case the real noise is much 
larger than that one given by the quantity "noise" and a not optimum δ 
is calculated. By using the maximum intensity of δ in comparison to 
the variation of the intensity values in δ and the extension of the 
maximum peak a quality is calculated. Its values can be between 0.0 
and 1.0 corresponding to a perfect δ. By setting a threshold for this 
quality it is possible to discriminate out unsuccessful comparisons 
between the two images. 

Even if the comparison of two images was successful, it might be 
necessary to react on a shift which is too large. In this case, it is 
possible to define in addition a maximum allowed shift. 

Setting up mark detection 

The cross correlation parameters can be accessed from several points 
within the software. The way described in the following has the 
advantage that different parameters can be tried out while a pre-
recorded Image has been opened beforehand. 

STEP 1 ► Open a pre-recorded Image by using File > Open image. Some 
example images come with the software. 

STEP 2 ► Choose the command Filter > Mark detection to open the window 
for setting up the parameters. Figure 71 shows this window. 
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Figure 71 Window to 
define parameters for 
Mark detection 
filter. 

 

STEP 3 ► Select the name of an existing Parameter set or, if a set with 
appropriate parameters does not exist, create a new set by choosing 
the New icon. 

STEP 4 ► Select the reference image by using the Open Icon. 

STEP 5 ► For the first attempt choose a Noise of 100.0 and Max. shift of 90% 
of the image width. 

STEP 6 ► Select Show shift image and press Apply to calculate the δ image its 
Quality. 

STEP 7 ► Change Noise and press Apply again to find the largest value for the 
Quality and thus optimizing δ and therefore the mark detection. 

STEP 8 ► After finding the optimum value for noise, set Max. shift. The 
calculated shift is given in micrometer. 

STEP 9 ► Choose save to store the optimum parameter set under the current 
name. 
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The Scan Manager is a supporting tool which allows to define and to 
locate intensity recordings. These recordings are then used during 
more complex tasks, like dimensional metrology jobs or write field 
alignments. These tasks are described in other sections: adjusting the 
sample to the stage is described in section  Stage to sample 
adjustment, aligning a write field is described in section  Beam to 
sample alignment and during an exposure in section  Exposure. 
Within this chapter the focus lays on recording intensity, processing 
these intensities and using them for dimensional metrology jobs. 

9.1 Scan manager 
The various parameters can be individually stored for the various scan 
types. The organization of this is done in hierarchical way within the 
scan manager section of the control bar. For dimensional metrology 
jobs the following general scan types are available. 

• Type Linescans, i.e. scans made along one direction by an 
electron or an ion beam. These scans are used for measurements 
of positions and distances between structures. But can also be 
used for line width measurements, if an exact line width 
determination is not critical. 

• Type Images. These scans are used for recording images for 
example for off-line inspection or documentation purposes. 

• Type Image Linescans. These scans are used for measurements of 
positions or distances in images. Hence, measurements are 
possible in an off-line manner. 

• Type Calibration Linescans. These scans are used for 
measurements of line widths of structures where the exact line 
width determination is critical, e.g. as in CD measurements. 

9.1.1 Mouse commands 
Clicking with the right mouse button on one of the scan types or the 
scans themselves opens a small menu with the same commands as 
given under the Edit menu. 
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9.1.2 Drag and Drop 
Each of the scans can be placed within all UV windows or a 
Positionlist by using the drag-and-drop technique. When using an UV 
window as destination, the scan is stored in all open Positionlists. If no 
Positionlist is open, one is generated automatically. 

9.2 Defining Linescans 
A Linescan is recorded by moving the beam along one scan direction 
and measuring the intensity at each point. This scan direction is called 
the main direction. It can be along U- or V-direction as well as under 
an angle. In addition it is possible to average the intensity of several 
beam movements by defining a scan size perpendicular to the scan 
main direction. In the end, a Linescan is a single waveform showing 
the measured intensity versus a scan direction. 

After recoding the intensity it is possible to perform a post-processing, 
for example noise reduction, as well as a subsequent evaluation, for 
example peak detection. 

Starting from the scratch the first step is to define a new parameter set. 

9.2.1 Basic settings 
STEP 1 ► Select type Linescans and choose menu command Edit > New to 

create a new parameter set. Alternatively use the right mouse menu. 

STEP 2 ► In the following properties window define the name for this Linescan 
using the corresponding input field.  

STEP 3 ► Choose the tab Main to set the following Linescan parameters. 

Main Direction Select the primary scan orientation to be either in horizontal, i.e U-
direction, or vertical, i.e. V-direction.  

Scan Size Enter the length of the scan in µm. In general the scan size in the main 
direction is larger than in the averaging direction. Keep aspect 
ensures that if one of the scan sizes is changed the other is 
automatically scaled, such that the ratio between is constant. Please 
note, that for an finite scan size No. of Pixels must be larger than 1. 
Maximum scan size in is the current write field size. 

Step size It is possible to define the distance between two points in µm. For the 
main direction the step size defines then the minimum resolution of 
the Linescan. For the averaging direction this defines the distance 
between two separate beam movements which are then summed up for 
averaging. Step size is a multiple of Basic Step size which is defined 
in Exposure > Details. 
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No of pixels It is possible to define the number of pixel along the main as well as 
the averaging direction. Maximum scan size in pixel is 4096 minus the 
number of pixels used to compensate dynamic effects. In addition, No 
of pixels has to be a value which can be divided by 4 without a 
remainder, because in such a way images are handled internally within 
Windows. 

Scan size, Step size, and No. of Pixels depend on each other because 
the Scan size is the product of the two others. Consequently, the third 
value can be calculated after setting the two other quantities. Use the 
calculator button behind the value to perform the calculation. A 
message indicates, if these three values fit to each other. If this is the 
case, it is possible to confirm these settings by pressing OK. 

 

Scan size and Step size are quantities, which are normally given by 
the scan task itself, and therefore should be defined first. No of pixels 
can then be calculated. Because of the restriction that No of pixels is 
equal to Scan size / Step size, it can be necessary to calculate the 
other quantities in the following. 

Point average This parameter allows signal averaging by measuring the intensity at 
the same position several times. Therefore it is used to enhance the 
signal-to-noise ratio. 

Angle Choose the angle to record a Linescan under a certain angle. The 
angle is defined relatively to the main scan so that it can only be 
varied in the range between ±45°. 

9.2.2 Advanced settings 
STEP 1 ► Choose the tab Advanced to add additional parameters. 

Attribute Enter a character to be added to the column "Attribute" of the 
Positionlist when dropping the scan into a target window. Please note 
that some characters have a special meaning and can not be used. By 
default the character L is used assuring that the scan is defined as a 
Linescan and the character N marks it as a new one. If other characters 
shall be used in addition make sure that also L and N are used. 

Position This parameter defines the addressing mode of the scan. Absolute 
means that the stage drives to the position of the scan when dropped 
into a Positionlist. Relative means that the addressing is done with 
respect to the current stage position and the beam is deflected within 
the write field without driving the stage. If this mode is selected it is 
under the responsibility of the operator to type in the distance for the 
stage movement in U and V-direction. 

Options Within this input field it is possible to define some options for the 
execution of the scan. For a typical Linescan the stay option is the 
only important one. Please not this option is placed automatically 
when selecting stay at position. 
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stay at position Choose this option to prevent the stage from driving. This option can 
be used in connection with relative positioning. 

halt before closing Choose this option to halt execution which is useful for debugging 
purposes through the operator. 

save scan before closing  Choose this option to save the scan for example for 
documentation or off-line evaluation. 

STEP 2 ► Choose OK button to quit the scan property definition and to save the 
new parameter set. 

9.2.3 Processing Linescans 
Very often not only a recording but also a processing is required. The 
setup of these parameters is described in the following. 

STEP 1 ► Select one Linescan. 

STEP 2 ► Choose the menu command Edit > Properties to open the property 
window or alternatively double click the scan using the left mouse 
button. Select the tab Post Processing. 

STEP 3 ► Choose Noise reduction, Offset correction, Derivate to modify the 
Linescan directly after recording it. The functionality is described in 
section  Post-processing filters. 

STEP 4 ► Choose OK button to quit the scan property definition and to save the 
new parameter set. 

9.2.4 Evaluating Linescans 
After recording and optionally post-processing, Linescans can be 
evaluated also for line width, position, and distance measurements. 

STEP 1 ► Select one Linescan. 

STEP 2 ► Choose the menu command Edit > Properties to open the property 
window or alternatively double click the scan using the left mouse 
button. Select the tab Evaluation. 

STEP 3 ► Choose Check Amplitude, Peak detection, Edge detection, Pitch 
detection, Cross correlation, Check detected width to evaluate 
some of the Linescan properties. The functionality is described in 
section  Finding structures. When using Peak detection, Edge 
detection or Pitch detection it is possible to determine which quantity 
is stored by selection either Store position or Store width. The 
position is the center between the two edges whereas the width is the 
distance between the two edges. 
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STEP 4 ► Choose OK button to quit the scan property definition and to save the 
new parameter set. 

9.3 Defining Images 
An Image is recorded by moving the beam along two scan directions 
and measuring the intensity at each point. At each point it is possible 
to average the intensity by measuring the intensity several times. 

After recoding the intensity it is possible to perform a post-processing, 
for example noise reduction, as well as a subsequent evaluation, for 
example peak detection. 

Starting from the scratch the first step is to define a new parameter set. 

9.3.1 Basic settings 
STEP 1 ► Select type Image and choose menu command Edit > New to create a 

new parameter set. Alternatively use the right mouse menu. 

STEP 2 ► In the following properties window define the name for this image 
using the corresponding input field. 

STEP 3 ► Choose the tab Main to set the following Image parameters. 

Scan Size Enter the size of the scan in µm. This size is used for both directions. 
Please note, that for a finite scan size No. of Pixels must be larger than 
1. Maximum scan size in is the current write field size. 

Step size It is possible to define the distance between two points in µm. The 
step size defines then the minimum resolution of the Image. Step size 
is a multiple of Basic Step Size defined in Exposure > Details. 

No of pixels It is possible to define the number of pixel. Maximum scan size in 
pixel is 4096 minus the number of pixels used to compensate dynamic 
effects. 

Scan size, Step size, and No. of Pixels depend on each other because 
the Scan size is the product of the two others. Consequently, the third 
value can be calculated after setting the two other quantities. Use the 
calculator button behind the value to perform the calculation. A 
message indicates, if these three values fit to each other. If this is the 
case, it is possible to confirm these settings by pressing OK. 

 

Scan size and Step size are quantities, which are normally given by 
the scan task itself, and therefore should be defined first. No of pixels 
can then be calculated. Because of the restriction that No of pixels is 
equal to Scan size / Step size, it can be necessary to calculate the 
other quantities in the following. 
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Point average This parameter allows signal averaging by measuring the intensity at 
the same position several times. Therefore it is used to enhance the 
signal-to-noise ratio. 

Average Choose either Line-by-Line or Frame-By-Frame for signal 
averaging by multiple scans. If Line-by-Line is chosen, each line is 
scanned as often as defined as defined by Average Count before 
applying the average algorithm. If Frame-by-Frame is chosen, the 
entire image is scanned as often as defined by Average Count before 
applying the average algorithm. 

9.3.2 Advanced settings 
STEP 1 ► Choose the tab Advanced to add additional parameters. 

Attribute Enter a character to be added to the column "Attribute" of the 
Positionlist when dropping the Image into a target window. Please 
note that some characters have a special meaning and can not be used. 
By default the character I is used assuring that the scan is defined as 
an Image and the character N marks it as a new one. If other 
characters shall be used in addition make sure that also IN are set. 

Position This parameter defines the addressing mode of the Image. Absolute 
means that the stage drives to the position of the scan when dropped 
into a Positionlist. Relative means that the addressing is done with 
respect to the current stage position and the beam is deflected within 
the write field without driving the stage. If this mode is selected it is 
under the responsibility of the operator to type in the distance for the 
stage movement in U- and V-direction. 

Options Within this input field it is possible to define some options for the 
execution of the scan. For a typical Image the stay option is the only 
important one. Please not this option is placed automatically when 
selecting stay at position. 

stay at position Choose this option to prevent the stage from driving. This option can 
be used in connection with relative positioning. 

halt before closing Choose this option to halt execution which is useful for debugging 
purposes through the operator. 

save scan before closing Choose this option to save the scan for example for 
documentation or off-line evaluation. 

STEP 2 ► Choose OK button to quit the scan property definition and to save the 
new parameter set. 
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9.3.3 Post-processing Images 
Very often not only a recording but also a processing is required. 
Several functions to process images are implemented and the 
parameters of these functions are described in the following. 

STEP 1 ► Select one Imagescan. 

STEP 2 ► Choose the menu command Edit > Properties to open the property 
window. Select the tab Post Processing. 

STEP 3 ► Choose Image filter to modify the Image directly after recording it. 
The functionality is described in section  Imagescan window. 

After recording and optionally post-processing, it is possible to detect 
within an image a structure and to determine the deviation of a 
structure with respect to a reference structure. 

STEP 4 ► Choose Mark detection filter. The functionality is described in 
section  2-dimensional mark detection. 

STEP 5 ► Choose OK button to quit the scan property definition and to save the 
new parameter set. 
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It is typical for nearly all application tasks to find a specific location 
on a sample and then for example to expose at this location a GDSII 
structure. To find this location it is very convenient to apply a 
coordinate system to the sample. Finding this location is then in 
general simply a drive command within this coordinate system. In 
reality the success depends on the accuracy of the applied 
transformation, on the accuracy of the stage and last but not least on 
the required accuracy. 

The various possible coordinate systems turn out to be a difficult 
topic. To give an overview, the first part of this chapter introduces the 
various coordinates systems and transformations between them. 

 

Please note that throughout the software and manuals the terms 
"adjust" or "adjustment" are used only in connection with the 
transformation between stage and sample. The term "alignment" is 
used in connection with the transformation between sample and beam.

10.1 Coordinate systems and 
transformations 
To find a location it is very convenient to apply a coordinate system to 
the sample. For example the center of a wafer is (0, 0) and an axis of 
this coordinate system is pointing towards the flat. Within the Raith 
software this sample coordinate system is labeled with U, V, and W. 
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Figure 72: As an 
example, the sample 
coordinates U, V 
defined on a wafer. 

 

On the other side the stage of the system is moving in another 
coordinate system. The directions of the stage movements define this 
coordinate system. The directions of this coordinate system are 
labeled throughout this manual and the software by X, Y, and Z. 
These coordinates are oriented perpendicular to each other. Normally 
(0, 0) of this system is the center of the travel range and the X axis is 
then arbitrarily selected as one of the motor axis. 

Figure 73: Sketch of 
stage coordinates X, 
Y, Z. 

In the most cases these two coordinate systems are not identical. The 
two coordinate systems may have different origins, causing an offset 
vector. Additionally, the U, V, W system may be rotated against the 
X, Y, Z system and the systems may have different scales. 
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Figure 74: Stage 
sample coordinates 
transformation. 

In conclusion, a coordinate transformation has to be calculated, so that 
it is possible to drive to a specific location on a sample. How this 
transformation fits into the scheme of coordinate systems is shown in 

 Figure 75. 

Figure 75: Stage 
sample coordinates 
transformation A. 

But not all applications require a full transformation with two scaling 
factors, one shift vector, and two angles. Therefore, it is possible to 
use the coordinate transformation in several degrees of complexity. It 
is now absolutely important to know which application requires which 
coordinate transformation and to understand how the various functions 
work. The Adjust UVW (see  Figure 76) contains all commands to 
setup and establish the various transformations between the X, Y, Z 
system and the U, V, W system. 

After defining some term, this chapter describes two applications with 
increasing complexity as a guideline. 
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10.2 Adjust UVW 
Figure 76: Part of the 
Adjust UVW used to 
calculate the 
transformation 
between U, V, W and 
X, Y, Z. 

 

Reset Choose this command to reset the transformation to the identity 

transformation. Alternatively, choose the  button in the symbol 
bar. 

Adjust Choose to calculate and establish the coordinate transformation. 

Read Choose this button to read the current X, Y coordinates and store them 
in the corresponding input fields. 

 Choose this action button to drive to the corresponding position. 

   Choose the blue flags to read the X, Y coordinates from a UV 
window. To do so, open a calibrated image, choose the corresponding 
flag, and drop it into the image. 

10.3 Global and local transformations 
Within the Raith software two different transformations exist. The 
first one is called global transformation and the second one local 
transformation. To motivate the introduction of two different 
transformations, it is intuitively to look for example at a wafer 
application. When working on wafers it is very convenient to use two 
independent coordinate transformations. The first coordinate 
transformation can be attached to the wafer itself whereas the second 
transformation serves for navigation within a chip. 

The global and local transformations are defined only between the X, 
Y, U, and V. There is neither a global nor local transformation 
between Z and W. 
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--> Local, --> Global Choose this commands in the Adjust UVW to switch between the 
global transformation and the local transformation at any time. In 
addition it is possible to switch between them by choosing the related 

buttons   in the icon bar. The icons as well as the window title 
display the current status. 

For both global and local transformation a complete set of 
transformation parameters are stored. In addition, these sets include 
also the locations of for the marks which were used to calculate the 
transformations. Switching between global and local activates one of 
these sets. 

But the global and local transformations are not independently from 
each other. The following relationships exist between them. 

• Any action performed while the global transformation is active 
effects also the local transformation with the same action. 

• Any action performed while the local transformation is active has 
no impact on the global transformation. 

Example 
Switching to the global transformation and pressing than Adjust 
calculates also the local transformation with same transformation 
parameters. Switching to the local transformation would then make no 
difference. 
Changing then some coordinates and pressing Adjust, calculates a 
new local transformation totally independent from the global one. 
After switching back to the global transformation it is possible to use 
the global one again. 

10.4 Transformation with 1, 2, or 3 points 
Again the following information applies to the transformation between 
X, Y, U and V only. 

In general, a coordinate transformation can be established using 3 
points, 2 points, or 1 point only. How many points are adequate, 
depends on the application. To select the number of points, use the 
tick boxes in front of each blue flag within the Adjust UV (see  
Figure 76). 

• Using 1 point only. By defining X, Y, U and V at one location on 
the sample it is possible to calculate the shift between the two 
systems. Other transformation variables are not affected. An 
alternative is using the Origin Correction tab. On this tab one has 
to specify U and V only and when pressing Adjust the current X 
and Y coordinates are used. 
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• Using 2 points. By defining X, Y, U and V at two locations on the 
sample it is possible to calculate the shift, one rotation angle and 
one scaling factor between the two systems. The rotation angle 
and the scaling factor are applied to both axis in the same way, i.e. 
both axis are rotated and scaled by the same amount. An 
alternative is using the Angle Correction tab, but the 
functionality is quit the same. At each point X and Y are defined 
assuming that both locations lie on the U axis. Thus only one 
rotation angle can be calculated which is applied to both axis. The 
other transformation parameters are not affected. 

• Using 3 points. By defining X, Y, U and V at three locations on 
the sample it is possible to calculate the shift, two rotation angles 
and two scaling factors between the two systems. The rotation 
angles and the scaling factors are applied to each axes 
individually, i.e. the axis are rotated and scaled by different 
amounts. 

The following table summarizes this behavior. 

Table 32: Possible 
coordinate 
transformations and 
their results. 
 

transformation transformation variables 

1 point 
New shift. 
Scaling factors for both axes unchanged. 
Rotation angle for both axes unchanged. 

Origin Correction 
New shift. 
Scaling factors for both axes unchanged. 
Rotation angle for both axes unchanged. 

2 points 
New shift. 
One new scaling factor for both axes. 
One new rotation angle for both axes. 

Angle Correction 
Shift unchanged. 
Scaling factors unchanged. 
One new rotation angle for both axes. 

3 points 
New shift. 
Two new scaling factors one for each axis. 
Two new rotation angles one for each axis. 

10.5 An un-patterned, small sample 
In this case no pattern exists on the sample which can serve as a 
reference and the sample itself is not a complete wafer maybe only a 
fraction of it with at least one straight edge. 

This Adjustment consists of two tasks. One task is to assign a certain 
point on the sample specific coordinates whereas the other task is to 
define the U-direction on the sample. The sequence between these two 
tasks does not matter. It is also possible to do them at the same time, 
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for example when one point is used to define the point as well as the 
angle. 

Before starting these two tasks one should switch to global or local 
transformation. Normally, for simple tasks the global one is the best 
choice. Then one should press Reset to make sure that the scaling 
factors as well as all other parameters set to the identity 
transformation. 

10.5.1 Origin correction 
The Origin Correction tab serves to determine the shift vector between 
the origin of the X, Y system and the origin of the U, V system. 

Figure 77: Tab 
Origin Correction to 
calculate the shift 
between X, Y system 
and U, V system. 

 

Defining an origin correction 

STEP 1 ► Locate a reference structure on the sample such as the lower left 
corner of the sample. 

STEP 2 ► Use the appropriate control, e.g. a joystick, to place this reference 
structure in the center of the field of view, e.g. a SEM screen. 

STEP 3 ► Switch to global or local transformation before pressing Adjust to 
calculate the shift for that transformation. 

Please note, if an appropriate coordinate transformation already exists 
and only an offset correction is necessary one can use the blue flag @ 

10.5.2 Angle correction 
The Angle Correction tab offers the capability to adjust the angle 
between X axis and U axis. To calculate this transformation it is 
necessary to read in the X and Y of two different points along the U-
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axis of the sample. Naturally, the degree of accuracy of the angle is 
related to the accuracy of the positioning as well as the distance 
between these two points. If the distance is larger, it is more accurate. 

Figure 78 Tab: Angle 
Correction to 
calculate the angle 
between X axis and U 
axis.  

 

Defining an angle correction 

STEP 1 ► Locate an extended reference structure which can serve as the U axis, 
e.g. the lower edge of the sample. 

STEP 2 ► Use the appropriate control, e.g. a joystick, to place on point of this 
reference structure in the center of the field of view, e.g. a SEM 
screen. 

STEP 3 ► Choose Read in line 1 to use the corresponding X, Y coordinates for 
the angle calculation. 

STEP 4 ► Use the control to place another point of the reference structure in the 
center of the field of view. This second point should be separated by a 
few mm, e.g. 10 mm, from the first one. 

STEP 5 ► Choose Read in line 2 to use now this X, Y coordinates for the angle 
calculation. After pressing Read the Calculated angle is given on the 
same tab as information in red. Please verify that the calculated 
number makes sense especially that the sign is correct which means 
that the U axis is pointing into the right direction. 

STEP 6 ► Choose Adjust to use the so defined U direction. The angle between 
U and X is given now in green. 

10.6 A patterned sample 
If already a pattern exists on a sample, for example made in a previous 
process step, and one has to navigate on this sample, for example to 
find a specific structure, it is absolutely necessary to adjust the U, V 
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coordinates to this pattern. This situation becomes clearer when 
assuming the pattern was defined in a previous step by a mask plate 
with a scaling error. To find then a specific structure the Raith 
software has to use the same scaling factor. In addition and very 
common the pattern is rotated against a reference direction, e.g. a 
wafer flat, due to poor alignment. Of course is a mask plate of high 
fidelity and a good mask aligner or a good stepper is used, the rotation 
angles are very small, the scaling factors are near 1.0, and the 
adjustment procedure consists mainly in defining the origin. But in the 
following it is assumed that one has to do the full adjustment 
procedure meaning to use three points. 

Figure 79: Tab 3-
Points to calculate a 
full transformation. 

 

Defining a full transformation 

STEP 1 ► Type in the U, V coordinates of the three reference structures into the 
corresponding U, V fields. The easiest way is to get them from the 
GDSII design. Here it is possible to use the green flags. 

STEP 2 ► Locate one of the three reference structures, e.g. the first one. Choose 
Read to automatically update the corresponding X, Y coordinates. 

 

This task is normally the trickiest one. It this case it is very helpful to 
do first a course adjustment using only an origin and an angle 
correction using the global coordinate system. This coordinate system 
can then be used to find the first reference structure. The following 
fine adjustment using three points is then done in local coordinate 
system. Therefore it is possible to switch at each point back to global 
one to find the next structure or to repeat previous steps. 

STEP 3 ► Place the tick in front of the correspond coordinates. This tick means 
that the X, Y, U, V values will be used to calculate the corresponding 
transformation. 

STEP 4 ► Locate the second structure of the three reference structures. Choose 
Read and place the corresponding tick. 
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STEP 5 ► Locate the last structure of the three reference structures. Choose 
Read and place the corresponding tick. 

STEP 6 ► To calculate and to activate the transformation, choose Adjust. 

 

If the coordinate transformation differs not too much from the identity 
or a global transformation is used (see previous hint), the task to find 

the second and the third structure can be speeded up by pressing  
behind the corresponding U, V coordinates. 

10.7 Defining a new adjustment procedure 
The main task of a predefined adjustment procedure is to automate the 
adjustment on wafers (global adjustment) and their chips (local 
adjustment). If one work with the same wafer layout every day, the 
adjustment procedures will simplify and speedup this task. 

The adjustment procedure executes the following steps. The stage 
drives to all specified UV-position of the marks and records an 
Imagescan or a Linescan at each position. From the deviation between 
actual and reference position a new coordinate transformation is 
calculated and applied. The case that a manual procedure is executed 
the operator has to define the deviation using the Control key and left 
mouse button. 

 

The position of each mark is specified in U and V. Thus a coarse UV-
adjustment has be executed or applied to sample before using a 
procedure. This can be a Preadjustment or an unpatterned wafer 
adjustment. Than an adjustment procedure can be used for a fine 
adjustment. 

Within the Scan Manager three sorts of adjustment procedures are 
available: Manual, Automatic with Linescans and Automatic with 
Images. The Manual and Automatic with Images procedures use 
images and perform 2-dimensional mark detections to determine the 
shift at each mark. The Automatic with Linescans procedure uses 
Linescans in U- and V-direction and requires a cross-shaped mark. 

The details how to configure Imagescans used for the procedures 
Manual and Automatic with Images can be found in section  
Defining Images. Refer to the corresponding section  Defining 
Linescans to learn how to configure Linescans used for the Automatic 
with Linescans procedures. In the following only the deviation from 
these settings are described. 



 10.7 Defining a new adjustment procedure 

 157 

10.7.1 Main settings 
In the case of an Automatic with Linescans procedure two Linescans 
are defined to determine the deviation in U- and V-direction at each 
mark. Thus the selection of a Main Direction is not necessary. 

10.7.2 Mark procedure settings 
Choose the tab Mark procedure to define number and positions of the 
mark scans. Use the check boxes to select which marks shell be used 
and type in the U and V coordinates in corresponding input fields. 
Therefore, use the check boxes to select which marks shall be used. 
The number of marks corresponds to an 1-, 2- or 3-point adjustment 
(see section  Transformation with 1, 2, or 3 points). After selecting 
the number of marks, type in the U- and V-coordinates in the 
corresponding input fields.  

Offset This parameter is used only by Automatic with Linescans procedure 
to define the placement of each Linescan with respect to the mark 
position. The figure below shows the principle. 

Figure 80: Placement 
of Linescans with 
respect to a mark 
using the offset. 

 

10.7.3 Advanced settings 
It is possible to setup an Automatic with Images procedure in two 
different ways. If no reference image exists, select the option 
automatic scan with reference mark at beginning. In this case a 
reference image is created automatically by recording an image in the 
center of the write field. 

 

The precision of an adjustment depends on how accurate is the 
position of the reference image. Hence, when recording the reference 
image it is a must-see to perform first a very accurate adjustment as 
well as a write field alignment. 

Adjust after every mark Select this option to calculate and apply the coordinate 
transformation after every mark scan. This procedure increases the 
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accuracy from step to step and simplifies finding the next mark scan in 
the sequence. 

Halt before closing If this option is active, the automatic procedure stops execution after 
each mark scan. Do not select this feature, if full automatic procedure 
is desired. 

10.7.4 Processing and evaluation 
An automatic detection of the deviation at each mark, i.e. an 
evaluation algorithm, is mandatory for all automatic procedures. See 
the corresponding section  Evaluation algorithms to configure the 
mark detection. 



 

 159 

11 Beam to sample alignment 
11.1 Coordinate systems and transformations 160 

11.2 Align Write field 161 

11.3 Microscope control 162 

11.4 Alignment / adjustment interrelation 164 

11.5 Aligning write fields 164 

11.6 Defining a new alignment procedure 168 

Write field alignment is a very central alignment in the process of 
exposing a pattern into an existing pattern or exposing large structures 
consisting of several smaller write fields. The first case is called "Mix-
and-Match" exposure whereas the second one is called "stitching". 
This case is displayed in  Figure 81. Another case would be 
recording images or Linescans to determine a certain dimension 
("Metrology") or exposing elements with certain widths ("CD 
control"). In these two cases a correct orientation of the write field 
might be not so important, but its size becomes crucial. From these 
examples, it becomes clear that the beam has to be positioned very 
precisely on the sample or in other words the beam positioning has to 
be aligned to the sample coordinate system. 

Figure 81: Effect of 
write field alignment 
on "stitching". 
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To give an overview over the beam-to-sample coordinate 
transformation, the first part of this chapter introduces coordinate 
system of the beam and its transformation with respect to the sample. 

 

Please note that throughout the software and manuals the terms 
"align" or "alignment" are used only in connection with the 
transformation between beam and sample. The term "adjustment" is 
used in connection with the transformation between sample and stage.

11.1 Coordinate systems and 
transformations 
In section  Stage to sample adjustment the UV-coordinate systems of 
the sample were introduced. Thus a point on the sample can be placed 
underneath the beam by specifying its U- and V-coordinates. For the 
beam itself a different way was chosen. An additional coordinate 
system was not introduced; only the transformation between UV and 
the beam is visible. The relevant quantities are 

• ZoomU and ZoomV the scaling of the beam mayor axes with 
respect to U- and V-axes. Zoom values are necessary for the right 
scaling of the beam movement. For example, if an image is 
scanned, the dimensions of the displayed structure shell fit to the 
real size of this structure. 

• ShiftU and ShiftV the offset of the beam center with respect to a 
point in U and V. The shift is used to move the beam with respect 
to a reference structure on the sample. Thus, if the shift is 
determined correctly an overlay exposure is possible. 

• RotU and RotV the rotation of the beam mayor axes with respect 
to U- and V-axes. The rotation values are responsible for the 
correct orientation of the beam movement relative to the sample 
coordinate system. For example, if the rotation is well aligned, 
stitching of write fields is possible. 
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Figure 82: Sketch of 
the beam system with 
respect to the sample. 

This reason for this way of describing the transformation is that 
exactly these values are send to the Digital Pattern Generator or to the 
Scanboard. Then within the Pattern Generator these values are used to 
perform electronically the coordinate transformation. 

How the transformation between the sample and the beam fits into the 
general scheme of coordinate systems is displayed in  Figure 83.  

Figure 83: Sample 
beam coordinates 
transformation C. 

11.2 Align Write field 
The transformation quantities ZoomU … RotV are displayed and can 
be changed in the Align write field. In addition the control bar section 
gives access to all relevant commands to handle the transformation. 
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Figure 84: Align 
write field. 

 

ZoomU/V  Zoom for U-, V-axis scaling, value between 0 and 1 

Shift U/V Shift with respect to U-, V-axis, can be positive and negative. Please 
note Raith lithography systems compensate a shift larger than 2% of 
current write field (parameter can be changed) by applying the 
corresponding value to the transformation between sample and stage. 

Rotation U/V Rotation relative U-, V-axis, can be positive and negative. Beam tries 
to compensate rotation of UV system, therefore rotation angle of UV 
adjustment and beam have different signs. Please note Raith 
lithography systems compensate a rotation larger than 1º (parameter 
can be changed) by sending corresponding value to the column. 

Input boxes The values given here are the alteration of the transformation 
quantities. The values for zoom are multiplied and for shift and 
rotation are added to current values. 

Get marks Command calculates correction parameter from positionlist containing 
alignment marks. Alignment procedures called from the Scan 
Manager perform this command automatically. 

Reset Reset correction parameters to identity transformation. 

Send Send alteration of transformation parameters (values in input boxes) to 
beam control hardware. 

11.3 Microscope control 
Closely connected with each other are transformation quantities of the 
write fields are the settings on the column or microscope. For example 
when setting up a write field of 100 µm, the field of view has to be 
larger than this 100 µm. In addition, the correct transformation 
quantities might depend on the beam energy, working distance, slight 
non-linearity while using different amplifier for different 
magnification regions, etc. Thus each write field must be aligned for 
every magnification separately. As write field size, magnification and 
the transformation quantities depend on each other they are stored 
together in one database and this set is identified using an name. 
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Figure 85: 
Microscope control. 

 

The currently selected write field size and the magnification are 
displayed in the top of the dialog. If polling of the magnification is on, 
the magnification will be updated periodically. In this case a 
magnification, which does not fit to a selected write field, becomes 
red. 

Use the list to select a new write field. Within this list the various 
write fields are selected by their name and the active is marked by . 
If the alignment values stored in the database and the current 
alignment values are different, the corresponding entries in this list are 
blue. A new entry becomes red, if it was not stored in database. Black 
entries belong to parameter sets which database settings agree with 
current setting in the system. 

New Choose this command or  to create a new parameter set of write 
field size with corresponding magnification. Assign also a name to 
this parameter set, so that it can easily be identified. If no name is 
given, a name is automatically created using a combination of 
magnification and field size. By using names it is possible to create 
several parameter sets with equal write field size but different 
magnifications and vice versa. 

Save Choose this command or  to store changes of the currently selected 
parameter set to the database (only red and blue entries are affected).  

Delete Choose this command or  to delete an existing parameter set. 

Edit Choose this command or  to change an existing parameter set. 

Read Use this command or   to force reading current magnification from 
the column. 
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To setup a new parameter set, it helps to realize that the product of 
write field size and magnification should be constant. The actual value 
of the product itself depends on beam control hardware as well as the 
column. 

Set Choose this command or  to activate the currently selected write 
filed size and magnification. If Database values is selected the beam 
alignment values are read from the database before activating them. 
Otherwise current alignment values are still active. 

11.4 Alignment / adjustment interrelation 
As the marks used for an alignment are features on a sample, the 
sample orientation or dimensions on the sample are affecting the 
alignment itself. For Example if the sample is rotated by certain angle 
with respect to the stage, then after an alignment the write field will be 
rotated by the same angle (assuming that stage and beam are perfectly 
aligned to each other.) Hence, one can use the information from the 
UV-adjustment procedure to roughly calculate the rotation and scaling 
of the write field. 

Starting with version 4.0 a mechanism was implemented taking this 
interaction into account. This mechanism consists of parts. 

• Before storing the write field parameters to the database, the 
current UV-adjustment values are used to calculate new write 
field parameters which do not depend on the UV-adjustment 
values. Only these values are stored. 

• Before setting a write field with parameters from the database, the 
current UV-adjustment values are used to calculate effective write 
field parameters. Naturally, these effective values do depend on 
the current UV-adjustment. 

11.5 Aligning write fields 
The principle of a write field alignment is simple. Some unique and 
easily recognizable features on the sample are selected as marks. The 
dots from focusing or the corners on a "Chessy" are good examples. 
Scanning now over these marks with the beam let each mark appear at 
a certain positions. This actual position with respect to their reference 
position gives now the input parameter for calculating the write field 
transformation. 

The alignment procedure is imbedded into the general sequence as 
follows: 

STEP 1 ► Focus on the sample surface. 
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STEP 2 ► Adjust UV coordinates with respect to stage XY. 

STEP 3 ► Select desired write field size in Microscope Control. 

STEP 4 ► Perform write field alignment using corresponding procedures in Scan 
Manager. 

STEP 5 ► Execute exposure, metrology or other job. 

 

It is important to understand that a write field alignment depends on 
the current transformation between sample and stage. Therefore 
before starting a write field alignment, establish first the coordinate 
transformation between stage and sample, i.e. perform an UV-
Adjustment. 

Depending on equipment with laser interferometer stage two different 
alignment procedures are possible: alignment with and alignment 
without laser stage. The mix-and-match operation which is possible 
with and without a Laser stage is described in section  Mix-and-
Match Exposure. 

11.5.1 Write field alignment without laser stage 
If your system is not equipped with laser interferometer stage use 
precise and well structured sample. For example the "Chessy" sample. 
This sample serves as a measuring standard for the following write 
field alignment. 

 

Please note it is possible to align such parameter like shift and rotation 
using a "Chessy" but there are two limitations which make a stitching 
application impossible. First, the "Chessy" and the sample must have 
the same UV adjustment and the same focus (exactly same height). 
And second, the Stage must have an accuracy of a few nm to perform 
stitching. 

Normally, the alignment for each write field size is done once during 
installation before using the system. Then these values are store into 
the database. This makes it possible to work with these stored 
parameters without any alignment in the future. 

The following steps are necessary to perform a "Chessy" alignment. 
For a more detailed description please refer to the Operation Manual. 

STEP 1 ► Focus on a leveled sample. 

STEP 2 ► Perform an UV-Adjustment with Origin Correction and Angle 
Correction using the "Chessy". See section  Alignment / adjustment 
interrelation to understand why this step is necessary. 

STEP 3 ► Place the adjacent corners of two squares near to the center of the 
beam. Record at this position an image. 
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STEP 4 ► If an applicable alignment procedure in Scan Manager (see Align 
Write Field Procedures > Manual) exists, select this procedure and 
drag and drop it on to the adjacent corner in the image center. The 
result is displayed in  Figure 86. If an applicable procedure does not 
exist, crated one as described in section  Defining a new alignment 
procedure. 

Figure 86: Image 
after drag-and-
dropping an 
applicable procedure 
onto "Chessy". 

 

STEP 5 ► Select the Positionlist where the alignment procedure has been stored 
and scan the corresponding position.  

STEP 6 ► In each image place the blue marker on the mark by using the Control 
key together with the left mouse button. 

STEP 7 ► At the end of the procedure, apply correction values, if procedure was 
successful. 

11.5.2 Write field alignment with laser stage 
If your system is equipped with a laser interferometer stage it is 
possible to use the laser stage as measuring standard. The precision of 
the Laser stage allows a very precise alignment of the beam with 
respect to sample making a stitching possible. 

The internal procedure is not quite the same as within the "Chessy" 
procedure. Here only one mark is used. The mark is moved to several 
positions within an unaligned write field. At each position a smaller 
image is recorded such that the difference between the actual and 
reference position can be determined. From all differences the beam 
alignment values are calculated.  Figure 87 displays this procedure. 
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Figure 87: Align 
write field procedure 
used with Laser stage. 
One mark it moved 
using the Laser stage 
to different locations 
so that the same mark 
appears in each scan. 

Before this procedure can be executed, the following steps are 
necessary. 

STEP 1 ► Focus on a leveled sample. 

STEP 2 ► Perform an UV-Adjustment with Origin Correction and Angle 
Correction using the sample. See section  Alignment / adjustment 
interrelation to understand why this step is necessary. 

STEP 3 ► Place the mark near to the center of the beam. Record at this position 
an image. 

STEP 4 ► If an applicable alignment procedure in Scan Manager (see Align 
Write Field Procedures > Manual) exists, select this procedure and 
drag and drop it on to the adjacent corner in the image center. The 
result is displayed in  Figure 88. If an applicable procedure does not 
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exist, crated one as described in section  Defining a new alignment 
procedure. 

Figure 88: Image 
after drag-and-
dropping an 
applicable procedure 
onto one mark. 

 
 

STEP 5 ► Select the Positionlist where the alignment procedure has been stored 
and scan the corresponding position.  

STEP 6 ► In each image place the blue marker on the mark by using the Control 
key together with the left mouse button. 

STEP 7 ► At the end of the procedure, apply correction values, if procedure was 
successful. 

STEP 8 ► Repeat this sequence with a smaller scan fields until no decrease in 
correction factors is observed. 

11.6 Defining a new alignment procedure 
Within the Scan Manager three sorts of write field alignment 
procedures are available: Manual, Automatic with Linescans and 
Automatic with Images. The Manual and Automatic with Images 
procedures use images and perform 2-dimensional mark detections to 
determine the shift at each mark. The Automatic with Linescans 
procedure uses Linescans in U- and V-direction and requires a cross-
shaped mark. 

The details how to configure Imagescans used for the procedures 
Manual and Automatic with Images can be found in section  
Defining Images. Refer to the corresponding section  Defining 
Linescans to learn how to configure Linescans used for the Automatic 
with Linescans procedures. In the following only the deviation from 
these settings are described. 
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11.6.1 Main settings 
In the case of an Automatic with Linescans procedure two Linescans 
are defined to determine the deviation in U- and V-direction at each 
mark. Thus the selection of a Main Direction is not necessary. 

11.6.2 Mark procedure settings 
Choose the tab Mark procedure to define number and properties of 
mark scans. 

Mark sequence Choose which marks shall be used by selecting corresponding check 
boxes. 

Placement Defines the distance between the scans and center of write field. 

Iterations Defines the number of repetitions the alignment procedure are 
repeated to achieve better results.  

Offset This parameter is used only by Automatic with Linescans procedure 
to define the placement of each Linescan with respect to the mark 
position. The figure below shows the principle. 

Figure 89: Placement 
of Linescans with 
respect to a mark 
using the offset. 

 

11.6.3 Advanced settings 
It is possible to setup an Automatic with Images procedure in two 
different ways. If no reference image exists, select the option 
automatic scan with reference mark at beginning. In this case a 
reference image is created automatically by recording an image in the 
center of the write field. 

 

The precision of an adjustment depends on how accurate is the 
position of the reference image. Hence, when recording the reference 
image it is a must-see to perform first a very accurate adjustment as 
well as a write field alignment. 
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Halt before closing If this option is active, the automatic procedure stops execution after 
each mark scan. Do not select this feature, if full automatic procedure 
is desired. 

11.6.4 Processing and evaluation 
An automatic detection of the deviation at each mark, i.e. an 
evaluation algorithm, is mandatory for all automatic procedures. See 
the corresponding section  Evaluation algorithms to configure the 
mark detection. 
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Normally having a certain exposure result in mind, it is very important 
to have some background information on how the GDSII design is 
transferred into an exposure and how the various exposure parameters 
affect the exposure. 

The aim of this section is it, to provide the necessary information. To 
get an overview, it is useful to recall that the following steps have to 
be executed before an exposure. 

• Create the design structures using the GDSII editor and its 
elements with various properties. 

• Setup the column, i.e. select the acceleration voltage, the beam 
current, and the write field size. 

• Define design parameters, i.e. the layers, the working area, and the 
location on the sample. 

• Define your exposure parameters, i.e. step sizes, dwell times, 
settling times, and select between different modes. 

• Start the exposure. 

 

Within this reference manual we do not describe how to setup an 
exposure in a step-by-step way. To learn more about this, please 
consult the operation manual. 

12.1 Exposing GDSII structures 
A fast and very flexible way to expose a structure is provided in 
combination with the Positionlist mechanism of the Raith software. 
This approach becomes even more powerful when exposing multiple 
or repeated structures with the same or different parameters. This 
allows a powerful batch job type operation, especially if the stage can 
be driven automatically. 

12.1.1 Preparing a Positionlist 
To generate an automated exposure sequence of one or more 
structures at different locations on the sample, 
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• a GDSII database containing the structures must be loaded, 

• a new Positionlist must be created choosing the command File > 
New Positionlist. 

Now, select the structure to be exposed within the GDSII Database, 
drag it to and drop it at any location within the Positionlist window. 
Using this technique, the structure will be added as a line entry into 
that Positionlist. To expose multiply GDSII structures, repeat this 
procedure or use the Positionlist filters, like Matrix Copy, to generate 
additional exposure tasks. 

When using this drag-and-drop technique, the software stores the 
following settings 

• the current write field size, 

• the current UV position, 

• the current GDSII working area, and  

• if the exposure of lines and dots is switched on 

within the Positionlist. To use different parameters, one has to 
redefine these parameters for this position. The exposure of the GDSII 
structure will be performed by applying these parameters. 

For a quick graphical inspection of selected layers and the working 
area, just double-click on the line entry. This action opens 
automatically the GDSII viewer and displays the selected structure, 
layers and working areas. 

The exposure of each individual structure within the Positionlist as 
well as of groups or of all structures can be started by the Scan menu 
commands of the Positionlist, such as Current, All, etc. Of course, 
the complete exposure list can be stored and recalled for use or 
modification at any time. For more details please refer to section  
Positionlists. 

In order to modify or only to inspect these parameters, select the 
related line in the Positionlist by right mouse click and choose the 
command Properties from the appearing menu. After this you have 
access to a dialog box as shown in Figure 90 to set these parameters. 
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Figure 90: Dialog to 
set all parameters 
relevant for an 
exposure. 

 

Exposed layer Choose the corresponding button to select the layers to be exposed. A 
dialog appears with a listing of all layers. Select the layers to be 
exposed. Unselect layers by an additional mouse click. Alternatively, 
multiple layers are separated by a comma and a range of layers is 
indicated by a hyphen “-“. 

Working area Choose the corresponding button to select the working area from a list 
of predefined areas. Alternatively, enter the coordinates of the lower 
left and upper right corner in GDSII-UV-coordinates. 

Position Enter the location where the GDSII structure should be get exposed. 
The coordinates are sample-UV-coordinates. Within the design-UV-
coordinates this position corresponds to the center of the first write 
field. 

Figure 91: Definition 
of UV-position for an 
exposure. 
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If the sample coordinates are identical to the GDSII-coordinates, it is 

possible to use the  button to calculate the UV-position on the 
bases of the stored working area and current write field size. Thus, it 
is very important that the working area and the write field are set 
before using this function. 

 

Identical sample coordinates and GDSII coordinates is typical for a 
mix-and-match application, i.e. mixing of an optical lithography with 
an e-beam exposure step. 

Exposure Parameters Choose this button to enlarge the window to set the exposure 
parameters like step sizes, dwell times, etc. 

Default Select for each parameter, if the corresponding default value should be 
used. The default values are defined within the Exposure (see section 

 Exposure control). To edit one of these parameters unselect the 
Default option. 

Area Step Size This parameter defines the distance between exposure spots in µm. It 
has to be an integer multiple of the basic step size (see section  
Advanced Exposure Parameters). 

Area Dwell Time This parameter defines the time the beam waits at each step when 
exposing an area. The minimum dwell time depends on the hardware 
and is automatically set, if the user tries to enter a smaller value. 
Dwell times can be selected in steps of 1 ns and, if the user input does 
not fit exactly into this dwell time raster, the Raith software 
automatically selects the next larger value. 

Lines Select this option to enable the exposure of single pixel lines. 

Line Step Size This parameter defines the step size along a single pixel lines in µm. It 
has to be an integer multiple of the basic step size (see section  
Advanced Exposure Parameters). 

Line Dwell Time This parameter defines the time the beam waits at each step when 
exposing a line. The minimum dwell time depends on the hardware 
and is automatically set, if the user tries to enter a smaller value. 
Dwell times can be selected in steps of 1 ns and, if the user input does 
not fit exactly into this dwell time raster, the Raith software 
automatically selects the next larger value. 

Dots Select this option to enable the exposure of dots. 

Dot Dwell Time This parameter defines the time the beam waits when exposing a dot. 
The minimum dwell time depends on the hardware and is 
automatically set, if the user tries to enter a smaller value. Dwell times 
can be selected in steps of 1 ns and, if the user input does not fit 
exactly into this dwell time raster, the Raith software automatically 
selects the next larger value. 
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Dose Factor This parameter can be used to scale the applied dose for all GDSII 
elements by a certain factor. The dose factor is multiplied to the dwell 
time of areas, lines and dots. 

 

The dose factor becomes very useful, when used for the determination 
of the clearing dose. On a test sample the same structure is exposed at 
different locations with a different dose factor. After processing of the 
sample and inspection of the result, the best dose is selected and used 
for further sample preparations. The dose factor is also supported by 
the Positionlist command Matrix copy. 

12.1.2 Exposure Parameter Calculation 
 Calculator Choose this button to calculate the exposure parameters for the doses 

of areas, lines and dots. Please note, the parameters for lines and dots 
are only visible, if the corresponding option within the Exposure is 
selected. All parameters will be taken over from the Exposure 
Properties window, and they will be written back into it, when 
choosing the OK button. 

Figure 92: Window 
to calculate exposure 
parameters. 

Write field size, 

Min step size These values are given for information purposes only.  

Beam current For most systems a software module is available to read in the beam 
current from a current meter. Then its value is automatically given 
here. If such a module is not available, use an external current meter 
to measure the current and enter its value in nA. The same beam 
current is used to calculate the exposure parameter for areas, lines and 
dots. 

The four input parameters for an area exposure show four buttons 
besides the related input field. One may enter the values in any three 
of these four fields. To calculate the fourth parameter such that all 
four parameters fulfill the equation 
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size"² step area"
 time"dwell area"current" beam"dose" area" ⋅

= , 

choose the button behind it. Now that these four parameters fulfill the 
given equation, the corresponding title of the tab changes from red to 
black.  

The parameters for line and dot exposures may be calculated in the 
same way. In this case the following equations are used to calculated 
the parameters for a line exposure 

size" step line"
 time"dwell line"current" beam"dose" line" ⋅

=  

and for a dot exposure 

 time"dwelldot "current" beam"dose"dot " ⋅= . 

If all three parameter sets for area, line and dot exposure fulfill their 
corresponding equation, the OK button is enabled and the values will 
be written back into the Exposure parameters. 

12.1.3 Estimating exposure time 
Times Choose this button to get information about the expected total 

exposure time. After calculation has finished, a message box shows 
the different kinds of times. 

Figure 93: Window 
showing the different 
kinds of estimated 
exposure times. 
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12.2 Exposure control 
The Exposure section in the control bar allows the definition of the 
default parameters which are used during an exposure like step sizes, 
dwell times, and different exposure modes. But the actual exposure 
job is started from a Positionlist. The advantage is that within a 
Positionlist it is possible to define very flexible several additional 
parameters, e.g. the location on the sample where a structure should be 
exposed and the working area. A Positionlist can store also more than 
one exposure job making a kind of batch execution possible. 
Additionally, it is possible to use for each exposure job different 
exposure parameters, i.e. one can overwrite the default parameters as 
defined in the Exposure, which is very useful when searching for the 
best process parameters. 

 

It is very important to understand that some of the exposure 
parameters in the Exposure can be overwritten when using the 
Positionlist. If in doubt which setting for which parameter was used, 
see the protocol file. 

Exposure task may be combined with overlay alignment procedures as 
described in section  Beam to sample alignment. 
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Figure 94: Exposure 
to define the default 
exposure parameters. 

 

Write field size Information of the currently selected write field size. A squared write 
field is assumed so that width is equal to height. 

The following exposure parameters can be edited and calculated 
within the Exposure. An optional setting within a Positionlist is 
possible. 

Area step size U/V The same meaning as described in section  Preparing a Positionlist. 
In addition, entering a step size value in µm, the related step size in 
Pixel will be calculated. 

Area dwell time The same meaning as described in section  Preparing a Positionlist. 

SPL Exposure Select this option to enable the exposure of single pixel lines. After 
enabling the parameters step size and dwell time for these lines are 
available. 

Line step size The same meaning as described in section  Preparing a Positionlist. 

Line dwell time The same meaning as described in section  Preparing a Positionlist. 
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Curved Elements Select this option to enable the exposure of curved elements, like 
circles. After enabling the parameters step size and dwell time for 
curved elements is available. 

Curve step size The same meaning as described in section  Preparing a Positionlist. 

Curve dwell time The same meaning as described in section  Preparing a Positionlist. 

Dot Select this option to enable the exposure of dots. After enabling the 
parameter dwell time for dots is available. 

Dot dwell time The same meaning as described in section  Preparing a Positionlist. 

FBMS Area/Line  Both parameters are described in the corresponding manual. 

12.2.1 Advanced Exposure Parameters 
Details Choose this button to set some additional exposure parameters. 

Figure 95 Dialog to 
set additional 
exposure parameters. 

Loops The number entered within this text box defines how many times the 
complete structure will be exposed. Usually, a pattern is exposed just 
once. But it may be necessary, e.g. to avoid charging up effects, to 
perform the exposure in several loops with lower dose. 

If this parameter is set to zero, the exposure will start an endless loop 
until it is stopped within the corresponding window. 

Exposure Raster This setting is only available in connection with all digital pattern 
generators with version 6 or higher as well as ELPHY Quantum PCI-
board. The software automatically detects the hardware and enables 
this feature. 

The exposure raster determines the minimum distance between two 
neighboring points that can be exposed. This minimum distance is 
called Basic step size. The Basic step size depends on the currently 
used write field size. Use Fixed metric raster to automatically use the 
smallest possible Basic step size. Use Free metric raster mode to 
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define the Basic step size manually. It can be any number larger than 

approximately 
bits” of”number 2

size” field “write . For example the minimum Basic 

step size for 100 µm write field is 1.6 nm and 0.8 nm for 50 µm write 
field. The Basic step size can be increased in 0.1 nm steps. Sometimes 
it is useful to work with free metric raster to achieve optimal exposure 
results. 

 

For example, if several elements with dimension of 5 nm have to be 
exposed, it is best to define the Basic step size of for example 2.5 nm. 
This guarantees that all elements get the same number of points. If one 
would use for example 2 nm, it can happen that due to rounding one 
element would get 2 lines and another one would get 3 lines. 

Area Mode The filling of areas is defined here. In Line mode the beam exposes 
each line by driving the beam always from one direction. By this 
behavior a greater accuracy in exposure is achieved, but the exposure 
takes a longer time due to larger beam settling times. 

In Meander mode the beam is moved alternates from line to line its 
direction. This mode results in shorter exposure times. If one wants to 
use this mode, one has to switch off the dynamic compensation. 

Scan Direction When filling an area the beam exposes this area line by line. The 
direction of these lines is called the scan direction. 

The Scan direction can be set manually or automatically. If it is set 
automatically the longest dimension which is parallel to U or V of a 
trapezoid determines the scan direction. Selecting Manual forces the 
beam to expose only in the specified direction U or V. 

 

Normally the automatic mode should be used. If the manual mode is 
used, e.g. set to V, and a narrow horizontal rectangles is exposed, this 
results in longer exposure times. 

Settling Time The Settling time is the time which the hardware waits after 
positioning of the beam before starting the exposure of the next 
trapezoid, line or dot. The Settling time is necessary to stabilize the 
column deflection unit. Therefore the beam is blanked during this time 
and the values depend on the column itself as well as the distance. 
Typical values are in the range of milliseconds. 

The Settling time can be set manually or calculated automatically. In 
the case that it is calculated automatically, the software calculates the 
Settling time depending on the distance between the elements with 
respect to a reference value and assuming a linear dependency. The 
reference value has to be defined as a time per jump over such a 
distance. The value depends on the column. 
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Normally the automatic mode should be used. If the manual mode and 
a relatively large value for the Settling time is used, this results in 
longer exposure times. 

Flyback By means of the Flyback factor, the software calculates the time 
which the pattern generator waits between exposing two lines. The 
actual time is calculated by multiplying the Flyback factor with the 
settling time. 

The Flyback factor can be set manually or calculated automatically. 
In the case that it is calculated automatically, the software determines 
for each trapezoid the maximum needed flyback time which is then 
used for the complete trapezoid. The software calculates the Flyback 
factor depending on the distance between the start and end point with 
respect to a reference value and assuming a linear dependency. The 
reference value has to be defined as a time per jump over such a 
distance. The value depends on the column. 

 

Normally the automatic mode should be used. If the manual mode and 
a relatively large value for the Flyback factor is used, this results in 
longer exposure times. 

Advanced Details Two modes can be activated here. When using the Circular mode, 
circles defined in the GDSII are not fractured into trapezoids. Instead 
they are fractured down into concentric rings with decreasing 
diameter. Hence, this mode is more adapted to the circular geometry 
of the pattern and the exposure is of higher quality. The Circular 
mode is only available, if within the GDSII the element is defined as 
full and completely filled circle. 

FBMS The parameters related to the Fixed Beam Moving Stage option are 
described in a separate manual. 

Drift Compensation @ 

Visualization Using Show fractured elements in Viewer enables the visualization 
of the currently fractured elements as an overlay over the GDSII 
viewer. Show stitch field array enables a coarse view of the currently 
fractured write fields. Create ASCII debug file writes the fractured 
elements into one file using the ASCII format described in section  
Saving files in ASCII format. 

In addition, it is possible to switch off the Dynamic compensation 
applied to the beam. All Raith systems come with an algorithm to 
compensate dynamic effects which occur when steering the beam 
whereas all Raith attachments do not have this option. Thus, only at 
systems it is possible to switch this mode off. If Dynamic 
compensation has been switched off, much faster exposures can be 
expected but with a reduced placement accuracy. 
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12.2.2 Exposed layer 
Exposed layer Choose this button to select the layers to be exposed. A dialog appears 

with a listing of all layers. Select the layers to be exposed. Unselect 
layers by an additional mouse click. 

12.3 Mix-and-Match Exposure 
To perform mix-and-match lithography, interactive as well as 
automatic write field alignments can be performed. 

To use this functionality one has to go through the following steps. 

STEP 1 ► Within the GDSII design one has to define the mark scans. These 
mark scans can be placed in the GDSII editor by using the commands 
Add > Manual mark scan and Add > Auto mark scan. The 
command Add > Manual mark scan places scans which require 
some interaction with the software. Within the following dialog type 
in the exact position of the related physical mark on the sample 
fabricated within a preceding process step. Define also the size of the 
scan field. 

Up to three mark scans can be used within one write field. A shift 
correction is possible with just one mark. In case of using 3 marks in 
each writing field, a complete field alignment in (XY) scaling, 
rotation, rectangularity and (XY) shift can be performed. If more than 
3 marks are defined, these marks are used only if a previous scan 
failed. 

 

Each mark scans has to lie within one write field. Otherwise it is 
fractured by a write field border and part of the scan is executed 
within the adjacent write field. 

 

 

In the case of automatic scans each U-Scan has to be followed by a V-
Scan. Also when placing them within the editor. Use the command 
Modify > Order to check the element order and if required to change 
it. Otherwise the software can not calculate the correct transformation.

STEP 2 ► Within the Scan Manager use the scans defined under Align write 
field procedure > GDSII Markscans > Automatic or Manual to set 
the corresponding parameter like number of points averaging, etc. For 
the automatic mark scans make sure to define the correct evaluation 
method. All parameters are the same as described in section  Scan 
Manager. 

STEP 3 ► When choosing the layers to be exposed, select layer 63 to execute the 
manual mark scans and layer 61 to execute the automatic scans. Them 
one can start the exposure task. 
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STEP 4 ► If Manual mark scans are executed, the user has to assign for each 
displayed mark the true mark centers. After scanning all marks within 
the current write field the user is asked to confirm the correct 
transformation values. 
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13 Wafermaps 
13.1 Wafermap window 185 

13.2 Mouse Commands 196 

13.3 Interaction with Other Modules 196 

A Wafermap is defined and stored as an ASCII data file, which 
normally is indicated by extension WLO. In case of importing defect 
data by using the Import window, the Wafermap layouts are 
automatically constructed from the imported data file and stored 
within the subdirectory WAFER of the user’s directory. For 
generation of customized Wafermap layouts choose the command File 
> Waferlayout as described below. 

13.1 Wafermap window 
Figure 96: Example 
of a Wafermap 
representing an 8” 
wafer. 

Use one of the following ways to open a Wafermap window: 

• Choose the command File > New Wafermap. In this case an 
empty Wafermap is displayed. This map can be modified using 
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the command File > Waferlayout or replaced by an existing 
Wafermap using the command File > Open. 

• Choose the command File > Open Wafermap. In this case an 
existing Wafermap will be loaded and displayed. Also this 
Wafermap can be modified or replaced by another one. 

The elements of the Wafermap window are (see figure): 

Title Bar The title bar shows the name of the loaded Wafermap. 

Scale The scale serves to indicate the size of your sample, graphically. 

Limits As an overlay the software limits can be graphically indicated. Use the 
command Module status > Wafermap > Show limits to enable this 
feature. 

Icon bar If a Wafermap window is activated, additional symbols, menus and 
menu items are available within the menu bar which will be explained 
in detail in the following sections. 

13.1.1 File Menu 
Open Choose this command to load an existing Wafermap layout. This 

command replaces the actually activated layout by the newly selected 
one. 

Save Choose this command to save the activated Wafermap layout under its 
current name. 

Save as Choose this command to save the activated Wafermap layout under a 
freely selectable name. 

Link positionlist Choose this command to open a Positionlist and link it to the activated 
Wafermap. This relation between Wafermap and Positionlist is 
necessary to make use of the defect overlay feature which is not used 
in standard lithography applications. 

Open chipmap Choose this command or choose the symbol button  or double-
click on a chip within the Wafermap to open the related Chipmap 
window. 

Waferlayout Choose this command to open a dialog for editing the currently 
opened Wafermap meeting your application. A dialog is preset with 
parameters taken from the activated Wafermap window. Editing is 
described in the following section in section  Defining wafer layouts. 
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Defining wafer layouts 

Figure 97: Dialog to 
for editing a 
Wafermap. 

 

Filename: Enter a suitable name for your Wafermap layout file. The 
extension WLO will be added automatically. The file will be stored in 
the subdirectory WAFER of the user’s directory. 

On the Wafer tap the following controls can be used. 

Shape: Select an elliptical or a rectangular layout shape from this 
drop-down list box. 

Rest. Area: Enter the width of the restriction area, i.e. the thickness of 
a margin restricting the chip area. Chips which are partly or 
completely located inside the restriction area are not drawn in the 
Wafermap layout, but they may be counted in the chip numbering 
sequence. 

Size U/V: Enter the outer diameter of your wafer in U and in V 
direction. 

Origin U/V: Enter the origin of the U/V (sample) coordinate system, 
i.e. the distance of the U/V origin from the lower left corner of a 
square enclosing the wafer layout. Typical values are either "0 / 0", 
i.e. U/V origin is lower left, or "Radius / Radius", i.e. U/V origin is 
wafer center. Set the origin according to the conventions you are using 
for the general sample (U/V) coordinate system. 

Type: Use this drop-down list box to select one of the following 
orientation markers: Major Flat, Square or Notch. 

Position: Use this drop-down list to select one of the following 
locations of the orientation marker: Top, Right, Bottom or Left. 

Size: Enter the size of the orientation marker. 

Frame: Select the color wafer's border. 
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Fill: Select the fill color. 

Text: Select the text color. 

Image File: Enter the file name of an optional background image. 

Size U/V: Enter the size of the image. Select Full wafer size to stretch 
the image to the Wafermap. 

Offset U/V: Enter the position of the image in the Wafermap. Choose 
 to select the anchor point. 

On the Chip tab the following parameters are available. 

Size U/V: Enter the chip size with U = width and V = height. 

Distance U/V: Enter the horizontal (U) distance and the vertical (V) 
distance between two adjacent chips. 

Offset U/V: Enter the distance between the lower left corner of the 
center chip and the U/V origin of the wafer. 

Count origin U/V: Use these drop-down list boxes to select the 
starting point of the chip numbering scheme, i.e. to determine the chip 
counting direction. To increase chip numbers from left to right use 
Left and vice versa. To increase chip numbers from bottom to top 
choose Bottom and vice versa. The numbering scheme can be 

displayed by choosing the  symbol button. 

Count offset U/V: Enter the start number for the chip numbering 
scheme in U direction resp. in V direction. These text boxes are 
accessible for the numbering manners U/V and V/U, only 

Label : Use this drop-down list to select the manner of chip 
numbering. U/V first matrix coordinate U, V/U first matrix coordinate 
V, Number single number. 

Count offset: Enter the start number for the chip numbering scheme. 
This start number is valid for both matrix directions (U/V). This text 
box is accessible for the numbering manner Number, only. 

Count type U/V: Use this drop-down list to select between different 
alphanumerical numbering manners. 

Count: Use this drop-down list to select the manner of chip counting. 
Chips: The chips which are not completely located inside the chip 
area are not counted in the chip sequence. Matrix: The chips which 
are not completely located inside the chip area are counted in the chip 
sequence. 

Chip layout: Use this text box to assign an existing chip layout file to 
the Wafermap layout. The specified chip layout file must be available 
in the subdirectory CHIP within the user’s directory. It is used to 
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overlay a substructure on the Chipmap. If no chip layout is available 
or required leave this text box free. 

Database File: Choose the GDSII database which is associated to the 
wafer and overlaid in each chip. 

Structure Name: Choose the structure within the GDSII database. 

Design Origin: Use this drop-down list to select the entry point for 
the overlay. 

Offset U/V: If the origin requires an offset, use these fields to define 
it. 

To modify the waferlayout on-line on a chipwise base, point to the 
chip of interest, press and hold the Shift key and click the left mouse 
button. This operation opens the Edit Wafer Element dialog for the 
selected chip which can be used to modify chip representations or to 
delete the complete chips from the wafer. 

Figure 98: Dialog for 
editing the properties 
of a selected chip. 

 

Select the element Type from the drop-down list box. Available types 
are ELLIPSE, BOX, CHIP, TEXT. The Text field is used only for 
the elements CHIP and TEXT but is ignored for ELLIPSE and 
BOX. 

Select Frame color, Fill color and Text color for the specified 
element from the related drop-down list boxes. For the element 
TEXT, fill color and text color are ignored, but the frame color is 
used instead. For the element CHIP, frame color and fill color are 
ignored, but the color coding defined by the command Chip Colors is 
used instead. 

Enter the coordinates of the lower left corner (U1, V1) and the 
coordinates of the upper right corner (U2, V2) of the specified element 
within the related text boxes. 
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Choose Delete to delete the specified element completely from the 
wafer layout. 

 

The element will be deleted at once without further query. An undo 
function is not implemented. 

13.1.2 Edit Menu 
Delete Choose this command to delete the selected chips. 

Preadjustment Choose this command or choose the icon  to set up an open the 
Automatic Adjustment dialog showing information about the 
transformation parameters. Choose the OK button to perform the 
preadjustment. These values are stored together with the Wafermap 
file and are imported when the corresponding file is opened. 

Unpatterned wafer adjustment The adjustment procedure for an unpatterned or blank 
wafer requires a different approach compared to that for other 
samples, as in this case there are no easy to recognize regular 
structures for which the sample coordinates are known. To overcome 
this disadvantage, the adjustment procedure determines the center of 
the wafer and its angular orientation by using its perimeter and its flat 
or notch. It requires no additional input information such as precise 
wafer size or a set of known coordinates. 
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Figure 99: Dialog to 
perform 
preadjustment 
procedure. 

 

The corresponding dialog offers a toolbox and calculator for the 
alignment routine. In parallel, there is an overlay displayed on the 
Wafermap which indicates the selected sites within the alignment 
procedure. 



13 Wafermaps 

192 

Figure 100: 
Visualization of 
preadjustment 
procedure within 
Wafermap.  

The dialog box has the following functionality: 

Wafer: This section displays information already available to the 
program from the import of the Wafermap, such as wafer diameter 
and wafer center in UV coordinates. 

Perimeter Marks: This section is the interactive part which allows 
also configuring the marks to be used for alignment. Three perimeter 
marks have to be set and used for determining the exact center of the 
wafer. The ideal locations of the marks are displayed in parallel on the 
Wafermap as "P#1 – P#3". Each of these marks can be assigned with a 
dedicated angular position or all marks together can be rotated 
stepwise on the Wafermap, if the default settings are not suitable for 
the instrument or application. Use Goto followed by the Read buttons 
(or the blue flags for reading coordinate data from UV windows) to 
read current stage position when at the corresponding mark at the 
perimeter. 

 

The procedure of determining the wafer center has to be completed 
before the angular orientation can be measured within the section 
Deskew Marks. 

Deskew Marks: This section allows measuring the angular orientation 
of a blank wafer by aligning to the wafer notch or flat. From the 
information in the Wafermap, the program automatically determines 
whether the wafer has a flat or a notch. The procedure differs for these 
two cases. In the case of a flat, two marks are used, which are along 
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the flat of the wafer. In the case of a notch, only one mark is used. For 
both case, only the angular orientation is calculated. Use the Goto 
buttons followed by the Read buttons (or the blue flags for reading 
coordinate data from UV windows) to read current stage position 
when at the corresponding mark at flat or notch. 

Results: In this section the results of the adjustment actions are 
displayed. 

The results of the alignment procedure become active after choosing 
the Adjust button. The button can only be applied, if a complete set of 
angular and lateral wafer alignment steps has been performed. 

As results, the UV offset value of the wafer center and the calculated 
rotation is displayed. 

The individual adjustment steps can be repeated and changed 
independent form each other. 

Choose Clear to reset the coordinate transformation back to the 
identity transformation. 

Performing an adjustment routine 

STEP 1 ► Open the Wafermap and apply the preadjustment routine. 

STEP 2 ► Get access to the unpatterned wafer alignment window by choosing 
the command Edit > Unpatterned wafer adjustment. 

STEP 3 ► Set the 3 perimeter marks into those locations which can be easily 
accessed by your wafer stage. For this, you can vary the individual 
angular locations of the marks and the angle of the set commonly. 

Begin with the adjustment of the exact wafer center by using the 
perimeter marks. 

STEP 4 ► Choose for mark #1 the Goto button, and the stage will automatically 
move close to the wafer boundary under the specified angular 
orientation. 

STEP 5 ► After the stage has reached its destination, move the stage manually in 
such a way that you can see the wafer boundary crossing the center of 
your SEM screen displaying e.g. an SE image. For this it is not 
important that you keep or take care on the angular orientation. If 
necessary, perform a backlash operation and readjust. Then choose the 
Read button. 

STEP 6 ► Alternatively, if a image is available, use the Blue Flag and drag it 
onto the wafer boundary within the image. The first check box gets a 
tick mark, which means that this mark has been processed. 

STEP 7 ► Repeat these steps for mark #2 and #3. 
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Now perform the deskew procedure which is explained here for a 
wafer flat. 

STEP 8 ► Choose the Goto button of deskew mark #1. The stage will move to 
that location based on the current adjustment. 

STEP 9 ► After the stage has reached its destination, move the stage manually in 
such a way that you can see the wafer boundary crossing the center of 
your SEM screen displaying e.g. an SE image. For this it is not 
important that you keep or take care on the exact position along the 
flat. If necessary, perform a backlash operation and readjust. Then 
choose the Read button. 

STEP 10 ► Alternatively, if an image is available, use the Blue Flag and drag it 
onto the wafer boundary within the Image. The first check box gets a 
tick mark, which means that this mark has been processed. 

STEP 11 ► Repeat these steps for deskew mark #2. 

STEP 12 ► Choose the Adjust to apply this new UV-Adjustment. 

Please note that after this adjustment procedure the particles should be 
in reach of the stage. In some cases, a 3 point alignment at found 
particles or a post-alignment can be useful to improve accuracy and 
speed of the review procedure. However, this depends strongly on the 
precision of both: the stage and the defect inspection tool, delivering 
the coordinate set (Positionlist). 

Adjustment Command common to all UV windows, described in section  UV 
Windows. Please note the resulting mark location depends on the 
actual catch status. 

Measure Command common to all UV windows, described in section  UV 
Windows. 

13.1.3 View menu 

Chip text Choose this command or icon  to display the chip labeling.  

Defect marker Choose this command or icon  to display the defect positions. 

Redraw Choose this command to refresh the graphical representation of the 
Wafermap due to layout changes. 

Zoom Command common to all UV windows, described in section  UV 
Windows. 

Overlay Command common to all UV windows, described in section  UV 
Windows. 

Toolbox Command common to all UV windows, described in section  UV 
Windows. 
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13.1.4 Options menu 
Catch mode The catch mode defines how a location within a chip is addressed, for 

example when a chip is the target for a drag-and-drop action. Three 
different modes exist: None, Offset and Position. If the catch status is 
None, the exact pointer position is used for UV addressing. If the 
catch status is Offset, the Chip Catch Offset setting with the chip is 
used. Choose the command Chip Catch Offset to define this offset. If 
the catch status Position, the existing position located nearest to the 
mouse pointer is used. The Catch mode status is displayed also the the 

following icons:  for None,  for Offset and  for Position. 
The icons can also be used to toggle between the modes. The Chip 

Catch Offset can also be defined using the  icon. 

Figure 101: Dialog to 
define the catch offset 
for each chip. 

 

Chip colors Some chips containing one or more positions from an associated 
Positionlist can be color coded and thus give an overview in which 
chips are which kinds of defects. 

 

A Positionlist must be opened and linked to the Wafermap. Otherwise 
this command is not possible. 

Choose this command or choose the symbol button  to modify the 
assignment of the chip color coding within the Wafermap layout to the 
defect attributes in the related Positionlist. 

Figure 102: Dialog to 
define the color 
coding for each chip 
depending on the 
Position it contains. 
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On the left hand side, the Chip colors list box shows the current 
assignment for all attributes of the associated Positionlist. Select the 
current color assignment to be modified within that list box. Then 
select the new color to be assigned and choose Accept. In addition, 
you may enter a description of the attribute. 

Same aspect ratio Command common to all UV windows, described in section  UV 
Windows. 

Cursor grid Command common to all UV windows, described in section  UV 
Windows. 

UV Display … Command common to all UV windows, described in section  UV 
Windows. 

13.2 Mouse Commands 
The table below gives a summary of all available mouse commands 
within an activated Wafermap window. 

Table 33: Mouse 
commands in 
Wafermap window. 

Action Key(s) + Mouse 
Button Functionality 

Single 
click Shift + left Opens Edit Wafer Element dialog.

Single 
click none + right Drives the stage to the selected 

position. 
Double 
click none + left Opens the related Chipmap 

window. 
Wheel 
mouse none Zoom in and out of Wafermap. 

13.3 Interaction with Other Modules 
A summary of drag and drop operations involving a Wafermap is 
listed below. 
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Table 34: Wafermap 
drag and drop 
functionality. 

Source Object Target Action 

GDSII 
Database Structure 

Wafermap 
with 
associated 
Positionlist 

GDSII structure is placed in 
Wafermap and stored in 
Positionlist. 

Positionli
st Position 

Wafermap 
with 
associated 
Positionlist 

Redefines location of object. 

Scan 
Manager 

Scan 
Definitio
n 

Wafermap 
with 
associated 
Positionlist 

Scan task is placed in 
Wafermap and stored in 
Positionlist. 

Automati
on 

Script or 
Macro 

Wafermap 
with 
associated 
Positionlist 

Macro file is placed in 
Wafermap and stored in 
Positionlist. 
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14 Chipmaps 
14.1 Chipmap window 199 

14.2 Mouse Commands 201 

The Wafermap representation and addressing is very convenient on a 
large scale wafer level. For more precise addressing inside a chip, use 
the Chipmap representation which contains a zoomed chip from a 
Wafermap. 

14.1 Chipmap window 
First activate a Wafermap window, and then use one of the following 
ways to open a Chipmap window: 

• Choose the command File > Open Chipmap and select the chip 
of interest within the appearing dialog box. 

• Double-click on the chip of interest. 

Figure 103: Example 
Chipmap with same 
defects. 

 

The elements of a Chipmap window are. 

Title Bar The title bar shows the name of the related Positionlist and the number 
of the chip within the related Wafermap. 

Position Cursor The position cursor graphically indicates the actual location of the 
electron beam on the sample. In addition, the global wafer 
coordinates, the local chip coordinates and the stage coordinates XY 
of the current location are displayed within the status bar. 
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Scale The scale bars indicate the size of the sample. 

Defects The defects are graphically indicated by colored rectangles, circles or 
crosses. 

If a Chipmap window is activated, additional menus, menu items and 
symbols are available within the Program Desktop which will be 
explained in detail in the following. 

14.1.1 File menu 
Open … Choose this command to load a chip layout file to be overlaid within 

the Chipmap window. Chip layout files (extension CLO) are 
commonly used to define a Bitmap design. 

14.1.2 Edit menu 
Cell navigator This command is only available, if a chip layout file was selected. 

Choose this command or use the hot keys Ctrl + n to open the 
memory cell navigator dialog box. After finishing navigation work, 
use the Esc key to close this dialog box.  

 

The cell navigator allows entering drive commands digitally on the bit 
line and word line level, similar to the handling of the Stage Control. 

The following commands are available: 

Table 35: Commands 
available within Cell 
navigator dialog. 

Command Functionality Example 

<n>B Relative drive 
command over 
<n> bit lines. 

-1B Moves 1 bit line down. 

<n>b Absolute drive 
command to bit 
line <n>. 

120b Moves to bit line 
number 120. 

<n>W Relative drive 
command over 
<n> word lines. 

4W Moves 4 word lines 
up. 

<n>w Absolute drive 
command to word 
line <n>. 

8191w Moves to word line 
number 8191. 

The small button on the right hand side of the text box allows 
repeating the last command. 
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Adjustment Command common to all UV windows, described in section  UV 
Windows. 

Measure Command common to all UV windows, described in section  UV 
Windows. 

14.1.3 View menu 
Chip layout level Choose this command to change the hierarchy level of the displayed 

Chip layout by one step upwards or one step downwards: from array 

to segment to block to quadrant. Alternatively, use the icons  . 

Redraw Command common to all UV windows, described in section  UV 
Windows. 

Zoom Command common to all UV windows, described in section  UV 
Windows. 

Overlays Command common to all UV windows, described in section  UV 
Windows. 

Toolbox Command common to all UV windows, described in section  UV 
Windows. 

14.1.4 Options menu 
Catch Mode Command described in section  Wafermaps. Alternatively, use icons 

   . 

Defect Marker Command described in section  Wafermaps. Alternatively, use icon 

. 

Same aspect ratio Command common to all UV windows, described in section  UV 
Windows. 

UV Display… Command common to all UV windows, described in section  UV 
Windows. 

14.2 Mouse Commands 
The table below gives a summary of all available mouse commands 
within an activated Chipmap window. 
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Table 36: Mouse 
commands in 
Chipmap window. 

Action Key(s) + Mouse 
Button 

Functionality 

Single 
click 

Control + right Drives the stage to the selected 
position. 

Double 
click 

none + left Opens "Edit Position" dialog 
box for the defect located near 
to the selected position. 
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